ISP Configuration

If I reset everything, set only some parameter id, pw , atm, etc. The router takes my dsl line configuration. But handshake not happens.
ISP TurkNET
My isp suggest this configuration
https://turk.net/cms/assets/selfcare/_resampled/ResizedImageWzU4NSwzOTld/zte-setup-image067.png

cat /etc/config/network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdf1:81cd:ed24::/48'

config atm-bridge 'atm'
	option encaps 'llc'
	option nameprefix 'dsl'
	option vpi '8'
	option vci '35'
	option payload 'routed'

config dsl 'dsl'
	option annex 'a'
	option tone 'av'
	option ds_snr_offset '0'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option ifname 'dsl0'
	option proto 'pppoe'
	option username '*********adsl@turk.net'
	option password 'e******3'
	option ipv6 'auto'
        option mtu '1492'

config device 'wan_dsl0_dev'
	option name 'dsl0'
	option macaddr 'ec:08:6b:9f:36:42'

config interface 'wan6'
	option ifname '@wan'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 2 4 5 6t'


and then vaaaala but handshake doesn't achieve

DSL Status
Line State: UP [0x0]
Line Mode: G.993.2 (VDSL2)
Line Uptime: 23m 18s
Annex: B
Profile: 17a
Data Rate: 35.833 Mb/s / 3.072 Mb/s
Max. Attainable Data Rate (ATTNDR): 37.515 Mb/s / 3.656 Mb/s
Latency: 0.0 ms / 0.0 ms
Line Attenuation (LATN): 16.8 dB / 24.1 dB
Signal Attenuation (SATN): 16.5 dB / 23.8 dB
Noise Margin (SNR): 8.8 dB / 9.8 dB
Aggregate Transmit Power (ACTATP): 5.7 dB / 14.0 dB
Forward Error Correction Seconds (FECS): 0 / 0
Errored seconds (ES): 5 / 3327
Severely Errored Seconds (SES): 0 / 1344
Loss of Signal Seconds (LOSS): 0 / 1340
Unavailable Seconds (UAS): 183 / 183
Header Error Code Errors (HEC): 0 / 0
Non Pre-emptive CRC errors (CRC_P): 0 / 0
Pre-emptive CRC errors (CRCP_P): 0 / 0
ATU-C System Vendor ID: Ikanos 0.1
Power Management Mode: L0 - Synchronized

I tried another setting similar to my situation the same ISP.

I reedited my setting like the above message. But I couldn't connect. Could you help me? @vahithosan how managed internet configuration with this setting? Could you share the actual setting?


Here my config file. what is wrong with this setting. I did the same as yours

cat /etc/config/network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd3a:de34:9e62::/48'

config atm-bridge 'atm'
	option encaps 'llc'
	option nameprefix 'dsl'
	option vci '35'
	option vpi '8'
	option payload 'routed'

config dsl 'dsl'
	option ds_snr_offset '0'
	option annex 'b'
	option xfer_mode 'ptm'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	list dns '208.67.222.222'
	list dns '208.67.222.220'

config interface 'wan'
	option proto 'pppoe'
	option password '******25a3'
	option username '********50adsl@turk.net'
	option ipv6 'auto'
	option ifname 'ptm0.35'

config device 'wan_dsl0_dev'
	option name 'dsl0'
	option macaddr 'ec:08:6b:9f:36:42'

config interface 'wan6'
	option ifname '@wan'
	option proto 'dhcpv6'
	option reqaddress 'try'
	option reqprefix 'auto'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 2 4 5 6t'

The modem could receive information normally. with this situation I could not manage to meet my ISP.
After @vahithosan configuration, DSL values are completely lost

DSL Status
Line State: DOWN [0x0]
Line Mode: -
Line Uptime: down
Annex: -
Profile: -
Data Rate: 0 b/s / 0 b/s
Max. Attainable Data Rate (ATTNDR): 0 b/s / 0 b/s
Latency: 0.0 ms / 0.0 ms
Line Attenuation (LATN): 0.0 dB / 0.0 dB
Signal Attenuation (SATN): 0.0 dB / 0.0 dB
Noise Margin (SNR): 0.0 dB / 0.0 dB
Aggregate Transmit Power (ACTATP): 0.0 dB / 0.0 dB
Forward Error Correction Seconds (FECS): 0 / 0
Errored seconds (ES): 0 / 0
Severely Errored Seconds (SES): 0 / 0
Loss of Signal Seconds (LOSS): 0 / 0
Unavailable Seconds (UAS): 0 / 0
Header Error Code Errors (HEC): 0 / 0
Non Pre-emptive CRC errors (CRC_P): 0 / 0
Pre-emptive CRC errors (CRCP_P): 0 / 0
ATU-C System Vendor ID:
Power Management Mode: L3 - No power

The Turk.net URL you provided does not work (for me).

In your original config, you have not set the VLAN ID.

config interface 'wan'
	option ifname 'dsl0.35'       #Turk.net for OpenWrt 18 or later.
#       option ifname 'ptm0.35'       #Turk.net for LEDE 17.

This Turk.net page I googled quotes VLAN ID 35 is required.
https://turk.net/destek/nasil-yaparim/internet-baglantimla-ilgili-sorunlari-nasil-cozebilirim/modemimi-nasil-kurarim/adsl-ve-vdsl-modem-kurulum-degerleri.html

fyi:
https://openwrt.org/docs/guide-user/network/wan/isp-configurations

Thank u so much.
I tried few times ptm0.35 but not worked but your recommendation worked immediatelly
dsl0.35 worked.

cat /etc/config/network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdf1:81cd:ed24::/48'

config atm-bridge 'atm'
	option encaps 'llc'
	option nameprefix 'dsl'
	option vpi '8'
	option vci '35'
	option payload 'routed'

config dsl 'dsl'
	option annex 'a'
	option ds_snr_offset '0'
	option xfer_mode 'ptm'
	option line_mode 'vdsl'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option proto 'pppoe'
	option username '***************@turk.net'
	option password '****'
	option ipv6 'auto'
	option mtu '1492'
	option ifname 'dsl0.35'

config device 'wan_dsl0_dev'
	option name 'dsl0'
	option macaddr 'ec:08:6b:9f:36:42'

config interface 'wan6'
	option ifname '@wan'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 2 4 5 6t'

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.