The current configuration on WAN is like this.
config interface 'wan'
option type 'bridge'
option ifname 'eth0.1'
option macaddr '50:42:d3:99:c5:ff'
option mtu '1500'
option vlanid '1'
option reqopts '43'
option proto 'dhcp'
option igmp_snooping '0'
option metric '0'config interface 'wan_v6'
option ifname '@wan'
option proto 'dhcpv6'
option metric '1'
If I want to separate the IPv4 and IPv6 configurations, I need to enable the 'CONFIG_BRIDGE_VLAN_FILTER' in the kernel, and then configure it like this.
config device 'dev'
option name 'br0'
option type 'bridge'
list ports 'eth0'config device 'dev_wan'
option ifname 'br0'
option type '8021q'
option macaddr '50:42:d3:99:c5:ff'
option mtu '1500'
option device 'br-wan'
option vid '1'config interface 'wan'
option device 'br-wan'
option proto 'dhcp'
option metric '0'
option vlanid '1'
option metric '0'
option reqopts '43'
option igmp_snooping '0'
option special_line '0'config interface 'wan_v6'
option device 'br-wan'
option proto 'dhcpv6'
option metric '1'
option vlanid '1'