Hello,
First of all, big thank you to the OpenWRT community for helping clueless people like me with their network woes.
I'm using an Edgerouter-X with openwrt 19.07 and my config was working fine since I set it up about 3 years ago as initially mentioned in this thread Routing all external traffic from one specific machine to a particular WAN interface
However, I'm not sure why or when it happened but ipv6 stopped working. I never noticed it because my connection is using a 4over6 MAP-E tunnel (similar to the one mentioned in this thread A guide for Japan NTT users on IPoE/IPv6 setting (MAP-E only)) so connectivity was never lost: I'm just connected over v4.
The weird thing is that the router itself seems to have a proper v6 address, the 4over6 connection works and all my devices can access internet using that connection. However, trying to ping any v6 address straight from the router (ping6 google.com, ping ipv6.google.com etc) fails. I also tried to revert the config to a previous backup but still no dice.
Another symptom was that my main machine (Windows 10) would only get a link-local ipv6 address and testing with https://test-ipv6.com/ would also fail (when it used to be working just fine). For this particular issue, I had to change a setting in the router as mentioned here and my machine can now get a proper v6 address. What prompted the need for such a change, I have no clue. However it still cannot access using the v6 connection (probably because the router itself cannot either?).
My config files have remained largely unchanged from the first thread linked above (except for the bit about router advertisement and slaac) but I've pasted the latest version below again just in case.
Before I start updating my router to the latest version and try to fix it with the changes from the second thread (the authors confirmed it working as of last month, so it could possibly fix mine too) I would like to try to fix/stabilize my setup first, make another backup and then try updating.
Any help greatly appreciated
/etc/config/network
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'xxxxx'
config interface 'lan'
option type 'bridge'
option ifname 'eth0.1'
option proto 'static'
option ip6assign '60'
option ipaddr '192.168.0.1'
option netmask '255.255.255.0'
list dns '192.168.0.48'
config device 'lan_eth0_1_dev'
option name 'eth0.1'
option macaddr 'xxxxxx'
config interface 'wan'
option ifname 'eth0.2'
option proto 'pppoe'
option password 'xxxxx'
option username 'xxxxx'
option mtu '1454'
option peerdns '0'
option ipv6 '0'
option delegate '0'
option ip4table '100'
option ip6table '100'
config device 'wan_eth0_2_dev'
option name 'eth0.2'
option macaddr 'xxxxx'
config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'
config switch_vlan
option device 'switch0'
option vlan '1'
option ports '1 2 3 4 6t'
config switch_vlan
option device 'switch0'
option vlan '2'
option ports '0 6t'
config interface 'wan6'
option ifname 'eth0.2'
option proto 'dhcpv6'
option reqaddress 'try'
option peerdns '0'
list ip6prefix 'xxxxx/56'
option reqprefix 'auto'
config interface 'wan6_map'
option proto 'map'
option type 'map-e'
option tunlink 'wan6'
option peeraddr 'xxxxx'
option ipaddr 'xxxxx'
option ip4prefixlen '15'
option ip6prefix 'xxxxx'
option ip6prefixlen '31'
option ealen '25'
option psidlen '8'
option offset '4'
option encaplimit 'ignore'
config rule 'lan_lan'
option in 'lan'
option dest '192.168.0.0/24'
option lookup 'main'
config rule 'lan_wan'
option in 'lan'
option src '192.168.0.199/32'
option lookup '100'
/etc/config/dhcp
config dnsmasq
option localise_queries '1'
option local '/lan/'
option domain 'lan'
option expandhosts '1'
option authoritative '1'
option readethers '1'
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.auto'
option localservice '1'
option rebind_protection '0'
option domainneeded '1'
option nonegcache '1'
option dnssec '1'
option dnsseccheckunsigned '1'
list server '208.67.222.222'
list server '208.67.220.220'
list server '8.8.8.8'
list server '8.8.4.4'
config dhcp 'lan'
option interface 'lan'
option start '100'
option limit '150'
option leasetime '12h'
option ndp 'relay'
list dhcp_option '6,192.168.0.48'
option ra 'server'
option ra_slaac '1'
option ra_flags 'none'
config dhcp 'wan6'
option dhcpv6 'relay'
option ra 'relay'
option ndp 'relay'
option master '1'
option interface 'wan6'
option start '100'
option leasetime '12h'
option limit '150'
config dhcp 'wan'
option interface 'wan'
option ignore '1'
config odhcpd 'odhcpd'
option maindhcp '0'
option leasefile '/tmp/hosts/odhcpd'
option leasetrigger '/usr/sbin/odhcpd-update'
option loglevel '4'