IPv6 issue with OpenWrt

Hi there.
My ISP provide me an /60 prefix and I can see IPv6-PD in wan6's information.
image

At first I could see the /60 IPv6-PD in lan area, and everything went well.
Yesterday I tried to increase a new lan_2 interface which in another vlan (vlan id 3)
And I 've tried to make both of the lan interface has a IPv6 PD poll.
Then I edit the interface and set the IPv6-assignment to 61.
But both of the interface just show an /61 IP address, no PD.
Then I recover the setting but the IPv6-PD didn't show again in my lan interface, After I deleted the lan_2 interface, it's still only a single IPv6 address without PD in my lan interface.
image
And even if I reinstall the openwrt or chage a diffirent openwrt router, nothing changed here.
(I can ping with the ipv6 address outside, both direction is OK. But the test-ipv6.com returns me a faliur info)

maybe someone can assist better, if you post the OpenWRT network config file formatted according to How to format logs, scripts, configs and general console output

The part where I can help here a little: do not assume, that prefix delegation through OpenWRT is autocomfig-based or that it selects a working subnet automatically or that it is able to pick the optimum on itself. I once tried PD and got the impression that I have to manually try different prefixes and it can end lots of manual trying different prefix lengths on WAN and LAN side. And any prefix setting „AUTO“ value more like means „default“ (I cant remember, what default value that would be)

Thanks for replying.
Here is my network configure file

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'

config interface 'wan'
	option proto 'pppoe'
	option username '****'
	option password '****'
	option device 'eth1.2'
	option metric '0'
	option ipv6 'auto'
	option delegate '0'

config interface 'wan_50'
	option proto 'pppoe'
	option username '****'
	option password '****'
	option ipv6 'auto'
	option metric '2'
	option device 'eth2.3'
	option delegate '0'

config interface 'wan_cmcc'
	option proto 'pppoe'
	option username '***'
	option password '***'
	option metric '1'
	option device 'eth1.400'
	option ipv6 '1'

config interface 'wan_cmcc_6'
	option proto 'dhcpv6'
	option device '@wan_cmcc'
	option reqaddress 'try'
	option reqprefix 'auto'

config interface 'lan'
	option proto 'static'
	option device 'eth0'
	option ipaddr '192.168.10.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

and here the dhcp config file


config dnsmasq
	option domainneeded '1'
	option localise_queries '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option localservice '1'
	option ednspacket_max '1232'
	option filter_aaaa '0'
	option quietdhcp '1'
	option authoritative '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option cachesize '0'

config dhcp 'lan'
	option interface 'lan'
	option leasetime '30m'
	option dhcpv4 'server'
	option start '11'
	option limit '100'
	list dhcp_option '6,192.168.10.1'
	option ra 'server'
	list ra_flags 'none'
	option dhcpv6 'server'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

uci add_list dhcp.lan.ra_flags='managed-config'
uci add_list dhcp.lan.ra_flags='other-config'
uci commit
service odhcpd restart

Nope
It could only make me have the third address on my device
No PD shows in LAN and can't pass any ipv6 test

Please run the following commands (copy-paste the whole block) and paste the output here, using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have

ubus call system board; \
uci export network; \
uci export dhcp; uci export firewall; \
head -n -0 /etc/firewall.user; \
ip -6 addr ; ip -6 ro li tab all ; ip -6 ru; \
ifstatus wan_cmcc_6; ifstatus lan
{
	"kernel": "5.4.143",
	"hostname": "OpenWrt",
	"system": "Intel Core Processor (Skylake, IBRS)",
	"model": "QEMU Standard PC (i440FX + PIIX, 1996)",
	"board_name": "qemu-standard-pc-i440fx-piix-1996",
	"release": {
		"distribution": "OpenWrt",
		"version": "21.02.0",
		"revision": "r16279-5cc0535800",
		"target": "x86/64",
		"description": "OpenWrt 21.02.0 r16279-5cc0535800"
	}
}
package network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'

config interface 'wan'
	option proto 'pppoe'
	option username '****'
	option password '****'
	option device 'eth1.2'
	option metric '0'
	option ipv6 'auto'
	option delegate '0'

config interface 'wan_50'
	option proto 'pppoe'
	option username '****'
	option password '****'
	option ipv6 'auto'
	option metric '2'
	option device 'eth2.3'
	option delegate '0'

config interface 'wan_cmcc'
	option proto 'pppoe'
	option username '****'
	option password '****'
	option metric '1'
	option device 'eth1.400'
	option ipv6 '1'

config interface 'wan_cmcc_6'
	option proto 'dhcpv6'
	option device '@wan_cmcc'
	option reqaddress 'try'
	option reqprefix 'auto'

config interface 'ott-tv'
	option proto 'dhcp'
	option hostname 'android-e*****'
	option sendopts '0x3c:000***********2'
	option metric '30'
	option delegate '0'
	option auto '0'
	option device 'eth2.431'

config interface 'lan'
	option proto 'static'
	option device 'eth0'
	option ipaddr '192.168.10.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

package dhcp

config dnsmasq
	option domainneeded '1'
	option localise_queries '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option localservice '1'
	option ednspacket_max '1232'
	option filter_aaaa '0'
	option quietdhcp '1'
	option authoritative '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option port '5353'
	option cachesize '0'

config dhcp 'lan'
	option interface 'lan'
	option leasetime '30m'
	option dhcpv4 'server'
	option start '11'
	option limit '100'
	list dhcp_option '6,192.168.10.1'
	option ra_dns '0'
	option dhcpv6_pd '1'
	option ra 'server'
	option dhcpv6 'server'
	option dns_service '0'
	list ra_flags 'none'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '1'

config host
	option dns '1'
	option ip '192.168.10.254'
	option leasetime '12h'
	option name 'RE350'
	option mac '******'

config host
	option name 'EX6150'
	option dns '1'
	option mac '******'
	option ip '192.168.10.253'
	option leasetime '12h'

config host
	option dns '1'
	option ip '192.168.10.252'
	option leasetime '12h'
	option mac '******'
	option name 'EX6150v2'

config host
	option dns '1'
	option ip '192.168.10.251'
	option leasetime '12h'
	option name 'R7500v2'
	option mac '******'

config host
	option dns '1'
	option leasetime '12h'
	option ip '192.168.10.250'
	option name 'EA8500'
	option mac '******'

config host
	option dns '1'
	option name 'CS-X5S-4W'
	option mac '84:9A:40:07:1A:58'
	option ip '192.168.10.249'
	option leasetime '15m'

package firewall

config defaults
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option synflood_protect '1'

config zone
	option name 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	list network 'lan'

config zone
	option name 'wan'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'
	list network 'wan6'
	list network 'wan'
	list network 'wan_50'
	list network 'wan_cmcc'
	list network 'wan_cmcc_6'

config forwarding
	option src 'lan'
	option dest 'wan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option src_ip 'fc00::/6'
	option dest_ip 'fc00::/6'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPSec-ESP'
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option name 'Allow-ISAKMP'
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'

config rule
	option name 'Support-UDP-Traceroute'
	option src 'wan'
	option dest_port '33434:33689'
	option proto 'udp'
	option family 'ipv4'
	option target 'REJECT'
	option enabled '0'

config rule
	option family 'ipv6'
	option src 'wan'
	option target 'ACCEPT'
	option dest 'lan'
	list proto 'tcp'
	option name 'Allow-NAS'
	list dest_ip '::****/::ffff:ffff:ffff:ffff'
	list dest_ip '::****/::ffff:ffff:ffff:fffc'
	option dest_port '****'

config rule
	list proto 'tcp'
	option src 'wan'
	option dest 'lan'
	option target 'ACCEPT'
	option family 'ipv6'
	option name 'Bittorrent'
	option dest_port '****'

config rule
	option family 'ipv6'
	option src 'wan'
	option target 'ACCEPT'
	option dest 'lan'
	list proto 'udp'
	option name 'BitTorrent-UDP'
	option dest_port '****'

config include
	option path '/etc/firewall.user'

config zone
	option name 'tv'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option input 'REJECT'
	list network 'IPTV'
	list network 'iptv'
	list network 'ott'

config include 'fullcone'
	option path '/etc/fullcone.user'
	option reload '1'

config include 'openclash'
	option type 'script'
	option path '/var/etc/openclash.include'
	option reload '1'

config include 'miniupnpd'
	option type 'script'
	option path '/usr/share/miniupnpd/firewall.include'
	option family 'any'
	option reload '1'

# This file is interpreted as shell script.
# Put your custom iptables rules here, they will
# be executed with each firewall (re-)start.

# Internal uci firewall chains are flushed and recreated on reload, so
# put custom rules into the root chains e.g. INPUT or FORWARD or into the
# special user chains, e.g. input_wan_rule or postrouting_lan_rule.
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 state UNKNOWN qlen 1000
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 2409:8a34:****::1/60 scope global dynamic noprefixroute 
       valid_lft 257841sec preferred_lft 171441sec
    inet6 2409:8a34:****::1/64 scope global deprecated dynamic 
       valid_lft 4410sec preferred_lft 0sec
    inet6 fe80::5054:ff:****/64 scope link 
       valid_lft forever preferred_lft forever
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::5054:ff:****/64 scope link 
       valid_lft forever preferred_lft forever
4: eth2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::5054:ff:****/64 scope link 
       valid_lft forever preferred_lft forever
26: eth2.3@eth2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::5054:ff:****/64 scope link 
       valid_lft forever preferred_lft forever
45: eth1.2@eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::5054:ff:****/64 scope link 
       valid_lft forever preferred_lft forever
49: ifb4pppoe-wan: <BROADCAST,NOARP,UP,LOWER_UP> mtu 1500 state UNKNOWN qlen 32
    inet6 fe80::54fb:eff:****/64 scope link 
       valid_lft forever preferred_lft forever
53: utun: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 9000 state UNKNOWN qlen 500
    inet6 fe80::1aba:47ba:****/64 scope link stable-privacy 
       valid_lft forever preferred_lft forever
68: eth1.400@eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::5054:ff:****/64 scope link 
       valid_lft forever preferred_lft forever
69: pppoe-wan_cmcc: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1492 state UNKNOWN qlen 3
    inet6 2409:8a34:********:7472/64 scope global dynamic noprefixroute 
       valid_lft 258508sec preferred_lft 172108sec
    inet6 fe80::2805:3fc6:****/128 scope link 
       valid_lft forever preferred_lft forever
unreachable 2409:8a3*:****:334e::/64 dev lo table 4 proto static metric 2147483647 pref medium
2409:8a3*:****:6fe0::/64 dev eth0 table 4 proto kernel metric 256 pref medium
2409:8a3*:****:a270::/64 dev eth0 table 4 proto static metric 1024 pref medium
unreachable 2409:8a3*:****:a270::/60 dev lo table 4 proto static metric 2147483647 pref medium
fe80::2805:3fc6:**** dev pppoe-wan_cmcc table 4 proto kernel metric 256 pref medium
fe80::ae85:3dff:**** dev pppoe-wan_cmcc table 4 metric 1 pref medium
default via fe80::ae85:3dff:**** dev pppoe-wan_cmcc table 4 proto static metric 512 pref medium
default from 2409:8a3*:****:334e::/64 via fe80::ae85:3dff:**** dev pppoe-wan_cmcc proto static metric 512 pref medium
default from 2409:8a3*:****:a270::/60 via fe80::ae85:3dff:**** dev pppoe-wan_cmcc proto static metric 512 pref medium
unreachable 2409:8a3*:****:334e::/64 dev lo proto static metric 2147483647 pref medium
2409:8a3*:****:6fe0::/64 dev eth0 proto kernel metric 256 expires 4409sec pref medium
2409:8a3*:****:a270::/64 dev eth0 proto static metric 1024 pref medium
unreachable 2409:8a3*:****:a270::/60 dev lo proto static metric 2147483647 pref medium
fe80::2805:3fc6:**** dev pppoe-wan_cmcc proto kernel metric 256 pref medium
fe80::ae85:3dff:**** dev pppoe-wan_cmcc metric 1 pref medium
fe80::/64 dev eth2 proto kernel metric 256 pref medium
fe80::/64 dev eth2.3 proto kernel metric 256 pref medium
fe80::/64 dev eth1 proto kernel metric 256 pref medium
fe80::/64 dev eth1.2 proto kernel metric 256 pref medium
fe80::/64 dev ifb4pppoe-wan proto kernel metric 256 pref medium
fe80::/64 dev eth0 proto kernel metric 256 pref medium
fe80::/64 dev eth1.400 proto kernel metric 256 pref medium
fe80::/64 dev utun proto kernel metric 256 pref medium
local ::1 dev lo table local proto kernel metric 0 pref medium
anycast 2409:8a3*:****:334e:: dev pppoe-wan_cmcc table local proto kernel metric 0 pref medium
local 2409:8a3*:****:334e:2805:3fc6:****:**** dev pppoe-wan_cmcc table local proto kernel metric 0 pref medium
anycast 2409:8a3*:****:6fe0:: dev eth0 table local proto kernel metric 0 pref medium
local 2409:8a3*:****:6fe0::1 dev eth0 table local proto kernel metric 0 pref medium
anycast 2409:8a3*:****:a270:: dev eth0 table local proto kernel metric 0 pref medium
local 2409:8a3*:****:a270::1 dev eth0 table local proto kernel metric 0 pref medium
anycast fe80:: dev eth2 table local proto kernel metric 0 pref medium
anycast fe80:: dev eth2.3 table local proto kernel metric 0 pref medium
anycast fe80:: dev eth1.2 table local proto kernel metric 0 pref medium
anycast fe80:: dev eth1 table local proto kernel metric 0 pref medium
anycast fe80:: dev ifb4pppoe-wan table local proto kernel metric 0 pref medium
anycast fe80:: dev eth0 table local proto kernel metric 0 pref medium
anycast fe80:: dev eth1.400 table local proto kernel metric 0 pref medium
anycast fe80:: dev utun table local proto kernel metric 0 pref medium
local fe80::1aba:47ba:**** dev utun table local proto kernel metric 0 pref medium
local fe80::2805:3fc6:**** dev pppoe-wan_cmcc table local proto kernel metric 0 pref medium
local fe80::5054:ff:**** dev eth0 table local proto kernel metric 0 pref medium
local fe80::5054:ff:**** dev eth1.2 table local proto kernel metric 0 pref medium
local fe80::5054:ff:**** dev eth1 table local proto kernel metric 0 pref medium
local fe80::5054:ff:**** dev eth1.400 table local proto kernel metric 0 pref medium
local fe80::5054:ff:**** dev eth2 table local proto kernel metric 0 pref medium
local fe80::5054:ff:**** dev eth2.3 table local proto kernel metric 0 pref medium
local fe80::54fb:eff:**** dev ifb4pppoe-wan table local proto kernel metric 0 pref medium
multicast ff00::/8 dev eth2 table local proto kernel metric 256 pref medium
multicast ff00::/8 dev eth2.3 table local proto kernel metric 256 pref medium
multicast ff00::/8 dev eth1 table local proto kernel metric 256 pref medium
multicast ff00::/8 dev eth1.2 table local proto kernel metric 256 pref medium
multicast ff00::/8 dev ifb4pppoe-wan table local proto kernel metric 256 pref medium
multicast ff00::/8 dev eth0 table local proto kernel metric 256 pref medium
multicast ff00::/8 dev eth1.400 table local proto kernel metric 256 pref medium
multicast ff00::/8 dev pppoe-wan_cmcc table local proto kernel metric 256 pref medium
multicast ff00::/8 dev utun table local proto kernel metric 256 pref medium
0:	from all lookup local
1004:	from all iif pppoe-wan_cmcc lookup 4
2004:	from all fwmark 0x400/0x3f00 lookup 4
2061:	from all fwmark 0x3d00/0x3f00 blackhole
2062:	from all fwmark 0x3e00/0x3f00 unreachable
3004:	from all fwmark 0x400/0x3f00 unreachable
32766:	from all lookup main
4200000000:	from 2409:8a3*:****:a270::1/60 iif eth0 unreachable
4200000001:	from all iif lo failed_policy
4200000002:	from all iif eth0 failed_policy
4200000028:	from all iif pppoe-wan_50 failed_policy
4200000046:	from all iif pppoe-wan failed_policy
4200000069:	from all iif pppoe-wan_cmcc failed_policy
4200000069:	from all iif pppoe-wan_cmcc failed_policy
{
	"up": true,
	"pending": false,
	"available": true,
	"autostart": true,
	"dynamic": false,
	"uptime": 1360,
	"l3_device": "pppoe-wan_cmcc",
	"proto": "dhcpv6",
	"device": "pppoe-wan_cmcc",
	"metric": 0,
	"dns_metric": 0,
	"delegation": true,
	"ipv4-address": [
		
	],
	"ipv6-address": [
		{
			"address": "2409:8a3*:****:334e:2805:3fc6:3ab3:****",
			"mask": 64,
			"preferred": 172107,
			"valid": 258507
		}
	],
	"ipv6-prefix": [
		{
			"address": "2409:8a3*:****:a270::",
			"mask": 60,
			"preferred": 171440,
			"valid": 257840,
			"class": "wan_cmcc_6",
			"assigned": {
				"lan": {
					"address": "2409:8a3*:****:a270::",
					"mask": 60
				}
			}
		}
	],
	"ipv6-prefix-assignment": [
		
	],
	"route": [
		{
			"target": "::",
			"mask": 0,
			"nexthop": "fe80::ae85:3dff:****:****",
			"metric": 512,
			"valid": 1107,
			"source": "2409:8a3*:****:a270::/60"
		},
		{
			"target": "::",
			"mask": 0,
			"nexthop": "fe80::ae85:3dff:****",
			"metric": 512,
			"valid": 1107,
			"source": "2409:8a3*:****:334e:2805:3fc6:3ab3:7472/64"
		}
	],
	"dns-server": [
		"2409:803*:2000::1",
		"2409:803*:2000::2"
	],
	"dns-search": [
		
	],
	"neighbors": [
		
	],
	"inactive": {
		"ipv4-address": [
			
		],
		"ipv6-address": [
			
		],
		"route": [
			
		],
		"dns-server": [
			
		],
		"dns-search": [
			
		],
		"neighbors": [
			
		]
	},
	"data": {
		"passthru": "001700202409803420000000000000000000000124098034200000000000000000000002"
	}
}
{
	"up": true,
	"pending": false,
	"available": true,
	"autostart": true,
	"dynamic": false,
	"uptime": 20585,
	"l3_device": "eth0",
	"proto": "static",
	"device": "eth0",
	"updated": [
		"addresses"
	],
	"metric": 0,
	"dns_metric": 0,
	"delegation": true,
	"ipv4-address": [
		{
			"address": "192.168.10.1",
			"mask": 24
		}
	],
	"ipv6-address": [
		
	],
	"ipv6-prefix": [
		
	],
	"ipv6-prefix-assignment": [
		{
			"address": "2409:8a3*:****:a270::",
			"mask": 60,
			"preferred": 171440,
			"valid": 257840,
			"local-address": {
				"address": "2409:8a3*:****:a270::1",
				"mask": 60
			}
		}
	],
	"route": [
		
	],
	"dns-server": [
		
	],
	"dns-search": [
		
	],
	"neighbors": [
		
	],
	"inactive": {
		"ipv4-address": [
			
		],
		"ipv6-address": [
			
		],
		"route": [
			
		],
		"dns-server": [
			
		],
		"dns-search": [
			
		],
		"neighbors": [
			
		]
	},
	"data": {
		
	}
}


Do you have downstream routers that will be assigning IPv6 addresses to client machines?

1 Like

You got the /60 assigned to the lan. If you won't use any delegated prefix behind lan, change the prefix assignment to /64 so that both interfaces will get a /64.

This is the only 'router' in my network. Other Openwrt device are all work as wireless AP
Do you means try to connect a router as downsteam and try to get prefix?

No. I was just wondering why you're trying to use prefix delegation on the LAN interfaces. If all you're trying to do is assign IPv6 addresses to attached devices then you should change the prefix assignment value like @trendy has advised above.

I changed prefix to 64
But now It still get problem
I run ping -6 openwrt.org and wget openwrt.org
Seems good, connected IPv6 address and download successfully.
And I can use my mobile cellular to access to my NAS's webpage through IPv6.
But
The testing like test-ipv6.com and ip.sb shows I have no IPv6 address. Test faliure.

I see, a /64 prefix is better.
But I'm wondering why I can see PD in lan interface before and now it disappear.
And I indeed got some issue with IPv6 connection.

All right, I found the faliur of test-ipv6 is due to the fake-ip mode of my clash proxy.
Add it to blacklist and it works now.
The only question I have is why the IPv6-PD disappeared in lan interface. Through I decided to change the prefix to /64

I do not understand what your question is.

My point is
Why the ipv6 address showed on lan interface doesn't has PD character anymore?

Because the LAN interface isn't delegating a prefix for other downstream routers, which is correct for your setup.

If, previously, it was showing a delegated prefix then that setup was wrong.

Why exactly is this continuing to be an issue for you?

1 Like

OK.
Because it is appeard with the IPv6 test faliure, I thought the issue is due to the PD.
But now the IPv6 test works normally, I think there is no issue for me.
Now I'm just curious why PD shows in lan interface for such a long time if it is a wrong set, and does it affect nothing if I have no downstream router?

Could you share a screenshot or a console output to understand better what you mean?
By default a /64 is the standard length for an interface and it is more than enough. If you cascade routers one after another, then you'd need to delegate a prefix to them and in that case you'd need to allocate to the lan interface a larger prefix than /64 so that lan can use a /64 and delegate another to some router requesting for a prefix.

Yes, I know /64 is standart prefix.
I had no addition router after my openwrt. But the 'IPv6-PD' still showed on my lan interface before the day I post this topic. If it is not suppose to show a PD there, I want to know why it had keeped for such a long time?