IPv6 for LTE modem not working

My network config:

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdcc:509d:268e::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'
	list ports 'sfp2'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device
	option name 'br-wan'
	option type 'bridge'
	list ports 'eth1'
	list ports 'wan'

config device
	option name 'eth1'
	option macaddr 'ea:18:59:99:9e:88'

config device
	option name 'wan'
	option macaddr 'ea:18:59:99:9e:88'

config interface 'wan'
	option device 'br-wan'
	option proto 'dhcp'
	option metric '10'

config interface 'wan6'
	option device 'br-wan'
	option proto 'dhcpv6'
	option metric '10'

config interface '4G'
	option proto 'qmi'
	option auth 'none'
	option pdptype 'ipv4v6'
	option device '/dev/cdc-wdm0'

I see an IPv6 address in LUCI

But when I run uqmi -d /dev/cdc-wdm0 --get-current-setting, I don't see an IPv6 address?

{
	"pdp-type": "ipv4-or-ipv6",
	"ip-family": "ipv4",
	"mtu": 1500,
	"ipv4": {
		"ip": "10.28.55.83",
		"dns1": "42.105.240.101",
		"dns2": "8.8.8.8",
		"gateway": "10.28.55.84",
		"subnet": "255.255.255.248"
	},
	"ipv6": {
		
	},
	"domain-names": {
		
	}
}

I can successfully ping IPv4 hosts (ping -I wwan0 1.1.1.1) using the wwan0 interface that is created but not IPv6 (ping -I wwan0 ipv6.google.com)

You probably need to add option ipv6 '1' to the QMI interface.

config interface '4G'
	option proto 'qmi'
	option auth 'none'
	option pdptype 'ipv4v6'
	option device '/dev/cdc-wdm0'
	option ipv6 '1'

Just tried it out still can't ping ipv6.google.com or any other IPv6 hosts

EDIT: My br-wan has IPv6 and trying with that it works, just form wwan0 interface it doesn't

Hello z4e,

I hope all is well with you!

Please how did you solve this issue? I am having the same issue, I am using a ATT SIM.

Thank you!

Last I checked, the AT&T wireless network does not run IPV6 at all. It's strictly IPv4 with CGNAT.

My modem interface is receiving an ipv6 /128. I believe it supports ipv6 when you get an ipv6 from the carrier. correct? It's the same SIM used for smart devices. Apn broadband

Please describe what your issue is and share some details, like ifstatus {lte interface name} and network configuration. No pictures please.