IPv6 failling to ping/traceroute

Hello...
Please, can anybody help me with this?
My router gets an IPv6 on WAN6... There is IPv6 on LAN...
but on clients registreds on LAN can't ping no IPv6 outside. Even if I ssh into the router ping fails:

root@OpenWrt1:~# ping www.google.com.br
PING www.google.com.br (2800:3f0:4001:819::2003): 56 data bytes
^C
--- www.google.com.br ping statistics ---
8 packets transmitted, 0 packets received, 100% packet loss


PING 2a03:b0c0:3:d0::1af1:1 (2a03:b0c0:3:d0::1af1:1): 56 data bytes

--- 2a03:b0c0:3:d0::1af1:1 ping statistics ---
5 packets transmitted, 0 packets received, 100% packet loss

Here is my network and DHCP files:

NETWORK:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option packet_steering '1'
        option ula_prefix 'fd7c:acb1:e35e::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan1'

config interface 'lan'
        option device 'br-lan.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'

config bridge-vlan
        option device 'br-lan'
        option vlan '1'
        list ports 'lan2'
        list ports 'lan3'

config bridge-vlan
        option device 'br-lan'
        option vlan '30'
        list ports 'lan2:t'
        list ports 'lan3:t'

config bridge-vlan
        option device 'br-lan'
        option vlan '107'
        list ports 'lan1:u*'
        list ports 'lan2:t'
        list ports 'lan3:t'

config interface 'guest'
        option device 'br-lan.30'
        option proto 'static'
        option ipaddr '192.168.30.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option delegate '0'

config interface 'iot'
        option device 'br-lan.107'
        option proto 'static'
        option ipaddr '192.168.9.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option delegate '0'

DHCP:

config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option localservice '1'
        option ednspacket_max '1232'
        list rebind_domain 'plex.direct'
        option port '53'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option dhcpv4 'server'
        option ra_slaac '1'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'
        option ra_management '1'
        option leasetime '120h'
        option ra_default '1'
        option ra 'hybrid'
        option dhcpv6 'hybrid'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config dhcp 'iot'
        option interface 'iot'
        option start '100'
        option limit '150'
        option leasetime '450h'

config dhcp 'guest'
        option interface 'guest'
        option start '100'
        option limit '150'
        option leasetime '2h'

Thank you!!

Can you show output ip a s on the router? Also ip -6 route show

ip a s:

root@OpenWrt1:~# ip a s
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1504 qdisc fq_codel state UP qlen 1000
    link/ether 50:64:2b:35:20:e1 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::5264:2bff:fe35:20e1/64 scope link 
       valid_lft forever preferred_lft forever
3: lan3@eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue master br-lan state LOWERLAYERDOWN qlen 1000
    link/ether 50:64:2b:35:20:e1 brd ff:ff:ff:ff:ff:ff
4: lan2@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether 50:64:2b:35:20:e1 brd ff:ff:ff:ff:ff:ff
5: lan1@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether 50:64:2b:35:20:e1 brd ff:ff:ff:ff:ff:ff
6: wan@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether 50:64:2b:35:20:e0 brd ff:ff:ff:ff:ff:ff
    inet 179.219.71.197/23 brd 179.219.71.255 scope global wan
       valid_lft forever preferred_lft forever
    inet6 2804:14d:4c89::327/128 scope global dynamic noprefixroute 
       valid_lft 2583187sec preferred_lft 595987sec
    inet6 fe80::5264:2bff:fe35:20e0/64 scope link 
       valid_lft forever preferred_lft forever
9: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether 50:64:2b:35:20:e1 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::5264:2bff:fe35:20e1/64 scope link 
       valid_lft forever preferred_lft forever
10: br-lan.1@br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether 50:64:2b:35:20:e1 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.1/24 brd 192.168.1.255 scope global br-lan.1
       valid_lft forever preferred_lft forever
    inet6 fd7c:acb1:e35e:20::1/60 scope global noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 fe80::5264:2bff:fe35:20e1/64 scope link 
       valid_lft forever preferred_lft forever
11: br-lan.30@br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether 50:64:2b:35:20:e1 brd ff:ff:ff:ff:ff:ff
    inet 192.168.30.1/24 brd 192.168.30.255 scope global br-lan.30
       valid_lft forever preferred_lft forever
    inet6 2804:14d:4c89:131d::1/64 scope global dynamic noprefixroute 
       valid_lft 2583187sec preferred_lft 595987sec
    inet6 fd7c:acb1:e35e::1/60 scope global noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 fe80::5264:2bff:fe35:20e1/64 scope link 
       valid_lft forever preferred_lft forever
12: br-lan.107@br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether 50:64:2b:35:20:e1 brd ff:ff:ff:ff:ff:ff
    inet 192.168.9.1/24 brd 192.168.9.255 scope global br-lan.107
       valid_lft forever preferred_lft forever
    inet6 fd7c:acb1:e35e:10::1/60 scope global noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 fe80::5264:2bff:fe35:20e1/64 scope link 
       valid_lft forever preferred_lft forever
13: wlan1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether 50:64:2b:35:20:e3 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::5264:2bff:fe35:20e3/64 scope link 
       valid_lft forever preferred_lft forever
14: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether 50:64:2b:35:20:e2 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::5264:2bff:fe35:20e2/64 scope link 
       valid_lft forever preferred_lft forever
15: wlan0-1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether 52:64:2b:35:20:e2 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::5064:2bff:fe35:20e2/64 scope link 
       valid_lft forever preferred_lft forever
16: wlan0-2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether 56:64:2b:35:20:e2 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::5464:2bff:fe35:20e2/64 scope link 
       valid_lft forever preferred_lft forever
17: wlan1-1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether 52:64:2b:35:20:e3 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::5064:2bff:fe35:20e3/64 scope link 
       valid_lft forever preferred_lft forever

ip -6 route show:

root@OpenWrt1:~# ip -6 route show
default from 2804:14d:4c89::327 via fe80::217:10ff:fe98:8589 dev wan  metric 512 
default from 2804:14d:4c89:131d::/64 via fe80::217:10ff:fe98:8589 dev wan  metric 512 
2804:14d:4c89::/64 dev wan  metric 256 
2804:14d:4c89:1::/64 dev wan  metric 256 
2804:14d:4c89:131d::/64 dev br-lan.30  metric 1024 
unreachable 2804:14d:4c89:131d::/64 dev lo  metric 2147483647 
fd7c:acb1:e35e::/64 dev br-lan.30  metric 1024 
fd7c:acb1:e35e:10::/64 dev br-lan.107  metric 1024 
fd7c:acb1:e35e:20::/64 dev br-lan.1  metric 1024 
unreachable fd7c:acb1:e35e::/48 dev lo  metric 2147483647 
fe80::/64 dev eth0  metric 256 
fe80::/64 dev br-lan  metric 256 
fe80::/64 dev br-lan.1  metric 256 
fe80::/64 dev br-lan.30  metric 256 
fe80::/64 dev br-lan.107  metric 256 
fe80::/64 dev wlan0  metric 256 
fe80::/64 dev wlan0-1  metric 256 
fe80::/64 dev wlan0-2  metric 256 
fe80::/64 dev wlan1  metric 256 
fe80::/64 dev wlan1-1  metric 256 
fe80::/64 dev wan  metric 256 
anycast 2804:14d:4c89:131d:: dev br-lan.30  metric 0 
anycast fd7c:acb1:e35e:: dev br-lan.30  metric 0 
anycast fd7c:acb1:e35e:10:: dev br-lan.107  metric 0 
anycast fd7c:acb1:e35e:20:: dev br-lan.1  metric 0 
anycast fe80:: dev eth0  metric 0 
anycast fe80:: dev br-lan.107  metric 0 
anycast fe80:: dev br-lan  metric 0 
anycast fe80:: dev br-lan.30  metric 0 
anycast fe80:: dev br-lan.1  metric 0 
anycast fe80:: dev wlan0-1  metric 0 
anycast fe80:: dev wlan0  metric 0 
anycast fe80:: dev wlan0-2  metric 0 
anycast fe80:: dev wlan1-1  metric 0 
anycast fe80:: dev wlan1  metric 0 
anycast fe80:: dev wan  metric 0 
multicast ff00::/8 dev eth0  metric 256 
multicast ff00::/8 dev br-lan.1  metric 256 
multicast ff00::/8 dev br-lan.30  metric 256 
multicast ff00::/8 dev br-lan.107  metric 256 
multicast ff00::/8 dev br-lan  metric 256 
multicast ff00::/8 dev wlan0  metric 256 
multicast ff00::/8 dev wlan0-1  metric 256 
multicast ff00::/8 dev wlan0-2  metric 256 
multicast ff00::/8 dev wlan1  metric 256 
multicast ff00::/8 dev wlan1-1  metric 256 
multicast ff00::/8 dev wan  metric 256 

On my network, there are 3 OpenWRT devices:
One of them is the main and it handle dhcp, wan connection, etc...
The other 2 are basicly AP's with VLAN tagging each network.

hunh, I've never seen that construct of vlans on top of a bridge. And that works for you?

In any case, it looks like you have only a /64 prefix on your br-lan.30 interface and no other public prefix on LAN.

Does your ISP do something stupid and just hand out a single /64 prefix? That's a broken config but surprisingly common, someone needs to go around wringing people's necks until they get with the program and hand out /56 by default and /48 on request.

1 Like

Isn't that how vlans are done when using DSA?

could be, I've never had a DSA device.

humm..
sorry.. i know almost nothing about ipv6, so I can't tell if any information that I provided before is correct and even if it's something that I have done wrong or if its my ISP issue.
There is something strange that IPv6 is mentioned on my br-lan.30 (guest) and br-lan.107 (iot) but on the network interfaces which each of those VLAN`s are bounded, I deactivated IPv6. My intention was to provide IPv6 only on the main LAN.
I had a similar config a few months ago. All devices were running openwrt 19.06 but one of my devices broke and a got a new one and it supports only 21.02, which works on this new DSA switch... So... that config of VLAN's at least for IPv4 is working fine.

and IPv6 worked? seems odd that it would work with a single /64 prefix as mentioned before

yes, it did!

hi @jaromanda ..
i did a traceroute -6 to googles ipv6 and it seams that its droping on ISP.. I'm not sure but my assumption is because this IP seems to be on the same range that my WAN6 interface:

root@OpenWrt1:~# ping www.google.com
PING www.google.com (2800:3f0:4001:822::2004): 56 data bytes
^C
--- www.google.com ping statistics ---
7 packets transmitted, 0 packets received, 100% packet loss
root@OpenWrt1:~# traceroute -6 2800:3f0:4001:809::2004
traceroute to 2800:3f0:4001:809::2004 (2800:3f0:4001:809::2004), 30 hops max, 64 byte packets
 1  2804:14d:4c89::1 (2804:14d:4c89::1)  14.607 ms  13.717 ms  13.515 ms
 2  2804:14d:4c00:a10::1 (2804:14d:4c00:a10::1)  12.166 ms  13.778 ms  13.691 ms
 3  2804:14d:4c00:1600:cc::2 (2804:14d:4c00:1600:cc::2)  15.300 ms  11.527 ms  13.134 ms
 4  *  *  2804:14d:4c00:1600:aa::2 (2804:14d:4c00:1600:aa::2)  11.978 ms
 5  *  *  *
 6  *  *  *
 7  *  *  *
 8  *  *  *
 9  *  *  *
10  *  *  *
11  *  *  *
12  *  *  *
13  *  *  *
14  *  *  *
15  *  *  *
16  *  *  *
17  *  *  *
18  *  *  *
19  *  *  *
20  *  *  *
21  *  *  *
22  *  *  *
wan       Link encap:Ethernet  HWaddr 50:64:2B:35:20:E0  
          inet addr:179.219.56.172  Bcast:179.219.57.255  Mask:255.255.254.0
          inet6 addr: *2804:14d:4c89*::327/128 Scope:Global
          inet6 addr: fe80::5264:2bff:fe35:20e0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:324919 errors:0 dropped:0 overruns:0 frame:0
          TX packets:93526 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:152457849 (145.3 MiB)  TX bytes:18683224 (17.8 MiB)

Do you think it's evidence of ISP issue?

yes, as was mentioned before about the /64 prefix being useless

If you look at the interfaces page in luci .... for wan6, what is the value of IPv6-PD:

Yes your traceroute shows your ISP has broken ipv6

Protocol: DHCPv6 client
Uptime: 15h 51m 2s
MAC: 50:64:2B:35:20:E0
RX: 3.24 GB (9430769 Pkts.)
TX: 592.45 MB (1985356 Pkts.)
IPv6: 2804:14d:4c89::327/128
IPv6-PD: 2804:14d:4c89:131d::/64

i just don't know if the issue is a /64 prefix or if it could be another ISP issue.
I mean... is the /64 prefix just a bad situation or its enough to IPv6 not work at all?

the /64 is just a bad situation, the fact that you can't traceroute means your ISP is fully broken in their ipv6 routing, that's a different problem entirely. Basically you need to get on the phone with your ISP and escalate to someone who knows what ipv6 routing is and tell them your traceroute results.

thanks...
Before contact them, I tried to test using the ISP modem on its router mode.. not in bridge mode as before.
I coul'd check that the modem also got a /64 prefix.
On OpenWRT, IPv4 WAN interface got an 192.168.0.0/24 address (as expected) and WAN6 also got a /64 prefix, but on luci was not showing as " IPv6-PD" It was showing as ˜ IPv6˜.

From the OpenWRT console I tried a traceroute6 to google it worked:

root@OpenWrt1:~# traceroute6 www.google.com
traceroute to www.google.com (2800:3f0:4001:81f::2004), 30 hops max, 64 byte packets
 1  2804:14d:4c89:10b2::1 (2804:14d:4c89:10b2::1)  2.415 ms  2.193 ms  2.017 ms
 2  2804:14d:4c89::1 (2804:14d:4c89::1)  12.727 ms  15.804 ms  12.455 ms
 3  2804:14d:4c00:a10::1 (2804:14d:4c00:a10::1)  12.597 ms  13.323 ms  14.624 ms
 4  2804:14d:4c00:1600:cc::2 (2804:14d:4c00:1600:cc::2)  12.639 ms  10.876 ms  12.047 ms
 5  *  *  *
 6  *  *  *
 7  *  *  *
 8  2800:3f0:8006::1 (2800:3f0:8006::1)  31.778 ms  *  *
 9  2001:4860:0:1::2778 (2001:4860:0:1::2778)  32.409 ms  *  *
10  2001:4860:0:1::56f1 (2001:4860:0:1::56f1)  31.327 ms  *  *
11  2001:4860::c:4001:85d8 (2001:4860::c:4001:85d8)  33.247 ms  32.972 ms  *
12  2800:3f0:4001:81f::2004 (2800:3f0:4001:81f::2004)  34.010 ms  2800:3f0:803b::1 (2800:3f0:803b::1)  29.431 ms  2800:3f0:8006::1 (2800:3f0:8006::1)  34.410 ms

Changing back the modem to bridge mode, got the same situation as before:

root@OpenWrt1:~# traceroute6 www.google.com
traceroute to www.google.com (2800:3f0:4001:819::2004), 30 hops max, 64 byte packets
 1  2804:14d:4c89::1 (2804:14d:4c89::1)  12.994 ms  13.149 ms  11.730 ms
 2  2804:14d:4c00:a10::1 (2804:14d:4c00:a10::1)  11.105 ms  16.188 ms  27.931 ms
 3  2804:14d:4c00:1600:cc::2 (2804:14d:4c00:1600:cc::2)  22.002 ms  11.375 ms  12.437 ms
 4  *  *  *
 5  *  *  *
 6  *  *  *
 7  *  *  *
 8  *  *  *
 9  *  *  *
10  *  *  *
11  *  *  *
12  *  *  *
13  *  *  *
14  *  *  *
15  *  *  *
16  *  *  *
17  *  *  *
18  *  *  *
19  *  *  *
20  *  *  *
21  *  *  *
22  *  *  *
23  *  *  *
24  *  *  *
25  *  *  *
26  *  *  *
27  *  *  *
28  *  *  *
29  *  *  *
30  *  *  *

I'm not defending my ISP, but this change using their modem as router could mean that I'm doing something wrong, right?

Also.. on both traceroutes the traffic goes trough the same IP: 2804:14d:4c00:1600:cc::2.

The fact that you get at least this far indicates that your own equipment is working properly, the fact that you get no farther suggests the ISP is doing something wrong.

1 Like

Can you try adding the last line below to wan6 as follows

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'
        option reqprefix '48' <=== also try '56' and 'auto'

and under

config interface 'lan'

change

      option ip6assign '60'

to

      option ip6assign '64'

Based on what the "modem" seems to be doing it does seem like IPv6 should work

perhaps the modem doesn't "bridge" IPv6 properly though

What sort of device is this modem - perhaps there's a known issue with IPv6 in bridged mode

Hey, @jaromanda!
It works!!
I did this:

config interface 'lan'
        option device 'br-lan.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '64'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'
        option reqaddress 'force'
        option ip6assign '48'
        option reqprefix '48'

On Luci view, LAN interface has chanched... now IPv6 /64 on LAN is not present but now I can ping6 both from LAN clients and from openwrt console.

image

here is my "ip a s" and "ip -6 route show" after these changes:

ip a s:

root@OpenWrt1:~# ip a s
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1504 qdisc fq_codel state UP qlen 1000
    link/ether 50:64:2b:35:20:e1 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::5264:2bff:fe35:20e1/64 scope link 
       valid_lft forever preferred_lft forever
3: lan3@eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue master br-lan state LOWERLAYERDOWN qlen 1000
    link/ether 50:64:2b:35:20:e1 brd ff:ff:ff:ff:ff:ff
4: lan2@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether 50:64:2b:35:20:e1 brd ff:ff:ff:ff:ff:ff
5: lan1@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether 50:64:2b:35:20:e1 brd ff:ff:ff:ff:ff:ff
6: wan@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether 50:64:2b:35:20:e0 brd ff:ff:ff:ff:ff:ff
    inet 179.219.56.172/23 brd 179.219.57.255 scope global wan
       valid_lft forever preferred_lft forever
    inet6 fd7c:acb1:e35e::1/48 scope global noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 2804:14d:4c89:131d::1/64 scope global dynamic noprefixroute 
       valid_lft 2591516sec preferred_lft 604316sec
    inet6 2804:14d:4c89::327/128 scope global dynamic noprefixroute 
       valid_lft 2591516sec preferred_lft 604316sec
    inet6 fe80::5264:2bff:fe35:20e0/64 scope link 
       valid_lft forever preferred_lft forever
9: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether 50:64:2b:35:20:e1 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::5264:2bff:fe35:20e1/64 scope link 
       valid_lft forever preferred_lft forever
10: br-lan.1@br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether 50:64:2b:35:20:e1 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.1/24 brd 192.168.1.255 scope global br-lan.1
       valid_lft forever preferred_lft forever
    inet6 2804:14d:4c89:131d::1/64 scope global deprecated dynamic 
       valid_lft 6714sec preferred_lft 0sec
    inet6 fd7c:acb1:e35e::1/48 scope global deprecated dynamic 
       valid_lft 6714sec preferred_lft 0sec
    inet6 fe80::5264:2bff:fe35:20e1/64 scope link 
       valid_lft forever preferred_lft forever
11: br-lan.30@br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether 50:64:2b:35:20:e1 brd ff:ff:ff:ff:ff:ff
    inet 192.168.30.1/24 brd 192.168.30.255 scope global br-lan.30
       valid_lft forever preferred_lft forever
    inet6 fe80::5264:2bff:fe35:20e1/64 scope link 
       valid_lft forever preferred_lft forever
12: br-lan.107@br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether 50:64:2b:35:20:e1 brd ff:ff:ff:ff:ff:ff
    inet 192.168.9.1/24 brd 192.168.9.255 scope global br-lan.107
       valid_lft forever preferred_lft forever
    inet6 fe80::5264:2bff:fe35:20e1/64 scope link 
       valid_lft forever preferred_lft forever
13: wlan1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether 50:64:2b:35:20:e3 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::5264:2bff:fe35:20e3/64 scope link 
       valid_lft forever preferred_lft forever
14: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether 50:64:2b:35:20:e2 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::5264:2bff:fe35:20e2/64 scope link 
       valid_lft forever preferred_lft forever
15: wlan0-1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether 52:64:2b:35:20:e2 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::5064:2bff:fe35:20e2/64 scope link 
       valid_lft forever preferred_lft forever
16: wlan0-2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether 56:64:2b:35:20:e2 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::5464:2bff:fe35:20e2/64 scope link 
       valid_lft forever preferred_lft forever
17: wlan1-1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether 52:64:2b:35:20:e3 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::5064:2bff:fe35:20e3/64 scope link 
       valid_lft forever preferred_lft forever

ip -6 route show

root@OpenWrt1:~# ip -6 route show
default from 2804:14d:4c89::327 via fe80::217:10ff:fe98:8589 dev wan  metric 512 
default from 2804:14d:4c89:131d::/64 via fe80::217:10ff:fe98:8589 dev wan  metric 512 
2804:14d:4c89::/64 dev wan  metric 256 
2804:14d:4c89:1::/64 dev wan  metric 256 
2804:14d:4c89:131d::/64 dev br-lan.1  metric 256  expires 2635sec
2804:14d:4c89:131d::/64 dev wan  metric 1024 
unreachable 2804:14d:4c89:131d::/64 dev lo  metric 2147483647 
fd7c:acb1:e35e::/64 dev wan  metric 1024 
fd7c:acb1:e35e::/48 dev br-lan.1  metric 256  expires 2635sec
unreachable fd7c:acb1:e35e::/48 dev lo  metric 2147483647 
fe80::/64 dev eth0  metric 256 
fe80::/64 dev br-lan  metric 256 
fe80::/64 dev br-lan.1  metric 256 
fe80::/64 dev br-lan.30  metric 256 
fe80::/64 dev br-lan.107  metric 256 
fe80::/64 dev wan  metric 256 
fe80::/64 dev wlan0  metric 256 
fe80::/64 dev wlan0-1  metric 256 
fe80::/64 dev wlan0-2  metric 256 
fe80::/64 dev wlan1  metric 256 
fe80::/64 dev wlan1-1  metric 256 
anycast 2804:14d:4c89:131d:: dev br-lan.1  metric 0 
anycast 2804:14d:4c89:131d:: dev wan  metric 0 
anycast fd7c:acb1:e35e:: dev br-lan.1  metric 0 
anycast fd7c:acb1:e35e:: dev wan  metric 0 
anycast fe80:: dev eth0  metric 0 
anycast fe80:: dev br-lan.1  metric 0 
anycast fe80:: dev br-lan.30  metric 0 
anycast fe80:: dev br-lan.107  metric 0 
anycast fe80:: dev br-lan  metric 0 
anycast fe80:: dev wlan0-2  metric 0 
anycast fe80:: dev wan  metric 0 
anycast fe80:: dev wlan0-1  metric 0 
anycast fe80:: dev wlan0  metric 0 
anycast fe80:: dev wlan1-1  metric 0 
anycast fe80:: dev wlan1  metric 0 
multicast ff00::/8 dev eth0  metric 256 
multicast ff00::/8 dev br-lan.1  metric 256 
multicast ff00::/8 dev br-lan  metric 256 
multicast ff00::/8 dev br-lan.30  metric 256 
multicast ff00::/8 dev br-lan.107  metric 256 
multicast ff00::/8 dev wan  metric 256 
multicast ff00::/8 dev wlan0  metric 256 
multicast ff00::/8 dev wlan0-1  metric 256 
multicast ff00::/8 dev wlan0-2  metric 256 
multicast ff00::/8 dev wlan1  metric 256 
multicast ff00::/8 dev wlan1-1  metric 256 

Not sure what

is doing under wan6!

Anyway, glad I could help - did you try option reqprefix 'auto' by any chance?