IPv6 External not working

I use Mediacom on a WRT1900. I've having trouble getting my internal IPv6 and their IPv6 to route.

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdc4:76fa:44e2::/48'

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.0.1'
        option ifname 'eth0.1 eth1.2'

config interface 'wan'
        option ifname 'eth1.2'
        option proto 'dhcp'
        option type 'bridge'

config interface 'wan6'
        option proto 'dhcpv6'
        option type 'bridge'
        option reqaddress 'try'
        option ifname 'eth0.1'
        option reqprefix '64'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 5t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '4 6t'

What are you trying to do? Why is eth0.1 part of both the lan and wan6 bridges, and why is eth1.2 part of both the lan and wan bridges? Is that the default configuration?

You can't add the same interface to multiple bridges.

1 Like