IPv6 configuration in OpenWrt

Hello gentlemen,
I'm having trouble configuring IPv6 on my Archer C7-v2.

  • When I do DHCPv6 to my ISP, it returns me with a Global IPv6 address (without IPV6-PD) which, when pinging via LuCi or via SSH, it returns me 0% loss, but when pinging my machine it returns me 100% loss.

Follow print:

Captura de Tela 2020-02-04 às 01.18.28

@RdTos, welcome to the community!

Can you explain your problem?

You are only issued single IP addresses, I'm not clear on what you're trying to confugure.

Also, not sure why you have that route configured. Can you explain what you're trying to do?

Do you want to install NAT for IPv6?

@lleachii, I apologize for the lack of clarity.
I am trying to configure internet access via IPv6.
My problem is this: I have IPv6 access only on the LuCi interface when I give a ping6 command on the diagnostics tab, that is via SSH OpenWrt also I can ping6 openwrt.org for example, but on my OS I can't ping6 command for no website IPv6.

  • I configured raute6 for wan, believing that it would be possible to go to the internet with IPv6 in this way

  • Atualmente, conforme as imagens de tela, essa é minha configuração, a qual não tenho acesso para internet com IPv6

  • My ISP may not work with DHCPv6 or else I am doing something very wrong to configure IPv6 on openWrt?

The thing is... there's nothing wrong with your config. If yor ISP doesn't issue a PD, you'll have to install something like NAT for IPv6 for your LAN to use it.

EDIT: and to be clear, the route is incorrect for at least 3 reasons:

  • it would be your ISP that needs to make routes
  • you listed a subnet as a gateway, that's invalid anyway
  • fe80 is in a Private range

See: https://openwrt.org/docs/guide-user/network/ipv6/ipv6.nat6

I think you looked at the WAN interface instead of the WAN6, the latter has a 2804:.../64 address.

1 Like

Correct, a single IP...on a subnet on the WAN side.

Are you suggesting that could be used....true...


You should not (need to) declare a manual IPv6 default route, remove that route entry again.
Make sure your WAN6 interface is configured to request a prefix ("Request IPv6-address: try", "Request IPv6-prefix of length: Automatic") and make sure that your LAN interface has the "IPv6 assignment length" set to something >= 64.

@lleachii, thanks for the advice. Regarding what you said, I think it is more likely that my ISP will not release IPV6-PD, and in this case I will have to configure a NAT IPv6 (I need to read a little about this because NAT IPv6 I don't know how it does).

@eduperez, thanks for the answer!
Yes exactly, I would like to use this IPv6 from WAN6, which is why I can ping6 on LuCi and SSH

@jow, thanks for the answer!
I've already configured it this way, and even then I don't receive an IPv6-PD... Here are screenshots:

Captura de Tela 2020-02-04 às 12.49.26

Captura de Tela 2020-02-04 às 12.48.12

Sorry if I am being obtuse, and sorry again if I am hijacking someone's else thread... but I just do not get the issue with the /64 network and the need for NAT6, perhaps I am not as well informed about IPv6 as I though.

If the ISP issued a /64 (as many ISP's do) to the OP, isn't OP supposed to just use that address, so all devices in his LAN get an address within that /64 subnet? Why the need for NAT6, then?

Also, should't OP's LAN interface have an address in the 2804:.../64 range (it doesn't)? Shouldn't all his devices connected to LAN have an address in the 2804:.../64 range (not tested)? Or I am missing something here?


Just like if you're issued a WAN IPv4 address from a /24 range - it doesn't mean that the remaining 251 IPs in the subnet are available for your usage.

He doesn't have a PD.

1 Like

Honestly, just get a tunnel, or pretend you don't have IPv6, since you actually basically don't. Getting one IPv6 assigned to you is like going to a restaurant and getting one grain of rice... Technically maybe you were served... but you didn't actually get a meal.

But I'd call the ISP, they probably just haven't got a clue but they might just need to enable something so you get a prefix designated.

1 Like

Thank you very much for the tips and advice of all.
@dlakelan, I will contact my ISP and request a correction, a light or a correct IPv6-PD release; I'll do it tomorrow and i will keep this topic up to date.

I think it depends on the ISP router. The router doesn't delegate a prefix, it only offers addresses from a prefix to the clients.

What internet access do you use? Could you use OpenWrt to connecto to your ISP? Can you get a modem from your ISP instead of a router?

Last option probably is to set IPv6 to relay mode.

I use PPPoe, make a direct connection to the ISP through OpenWrt