IPv6 Automatic OpenWrt Vs ISP

My ISP is providing me two connections, each with both IPv4 and IPv6 public address as well as IPv6 PD.

I am using Fedora Silverblue 33 as my testing machine. I find two different behaviour if my FCB33 is connected to ISP Vs OpenWRT:

I am testing with IPv6 Automatic (in the sense of NetworkManager of Fedora) only - all IPv4 configuration are disabled - thus to make sure the whole Computer is IPv6 only.
The Interface at Router side also is IPv6 only - no IPv4 configured.

  1. With ISP, FCB33 everything seems normaly.
  2. With OpenWRT, NetworkManager-wait-online service will failed. And after bootup, systemd-resolve --status reports no DNS server detected, or DNS server only show up after very long time.

As everything in the Fedora Side is default settings - how can I configure OpenWRT so that Fedora can got the DNS much faster?

1 Like

IPv6 multi homing is still a research topic.what happens if you connect to just ONE connection with just one prefix on LAN?

Oh - I mean, it is a single physical connection, but allowing two device connections. (So I can connect two device and both got IP. But the third device will not got any IP, when all connected to the ISP switch.)

This is my current setup:

WAN - Got IPv4 from ISP DHCP
WAN6 - Got IPv6 from ISP (DHCP or Automatic, I am not sure)
VLAN1 - Providing DHCP for IPv4 clients
VLAN6 - Providing auto IPv6 distribution from the ISP dynamic PD range.


  • Single NIC with Automatic in IPv6, and IPv4 Disabled.

Ok i understand. I think the question is why does Fedora take so long. Does it have IPV4 set to disabled in network manager? openwrt should be sending the DNS within the router advertisements. Can you check your interface IPV6 settings to make sure you're advertising the DNS? normally you would put the routers ULA as the DNS.

From my FSB33 side, I do not change anything, just change the up stream connection: patch to OpenWRT Router (to VLAN6) or to ISP Switch .

The NetworkManager configuration is:

  • IPv4 Disabled
  • IPv6 Automatic

From OpenWRT Router:

  • The VLAN6 interface has no IPv4 definition. Just IPv6.

In this case, do I need to put my Router's VLAN6 IPv6 address - the ULA one, and advertise it as DNS for down streams?

Yes I'm not sure if this is the default config. But I think you can check in luci the IPV6 settings for the vlan6 interface. It has some dns settings I think

In LUCI, Interfaces->DHCP Server, I am having:

Router Advertisement-Server: server mode
DHCPv6-Service: server mode
NDP-proxy: disabled
DHCP-v6-Mode: stateless + stateful

Always announce default router: cleared
Announced DNS servers: empty
Announced DNS domains: empty

All of the above are OpenWRT defaults.

I further simplify my testing:

Once Fedora notebook is now dedicated connecting to ISP switch. While the original FCB33 is connected to VLAN6 of OpenWRT. This is to avoid any switch of the Physical LAN cable connections.

For the Notebook, boot up is all normal.

For FCB33 - NetworkManager is reporting failed connection attempts.

Put the ula of your router there

1 Like

Putting that ULA IP into the DNS box do not help.

did you restart networking on the openwrt?

Hi and welcome to the forum! :smiley:

If the issue persists, collect the diagnostics and post it to pastebin.com redacting the private parts:

uci show network; uci show dhcp; uci show firewall; ifstatus wan6
1 Like

I reset my router to default. It seems OK with a simple configuration now.

I am trying to rebuild my configuration one step at a time, and see if the same issue will come up.