IPv6 - AP Settings?

I have 4 wndr3800 routers setup for my home network. 1 is a router and AP, the other 3 are AP's. The main router is setup as the DHCP server. What should the settings for the AP's be under Interfaces - LAN -> DHCP Server -> IP v6 Settings? I'm uncertain what the first two choices should be (Router Advertisement-Service and DHCPv6-Service). Server-only does not seem right, since my main router is doing DHCP. Should they be set to "relay" or "disabled"???


I am in the same boat. I'm using a x86 version of Openwrt with a second wireless router as an access point. I'm not getting a prefix on the LAN. I was just going to start a new topic but since you already have, maybe we can both get up and running from one thread. No need in having two topics out there asking the same thing.

1 Like

If they are just APs you should set Router Advertisement-Service, DHCPv6-Service, NDP-Proxy all to disabled. An AP is a layer 2 device (just forwards between MAC addresses) and shouldn't do anything with RA or DHCP etc

@goblinX your boat is slightly different. You need to set this up on the router (ie. a device connected to both WAN and LAN) not a separate AP only on your LAN. Post a new thread on that titled: "I can't get ipv6 on my LAN only my WAN" it will be easier for people in your same boat to find that topic and see the solution.

1 Like

You know what I'm up against already. I have been experiencing problems all of a sudden with the wireless cutting out from my AP. I have to keep rebooting the routers. I guess I better look and see if my AP has these settings disabled like you said.

also check to see that you've selected a channel manually and that it's not a radar detection required / DFS channel on 5ghz.

So IPv6 is working now. Have it working to Xbox Live as well. Thanks so much.... Simple as that... Lol.


From the other thread: I can't get ipv6 on my LAN only my WAN it seems like you have two ULAs, so you should go around to all your APs and ensure that they have DHCP and DHCPv6 turned off, and they are in disabled mode for router advertisements and NDP-proxy etc. The second set of ULA prefixes is probably coming from router-advertisements coming from one of your APs.