Ipv6 Address is not reflecting to WAN Interface and LAN bridge

Hi ,

I am using Openwrt software on my device. I have plugged the Real line/supporting ppp config for Ipv4/Ipv6 on WAN side.

But openwrt cli ---wan side there is no ipv6 address assigned. as well as LAN bridge , there is a IPv6 address with different prefix.

root@OpenWrt:/etc#
root@OpenWrt:/etc#
root@OpenWrt:/etc# ip -6 addr show br-lan
5: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 2a00:23c1:b58d:3c00::1/60 scope global dynamic===============No idea from where It is taking  2a00:23c1............
       valid_lft 8589117sec preferred_lft 8589117sec
    inet6 fd75:3f95:8264::1/60 scope global
       valid_lft forever preferred_lft forever
    inet6 fe80::1a62:2cff:fe2a:25b2/64 scope link
       valid_lft forever preferred_lft forever

root@OpenWrt:/etc# ip -6 addr show pppoe-wan
13: pppoe-wan: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1492 state UNKNOWN qlen 3
    inet6 fe80::341d:5c5:816a:3739/10 scope link
       valid_lft forever preferred_lft forever
root@OpenWrt:/etc#
root@OpenWrt:/etc#
root@OpenWrt:/etc#
root@OpenWrt:/etc#
root@OpenWrt:/etc#
root@OpenWrt:/etc#
root@OpenWrt:/etc# addr show pppoe-wan
-ash: addr: not found
root@OpenWrt:/etc# ifconfig pppoe-wan
pppoe-wan Link encap:Point-to-Point Protocol
          inet addr:81.131.99.222  P-t-P:172.16.15.47  Mask:255.255.255.255
          inet6 addr: fe80::341d:5c5:816a:3739/10 Scope:Link========================No global ipv6 prefix 
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1492  Metric:1
          RX packets:230294 errors:0 dropped:0 overruns:0 frame:0
          TX packets:125065 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3
          RX bytes:327224190 (312.0 MiB)  TX bytes:9336330 (8.9 MiB)

My line should give ipv6 address as 2a00:23a8:....../56

Any inputs will help.

Not having a global IPv6 address on the wan interface shouldn't be a problem. If the wan interface had received a global IPv6 address then it shouldn't be within the delegated prefix anyway. Linux will use a global IPv6 address from another interface when sending for example DNS requests to the internet.

If you want to use an IPv6 address from another subnet then you can assign a global IPv6 address to "lo", which then will be used instead of the lan address. For example you can create an logical interface called "local", use "@loopback" or "lo" as physical interface/ifname, and assign a /64 prefix.

First of all please use preformatted text (the </> button) when you paste console output.

What is the output of the following?
uci export network; ifstatus wan; ifstatus wan6; ifstatus wan_6; ifstatus lan

1 Like

Hi Trendy,

Please find the output.

root@OpenWrt:/etc# uci export network
package network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'
        option ip_int_instance '1'

config globals 'globals'
        option ula_prefix 'fd75:3f95:8264::/48'

config atm-bridge 'atm'
        option vpi '1'
        option vci '32'
        option encaps 'llc'
        option payload 'bridged'
        option nameprefix 'dsl'

config dsl 'dsl'
        option annex 'a'
        option tone 'av'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.1.254'
        option ip_int_instance '2'

config device 'lan_dev'
        option name 'eth0.1'
        option macaddr '18:62:2c:2a:25:b2'

config interface 'wan'
        option proto 'pppoe'
        option password 'password'
        option ipv6 '1'
        option username 'bthomehub@btbroadband.com'
        option keepalive '5 10'
        option keepalive_adaptive '0'
        option ifname 'eth0.2'
        option ip_int_instance '3'

config device 'wan_dev'
        option name 'dsl0'
        option macaddr '18:62:2c:2a:25:b3'

config interface 'wan6'
        option ifname '@wan'
        option proto 'dhcpv6'
        option ip_int_instance '4'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 4 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '5 6t'


root@OpenWrt:/etc#

The ISP line is giving 2a00:23a8:4802:f700::/56, was expecting wan interface and lan bridge will get global ipv6 address from this family and then my router can allocate lan prefix to lan clients so that they can configured their ipv6 using slaac.

Not sure from where It is taking 2a00:23c1:b58d:3c00:: family addresses.

Thank you

Do you have any IPv6 connectivity issues? Can you ping ipv6.google.com in OpenWrt?

Hi Mikma,

Yes, we can ping.

root@OpenWrt:~# ifconfig pppoe-wan
pppoe-wan Link encap:Point-to-Point Protocol
          inet addr:86.140.86.72  P-t-P:172.16.15.47  Mask:255.255.255.255
          inet6 addr: fe80::6c8a:89f5:8f0e:9fa9/10 Scope:Link
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1492  Metric:1
          RX packets:143 errors:0 dropped:0 overruns:0 frame:0
          TX packets:145 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3
          RX bytes:61455 (60.0 KiB)  TX bytes:28380 (27.7 KiB)

root@OpenWrt:~# ping ipv6.google.com
PING ipv6.google.com (2a00:1450:4009:807::200e): 56 data bytes
64 bytes from 2a00:1450:4009:807::200e: seq=0 ttl=54 time=14.667 ms
64 bytes from 2a00:1450:4009:807::200e: seq=1 ttl=54 time=13.997 ms
64 bytes from 2a00:1450:4009:807::200e: seq=2 ttl=54 time=14.652 ms
^C
--- ipv6.google.com ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max = 13.997/14.438/14.667 ms
root@OpenWrt:~#

First of all fix the previous posts with preformatted text. Some lines are preformatted, while others are not and it is difficult to read them.
From what I could read there is no problem in the configuration and ipv6 is delegated correctly.

Hi Trendy,

Thank you. Could you please tell me why this prefix (which my line is having ) 2a00:23a8:4802:f700.... not reflecting.Where I can see this prefix 2a00:23c1:b58d:3c00 in openwrt config.

You deleted the ifstatus console output.
Paste them again in preformatted text.

Please find the output.

root@OpenWrt:~# ifstatus wan
{
        "up": true,
        "pending": false,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "uptime": 5416,
        "l3_device": "pppoe-wan",
        "proto": "pppoe",
        "device": "eth0.2",
        "updated": [
                "addresses",
                "routes"
        ],
        "metric": 0,
        "dns_metric": 0,
        "delegation": true,
        "ipv4-address": [
                {
                        "address": "86.140.86.72",
                        "mask": 32,
                        "ptpaddress": "172.16.15.47"
                }
        ],
        "ipv6-address": [
                {
                        "address": "fe80::6c8a:89f5:8f0e:9fa9",
                        "mask": 128
                }
        ],
        "ipv6-prefix": [

        ],
        "ipv6-prefix-assignment": [

        ],
        "route": [
                {
                        "target": "0.0.0.0",
                        "mask": 0,
                        "nexthop": "172.16.15.47",
                        "source": "0.0.0.0/0"
                }
        ],
        "dns-server": [
                "81.139.56.100",
                "81.139.57.100"
        ],
        "dns-search": [

        ],
        "neighbors": [

        ],
        "inactive": {
                "ipv4-address": [

                ],
                "ipv6-address": [

                ],
                "route": [

                ],
                "dns-server": [

                ],
                "dns-search": [

                ],
                "neighbors": [

                ]
        },
        "data": {

        }
}


root@OpenWrt:~# ifstatus wan6
{
        "up": true,
        "pending": false,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "uptime": 5472,
        "l3_device": "pppoe-wan",
        "proto": "dhcpv6",
        "device": "pppoe-wan",
        "metric": 0,
        "dns_metric": 0,
        "delegation": true,
        "ipv4-address": [

        ],
        "ipv6-address": [

        ],
        "ipv6-prefix": [
                {
                        "address": "2a00:23c1:b58d:3c00::",
                        "mask": 56,
                        "preferred": 315354528,
                        "valid": 315354528,
                        "class": "wan6",
                        "assigned": {
                                "lan": {
                                        "address": "2a00:23c1:b58d:3c00::",
                                        "mask": 60
                                }
                        }
                }
        ],
        "ipv6-prefix-assignment": [

        ],
        "route": [
                {
                        "target": "::",
                        "mask": 0,
                        "nexthop": "fe80::12e8:78ff:fe8a:f351",
                        "metric": 512,
                        "valid": 3381,
                        "source": "2a00:23c1:b58d:3c00::/56"
                }
        ],
        "dns-server": [

        ],
        "dns-search": [

        ],
        "neighbors": [

        ],
        "inactive": {
                "ipv4-address": [

                ],
                "ipv6-address": [

                ],
                "route": [

                ],
                "dns-server": [

                ],
                "dns-search": [

                ],
                "neighbors": [

                ]
        },
        "data": {

        }
}
root@OpenWrt:~# ifstatus lan
{
        "up": true,
        "pending": false,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "uptime": 5682,
        "l3_device": "br-lan",
        "proto": "static",
        "device": "br-lan",
        "updated": [
                "addresses"
        ],
        "metric": 0,
        "dns_metric": 0,
        "delegation": true,
        "ipv4-address": [
                {
                        "address": "192.168.1.254",
                        "mask": 24
                }
        ],
        "ipv6-address": [

        ],
        "ipv6-prefix": [

        ],
        "ipv6-prefix-assignment": [
                {
                        "address": "2a00:23c1:b58d:3c00::",
                        "mask": 60,
                        "preferred": 315354523,
                        "valid": 315354523,
                        "local-address": {
                                "address": "2a00:23c1:b58d:3c00::1",
                                "mask": 60
                        }
                },
                {
                        "address": "fd75:3f95:8264::",
                        "mask": 60,
                        "local-address": {
                                "address": "fd75:3f95:8264::1",
                                "mask": 60
                        }
                }
        ],
        "route": [

        ],
        "dns-server": [

        ],
        "dns-search": [

        ],
        "neighbors": [

        ],
        "inactive": {
                "ipv4-address": [

                ],
                "ipv6-address": [

                ],
                "route": [

                ],
                "dns-server": [

                ],
                "dns-search": [

                ],
                "neighbors": [

                ]
        },
        "data": {

        }
}
root@OpenWrt:~#
root@OpenWrt:~#

Your ISP delegates you 2a00:23c1:b58d:3c00::/56
2a00:23c1:b58d:3c00::/60 is assigned to the LAN
WAN doesn't get any IP, except link local, but that is not necessary.
You can try to add reqaddress='try' under wan6, although this is the default.

Hi Trendy,

Thank you very much. But This is what my confusion is. My ISP line is giving different prefix 2a00:23a8:4802:f700::/56, If I am putting this same line , to a different device, Can observe this prefix change. Tried different line with different prefix, but in this openwrt router is always showing 2a00:23c1:b58d:3c00::/56.

What is the best way to capture and observe this on openwrt router to verify what isp line is delgating.

the ISP is probably seeing different MAC address and assigning different prefix, this is probably normal behavior for your ISP.

1 Like

Thank you. Issue has been fixed. Need to use correct ppp credentials.

If your problem is solved, feel free to mark the relevant post as the solution; and edit the title to add "[SOLVED]" to the beginning (click the pencil behind the topic).

grafik

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.