Ipv4 routing rules are invalid

The ipv4 routing rule is invalid. Please tell me how to configure and use this ipv4 routing rule.


Please run the following commands (copy-paste the whole block) and paste the output here, using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have

ubus call system board; \
uci export network; \
ip -4 addr ; ip -4 ro li tab all ; ip -4 ru
2 Likes
{
        "kernel": "5.15.127",
        "hostname": "OpenWrt",
        "system": "AMD EPYC 7302 16-Core Processor",
        "model": "VMware, Inc. VMware20,1",
        "board_name": "vmware-inc-vmware20-1",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "23.05.0-rc3",
                "revision": "r23389-5deed175a5",
                "target": "x86/64",
                "description": "OpenWrt 23.05.0-rc3 r23389-5deed175a5"
        }
}
package network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'

config device
        option name 'br-lan'
        option type 'bridge'
        option ipv6 '1'
        option mtu '9000'
        list ports 'eth0'
        list ports 'eth1'
        list ports 'eth2'
        option multicast '1'
        option igmp_snooping '1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '10.10.10.1'
        option netmask '255.255.255.0'
        option ip6assign '64'


config interface 'wan'
        option proto 'pppoe'
        option device 'eth3'
        option username '073091563822'
        option password '080123'
        option ipv6 'auto'
        option peerdns '0'
        option delegate '0'
        list dns '223.5.5.5'
        list dns '119.29.29.29'

config device
        option type '8021q'
        option ifname 'eth3'
        option vid '45'
        option name 'eth3.45'
        option ipv6 '1'
        option macaddr '70:BC:6A:40:79:74'

config interface 'iptv'
        option proto 'pppoe'
        option device 'eth3.45'
        option username 'zz0423426sd5@VOD'
        option password '434516@a'
        option ipv6 '0'
        option defaultroute '0'
        option delegate '0'

config device
        option name 'eth0'
        option mtu '9000'
        option ipv6 '1'

config device
        option name 'eth2'
        option mtu '9000'
        option ipv6 '1'

config device
        option name 'eth1'
        option mtu '9000'
        option ipv6 '1'

config device
        option name 'eth3'
        option ipv6 '1'

config device
        option name 'eth4'
        option ipv6 '1'

config device
        option name 'pppoe-iptv'
        option ipv6 '1'

config device
        option name 'pppoe-wan'
        option ipv6 '1'

config interface 'onu'
        option proto 'static'
        option device 'eth3'
        option force_link '0'
        option ipaddr '10.10.1.100'
        option netmask '255.255.255.0'
        option defaultroute '0'
        option delegate '0'

config route
        option interface 'iptv'
        option target '175.10.54.0/24'

config route
        option interface 'iptv'
        option target '124.232.231.0/24'

config route
        option interface 'iptv'
        option target '10.255.9.0/24'

config route
        option interface 'iptv'
        option target '10.255.25.0/24'

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
5: eth3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    inet 10.10.1.100/24 brd 10.10.1.255 scope global eth3
       valid_lft forever preferred_lft forever
7: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 9000 qdisc noqueue state UP group default qlen 1000
    inet 10.10.10.1/24 brd 10.10.10.255 scope global br-lan
       valid_lft forever preferred_lft forever
9: pppoe-iptv: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1492 qdisc fq_codel state UNKNOWN group default qlen 3
    inet 10.170.15.165 peer 10.170.8.1/32 scope global pppoe-iptv
       valid_lft forever preferred_lft forever
10: pppoe-wan: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1492 qdisc fq_codel state UNKNOWN group default qlen 3
    inet 175.1.89.68 peer 175.1.89.1/32 scope global pppoe-wan
       valid_lft forever preferred_lft forever
default via 175.1.89.1 dev pppoe-wan table 1 proto static
local default dev lo table 100 scope host
default via 175.1.89.1 dev pppoe-wan proto static
10.10.1.0/24 dev eth3 proto kernel scope link src 10.10.1.100
10.10.10.0/24 dev br-lan proto kernel scope link src 10.10.10.1
10.170.8.1 dev pppoe-iptv proto kernel scope link src 10.170.15.165
10.255.9.0/24 dev pppoe-iptv proto static scope link
10.255.25.0/24 dev pppoe-iptv proto static scope link
124.232.231.0/24 dev pppoe-iptv proto static scope link
175.0.80.1 dev pppoe-wan proto kernel scope link src 175.1.89.68
175.10.54.0/24 dev pppoe-iptv proto static scope link
local 10.10.1.100 dev eth3 table local proto kernel scope host src 10.10.1.100
broadcast 10.10.1.255 dev eth3 table local proto kernel scope link src 10.10.1.100
local 10.10.10.1 dev br-lan table local proto kernel scope host src 10.10.10.1
broadcast 10.10.10.255 dev br-lan table local proto kernel scope link src 10.10.10.1
local 10.170.15.165 dev pppoe-iptv table local proto kernel scope host src 10.170.15.165
local 127.0.0.0/8 dev lo table local proto kernel scope host src 127.0.0.1
local 127.0.0.1 dev lo table local proto kernel scope host src 127.0.0.1
broadcast 127.255.255.255 dev lo table local proto kernel scope link src 127.0.0.1
local 175.1.89.68 dev pppoe-wan table local proto kernel scope host src 175.1.89.68
0:      from all lookup local
32765:  from all fwmark 0x1 lookup 100
32766:  from all lookup main
32767:  from all lookup default

while uci -q delete network.@rule[0]; do :; done
while uci -q delete network.@route[0]; do :; done
uci -q delete network.onu.defaultroute
uci -q delete network.iptv.defaultroute
uci set network.lan.ip4table="1"
uci set network.onu.ip4table="2"
uci set network.iptv.ip4table="3"
uci -q delete network.lan_iptv
uci set network.lan_iptv="rule"
uci set network.lan_iptv.in="lan"
uci set network.lan_iptv.dest="172.130.0.20/32"
uci set network.lan_iptv.lookup="3"
uci set network.lan_iptv.priority="30000"
uci commit network
/etc/init.d/network restart
2 Likes

Thanks I'll try it

1 Like

Please delete the usernames and passwords from your configuration post above.

1 Like

The above account password address has been modified.

2 Likes