IPTV / UDP multicast problem

Hello,
i'm using a BPI-R3 with OpenWrt 23.05.2.
I'm trying to view my ISP's iptv network stream in VLC.
So I installed igmpproxy as explained here
Unfortunately it doesn't work. I was told that this string should work in VLC rtp://233.136.0.202:7500/202 and it doesn't.

So here is my configuration :

/etc/config/igmpproxy :

config igmpproxy
	option quickleave 1
	option verbose 3

config phyint
	option network wan
	option zone wan
	option direction upstream
	list altnet 0.0.0.0/0

config phyint
	option network lan
	option zone lan
	option direction downstream

/etc/config/network :

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'
	list ports 'sfp2'

config interface 'lan'
	option device 'br-lan'
	option igmp_snooping 1
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

as you can see option type 'bridge' is not set in the interface lan but in the device, not sure sure if it changes something, but as the tutorial said to add the option igmp_snooping 1 in lan I've done as they say.

also i can see this in the tutorial :

In older versions of igmpproxy it used to require firewall rules. However current versions insert the rules automatically during start-up of the igmpproxy daemon

unfortunately, i don't see any rule added in the firewall...is it because I have firewall4 so nftables?

Thank you for helping

In my experience, VLC can indeed do multicast, but it doesn't make IGMP subscription requests needed for the igmpproxy. YMMV.

Is your IPTV provider the one who told you the URI would work?

I would suggest trying quickleave 0.

no, it's a guy with the same ISP as me and using debian as a router. from his home, that link works in VLC.

And here is how he configured his igmpproxy

quickleave

phyint enp2s0 upstream  ratelimit 0  threshold 1
	altnet 77.128.0.0/9
	altnet 224.0.0.0/8

phyint lan0 downstream  ratelimit 0  threshold 1
	altnet 192.168.1.2/24

phyint wlp4s0 disabled
phyint lo     disabled
1 Like

additionaly here is my firewall rules, i don't see anything new added in it since i installed igmpproxy :

Edit:
i found where the rules landed in Luci, i can see them in STATUS>>FIREWALL

i can see this in my logs : can't join group 233.136.0.202 on interface br-wan; Errno(98): Address in use

Sat Jun  1 13:23:52 2024 user.notice igmpproxy[7039]: RECV Membership query   from 192.168.1.1     to 233.136.0.202
Sat Jun  1 13:23:52 2024 user.notice igmpproxy[7039]: RECV V2 member report   from 192.168.1.10    to 233.136.0.202
Sat Jun  1 13:23:52 2024 user.debug igmpproxy[7039]: Should insert group 233.136.0.202 (from: 192.168.1.10) to route table. Vif Ix : 0
Sat Jun  1 13:23:52 2024 user.info igmpproxy[7039]: Updated route entry for 233.136.0.202 on VIF #0
Sat Jun  1 13:23:52 2024 user.debug igmpproxy[7039]: Joining group 233.136.0.202 upstream on IF address 192.168.20.1
Sat Jun  1 13:23:52 2024 user.notice igmpproxy[7039]: Joining group 233.136.0.202 on interface br-wan
Sat Jun  1 13:23:52 2024 user.warn igmpproxy[7039]: can't join group 233.136.0.202 on interface br-wan; Errno(98): Address in use
Sat Jun  1 13:23:52 2024 user.debug igmpproxy[7039]: Joining group 233.136.0.202 upstream on IF address 93.22.XX.XX
Sat Jun  1 13:23:52 2024 user.notice igmpproxy[7039]: Joining group 233.136.0.202 on interface br-wan
Sat Jun  1 13:23:52 2024 user.warn igmpproxy[7039]: can't join group 233.136.0.202 on interface br-wan; Errno(98): Address in use

and here is a tcpdump

root@OpenWrt:~# tcpdump -i br-wan igmp
tcpdump: verbose output suppressed, use -v[v]... for full protocol decode
listening on br-wan, link-type EN10MB (Ethernet), snapshot length 262144 bytes
13:42:14.472896 IP 192.168.20.1 > 233.136.0.202: igmp v2 report 233.136.0.202
13:42:15.812889 IP 192.168.20.1 > 233.32.36.161: igmp v2 report 233.32.36.161
13:42:18.109196 IP one.one.one.one > all-systems.mcast.net: igmp query v2
13:42:18.432900 IP 192.168.20.1 > 233.136.0.202: igmp v2 report 233.136.0.202
13:42:24.572968 IP 192.168.20.1 > 239.255.255.250: igmp v2 report 239.255.255.250
13:42:25.212889 IP 192.168.20.1 > 233.32.36.161: igmp v2 report 233.32.36.161
13:42:28.216225 IP 192.168.20.1 > all-routers.mcast.net: igmp leave 233.32.36.161
13:42:28.310807 IP one.one.one.one > 233.32.36.161: igmp query v2 [max resp time 4] [gaddr 233.32.36.161]
13:42:28.710590 IP one.one.one.one > 233.32.36.161: igmp query v2 [max resp time 4] [gaddr 233.32.36.161]
13:42:29.110694 IP one.one.one.one > 233.32.36.161: igmp query v2 [max resp time 4] [gaddr 233.32.36.161]
13:42:48.108512 IP one.one.one.one > all-systems.mcast.net: igmp query v2
13:42:57.212946 IP 192.168.20.1 > 239.255.255.250: igmp v2 report 239.255.255.250
13:42:57.212973 IP 192.168.20.1 > 233.136.0.202: igmp v2 report 233.136.0.202
13:43:18.104342 IP one.one.one.one > all-systems.mcast.net: igmp query v2
13:43:20.492911 IP 192.168.20.1 > 233.136.0.202: igmp v2 report 233.136.0.202
13:43:27.933058 IP 192.168.20.1 > 239.255.255.250: igmp v2 report 239.255.255.250

Can we see the whole network config?

Is there a reason WAN is placed in a bridge?

i have a BPI-R3
image

ETH1 is an SFP port and it is bridged with the WAN port which is RJ45.

I have an ONU inserted in Eth1, to connect to my ISP. i made an interface called "onu" in order to manage it on the ip address 192.168.20.1

My network is on 192.168.1.0/24

My network config :

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd3f:f494:0214::/48'
	option packet_steering '1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'
	list ports 'sfp2'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option igmp_snooping 1
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device
	option name 'br-wan'
	option type 'bridge'
	list ports 'eth1'
	list ports 'wan'

config device
	option name 'eth1'
	option macaddr 'ce:a4:39:bd:8a:9a'

config device
	option name 'wan'
	option macaddr 'ce:a4:39:bd:8a:9a'

config interface 'wan'
	option device 'br-wan'
	option proto 'dhcp'
	option vendorid 'neufbox_BANANAPI-R3'
	option reqopts '1 3 6 12 14 15 17 28 40 42'
	option ipv6 '1'
	option peerdns '0'
	list dns '8.8.8.8'
	list dns '8.8.4.4'
	list dns '1.1.1.1'

config interface 'wan6'
	option device 'br-wan'
	option proto 'dhcpv6'
	option peerdns '0'
	option reqaddress 'try'
	option defaultreqopts '0'
	option reqopts '23 25 26'
	option noclientfqdn '1'
	option noacceptreconfig '1'
	list dns '2001:4860:4860::8888'
	list dns '2001:4860:4860::8844'
	option reqprefix 'auto'

config interface 'onu'
	option proto 'static'
	option device 'br-wan'
	option netmask '255.255.255.0'
	option ipaddr '192.168.20.1'

I've just reinstalled my ISP's router and it works. so there's no problem on my PC either...it's in the BPI-R3 configuration that something's wrong...

i found the culprit : it's my ONU SFP...
i removed it and used my ISP external ONT in the wan port (RJ45) and it worked immediatly.

1 Like

i just found this about what could be the reason :

followed by this message :

1 Like