Hi,
I'm curious, I want to use an aruba 303 that also have de Qualcomm IPQ4029 and has also good memory and flash. I want to use it with vlans, is this issue and Qualcomm IPQ4029 issue, or only in an MR33?
Its the same SoC, but you can use the DSA PR and have the working VLAN-s.
AP303 is already converted there
1 Like
mpa
February 7, 2022, 5:29pm
44
Driver-level VLANs are working fine on my AP-303, which is running stable OpenWrt 21.02.x.
Neither swconfig
nor DSA patches are required.
Good to hear.I hope to buy the aruba ap11and play with it the vlans , and does bluetooth also work?
ok, is the 303H also converted?
What do you mean wirth DSA PR? Is this another image?
I dont think that 303H was converted.
DSA PR is here:
openwrt:master
← sartura:ipq40xx-dsa
opened 05:32PM - 25 Oct 21 UTC
This PR is a WIP draft for adding a working ethernet + DSA driver along with som… e PHY SFP improvements.
Ethernet driver is an updated and fixed version of the IPQESS driver that has been in various trees.
DSA driver is based on an older qca8k driver to which IPQ40xx specific stuff was added based on even older modified qca8k that was lingering in the same trees as the IPQESS.
DSA driver itself lacks some features that newer qca8k has like VLAN offloading but that is something that I plan on adding.
The code also isn't upstream ready due to various hacks that are specific to the IPQ40xx in regards to PSGMII.
Driver combo works surprisingly well, however it has one bug that doesn't always present itself.
The issue is that PSGMII PHY-s won't calibrate on some boots, this happens really randomly.
I have only added conversion of Jalapeno board as an example, however, I will add a few more.
Note that I don't know if RGMII works properly as I don't have any board using it.
This patch series is based on the following tree:
https://github.com/sartura/linux/tree/ipq40xx/linux-v5.10.8-DSA
It can be referenced to see the actual development in individual commits as I slightly cleaned up some things when preparing for OpenWrt submission and those are not yet reflected in our public kernel tree.
I will rebase on 5.14.14 which we are using internally and publish with OpenWrt changes.
You can see that there were actually 3 working taggers added but I only included the shinfo one which has the lowest overhead.
I find the driver combo usable, but the code requires some work regarding features and a decent cleanup.
We are publishing it in hopes that by working with the community we can eventually get support for wired networking
upstream and that will complete IPQ40xx support upstream as the only major subsystem missing.
So since the driver combo has been really fixed up I think that we need to convert all of the boards to get this merged.
So, to track that let's add a checklist:
- [x] 8devices Habanero
- [x] 8devices Jalapeno
- [ ] Alfa AP120C-AC
- [x] Aruba AP-303
- [ ] Aruba AP-303H
- [ ] Aruba AP-365
- [ ] Asus Lyra (MAP-AC2200)
- [ ] Asus RT-AC42U
- [x] Asus RT-AC58U
- [x] AVM FRITZ!Box 4040
- [x] AVM FRITZ!Box 7530
- [ ] AVM FRITZ!Repeater 1200
- [ ] AVM FRITZ!Repeater 3000
- [ ] Buffalo WTR-M2133HP
- [ ] Cell C RTL30VW
- [ ] Crisis Innovation Lab MeshPoint.One
- [ ] Compex WPJ419
- [ ] Compex WPJ428
- [ ] devolo Magic 2 WiFi next
- [ ] D-Link DAP-2610
- [ ] Edgecore ECW5211
- [ ] Edgecore OAP100
- [ ] EnGenius EAP1300
- [ ] EnGenius EAP2200
- [ ] EnGenius EMD1
- [ ] EnGenius EMR3500
- [ ] EnGenius ENS620EXT
- [ ] EZVIZ CS-W3-WD1200G
- [ ] GL.iNet GL-AP1300
- [x] GL.iNet GL-B1300
- [ ] GL.iNet GL-B2200
- [ ] GL.iNet GL-S1300
- [x] Linksys EA6350
- [ ] Linksys EA8300
- [ ] Linksys MR8300
- [ ] Luma Home WRTQ-329ACN
- [x] Cisco Meraki MR33
- [ ] MobiPromo CM520-79F
- [ ] NETGEAR EX6100 v2
- [ ] NETGEAR EX6150 v2
- [ ] NETGEAR RBR50
- [ ] NETGEAR RBS50
- [ ] NETGEAR SRS60
- [ ] NETGEAR WAC510
- [ ] OpenMesh A42
- [ ] OpenMesh A62
- [ ] P&W R619AC
- [ ] Plasma Cloud PA1200
- [ ] Plasma Cloud PA2200
- [ ] Qualcomm Atheros AP-DK01.1 C1
- [ ] Qualcomm Atheros AP-DK04.1 C1
- [ ] Qxwlan E2600AC C1
- [ ] Qxwlan E2600AC C2
- [ ] Teltonika RUTX10
- [ ] Unielec U4019
- [x] ZyXEL NBG6617
- [ ] ZyXEL WRE6606
- [x] MikroTik hAP ac2
- [x] MikroTik hAP ac3
- [ ] MikroTik Wireless Wire Dish LHGG-60ad
- [ ] MikroTik SXTsq 5 ac
I got issues with the vlans with the cpus en ehternetports and vlans . The devices has 2 cpu's and 4 ethernet ports. In openwrt eth0 on the fysical device (POE) is the wan port. So the wan port should be the normal lan port , but with the vlans I can't solve it. So I hoped that maybe this issue is resolved also with this?
I have this issue posted here
Hi,
I successfuly flashed my aruba-303h. The 303h has 4 ethernet ports, so thats is a 4 port switch. The default config makes also a wan port. Has anybody a config to have all for ports in the switch and I can tagged them in de luci interface. I want to be my ap manage on 192.168.199.100/24
this is de defaulf config I get when it is flashed. I only want nog to connect eth0, because this one is powered wtih poe.
config interface 'loopback'
option device 'lo'
option proto 'static'
option ip…
I don't really understand, but IPQ40xx only has one 1Gbit Full duplex CPU ethernet uplink, everything user-facing is just the switch interfaces.
I am just telling you that with DSA VLAN-s work fine even on multiport devices
ok. Is it possible to have the patch also for the 303h applied?
Sure, anybody can contribute to the conversion list
Hi,
I'm trying on my 303h the same, but de dhcp request doesn't work. Do you have an example with driver-level vlans?
here is the config I use. This works on my older aruba ap-105
root@OpenWrt:/etc/init.d# cat /etc/config/network
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fd41:d718:0624::/48'
config device
option name 'br-lan'
option type 'bridge'
list ports 'eth1'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.199.199'
option netmask '255.255.255.0'
option gateway '192.168.199.254'
option ip6assign '60'
list dns '192.168.180.254'
option delegate '0'
config device
option name 'br-vlan10'
option type 'bridge'
option ipv6 '0'
list ports 'et1.10'
config interface 'vlan10'
option proto 'none'
option device 'br-vlan10'
option delegate '0'
mpa
February 13, 2022, 10:40pm
53
I cannot say anything about the 303h.
This is my config for the AP11/AP-303 (the model without 'h'):
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fdXX:XXXX:XXXX::/48'
config device
option name 'eth0.1'
option type '8021q'
option macaddr 'XX:XX:XX:XX:XX:fe'
option ifname 'eth0'
option vid '1'
config device
option name 'eth0.2'
option type '8021q'
option macaddr 'XX:XX:XX:XX:XX:ff'
option ifname 'eth0'
option vid '2'
config device
option name 'br-lan'
option type 'bridge'
option macaddr 'XX:XX:XX:XX:XX:fe'
list ports 'eth0.1'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr 'ddd.ddd.ddd.ddd'
option netmask '255.255.255.0'
option ip6assign '60'
config interface 'wan'
option device 'eth0.2'
option proto 'dhcp'