Hi,
I successfuly flashed my aruba-303h. The 303h has 4 ethernet ports, so thats is a 4 port switch. The default config makes also a wan port. Has anybody a config to have all for ports in the switch and I can tagged them in de luci interface. I want to be my ap manage on 192.168.199.100/24
this is de defaulf config I get when it is flashed. I only want nog to connect eth0, because this one is powered wtih poe.
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fd9c:31e2:22d0::/48'
config device
option name 'br-lan'
option type 'bridge'
list ports 'eth0'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.199.100'
option netmask '255.255.255.0'
option gateway '192.168.199.254'
option ip6assign '60'
config interface 'wan'
option device 'eth1'
option proto 'dhcp'
config interface 'wan6'
option device 'eth1'
option proto 'dhcpv6'
config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'
config switch_vlan
option device 'switch0'
option vlan '1'
option ports '2 3 4 0'
config switch_vlan
option device 'switch0'
option vlan '2'
option ports '5 0'
Presumably logical port 5 is your device's WAN or PoE-in port (as labeled on the case). This will put it onto the same network as the other 3 ports:
config switch_vlan
option device 'switch0'
option vlan '1'
option ports '2 3 4 5 0'
config switch_vlan
option device 'switch0'
option vlan '2'
option ports '0'
Hi port on the back is also eth0 of you can use the other as eth0.
I noticed that connecting eth0 , also eth1 gets dhcp form my lan port. Should I bridge eth0 and eth1 , and remove the config interface wan?
Good point.
Maybe I gave you bad advice. It depends on how the device is actually designed.
If what I suggested above doesn't work, then add eth1 to the br-lan definition.
like this?
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fd9c:31e2:22d0::/48'
config device
option name 'br-lan'
option type 'bridge'
list ports 'eth0'
list ports 'eth1'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.199.100'
option netmask '255.255.255.0'
option gateway '192.168.199.254'
option ip6assign '60'
config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'
config switch_vlan
option device 'switch0'
option vlan '1'
option ports '1 2 3 4 0'
config switch_vlan
option device 'switch0'
option vlan '2'
option ports '5 0'
Hi,
That works. thnx.
I only get in the web interface an error going to the interface
RPCError
RPC call to uci/get failed with ubus code 9: Unspecified error
at handleCallReply (http://192.168.199.100/luci-static/resources/rpc.js?v=git-21.295.67054-13df80d:15:3)
tried antoher browser, it get some other additianol info going to interfaces
RPCError
RPC call to uci/get failed with ubus code 9: Unspecified error
at ClassConstructor.handleCallReply (http://192.168.199.100/luci-static/resources/rpc.js?v=git-21.295.67054-13df80d:15:3)
I'm not sure what would cause that error.
What version of OpenWrt are you running? What have you changed aside from the edits to the configuration that we have addressed here? Did you install or upgrade any packages?
Hi,
I used the latest OpenWrt 21.02.1 r16325-88151b8303
I didn't change anything I think. I could perform a reset and only change the network config and check if it helps.
It is only when going to network - interfaces.
Try resetting and then adjusting the network file (manually) again.
ok, that was the trick..
I hoped to see the other network ports with dsa, but nothing is there. Should I change the config to have the ports in the luci gui to add/ change the vlans on the 4 ports?
Or should I add all the ports in the bridge?
LuCI vs CLI should yield the same results, so it doesn't matter how you achieve the goal.
You want to remove the WAN interface and then add eth1 to the br-lan. Obviously you also need to update the LAN IP address info, too.
From the looks of it, your device is likely still swconfig based (not DSA) -- I say that because you still have some "switch" stanzas in the config file.
Hi,
I found the switch support in the GUI, only there is back the WAN port. I made an extra vlan for my wireless. I didn't work. When I tagged the vlan also on de WAN port it worked, but also my whole my network was slow, also clients not connected on the aruba openwrt device.
Is it possible to have the WAN port with the switch also as LAN port? Now cpu eth0 and cpu eth1 and WAN is 1 port physical. That port is also the port that need POE to power the device, so it should be nice to have this as LAN port