[IPQ40XX] NBG6617: WAN connectivity loss when VLANs are added?

I recently set up a ZyXEL NBG6617 with OpenWrt master (now on the most recent 19.07 branch). My friends have an 'triple play' ISP that also offers TV decoders, which require a WAN connection to be fully functional. They had a WNDR3700 where I had bridged two LAN ports with the WAN port; that worked fine for those purposes.

So I halved the default VLAN on the NBG6617 thinking it would be a walk in the park just like on the WNDR3700... Quod non. Somehow, despite not touching the eth1 WAN interface, as soon as I create a second VLAN, the WAN interface fails to connect.

I am seeing the following behaviour:

  • Just one VLAN: everything works fine. WAN connects just fine.
  • Add a second VLAN: seems to work; but WAN does not connect anymore. I thought maybe it might be a VLAN ID issue (some switches seem to have that), so set VID 100 for the new VLAN instead of VID 2, but no difference either. It doesn't seem to matter whether I tag the CPU in VLAN 1 as well once I add a second VLAN; behaviour stays the same.
  • WAN (eth1) and LAN (eth0) seem to have some interplay but I'm unable to find out how and what.

Anybody seen something similar with ipq40xx or know how to fix/work around this?

Thank you!

I haven't yet catalogued what works and doesn't work with the "stock" implementation of the switch and Ethernet combinations yet.

Not yet, short of patching out the VLAN tagging in the source code. DSA/qca8k/ipqess was not the answer, at least as of a couple months ago. At that time, even upstream Linux on 5.x had not figured out how to deal with VLANs (at all), or with dual-MAC devices.

1 Like

Thanks. I just tried setting up SQM and I'm seeing all kind of weirdness there as well, probably because of that funky network layout...

Does it mean that it is impossible to separate the switch in 2 vlans at the moment? I ordered the device, but I need vlans badly.

Try to set the CPU port to "tagged" fro both VLANs.

1 Like