IP-phone and siproxd

Hello Forum,

I have a Fritzbox 4040 running as my OpenWrt router/firewall.
The internet-connection is done by a Fritzbox 7490. That one handles also my IP-Phones.
On a client behind the firewall I have a softphone running (PhoneLite). The config workes fine so far, but using the softphone each call breakes down after about 10 minutes.
So i tried to install siproxd on openwrt. But I can't get it running.
Can anyone tell me the right configuration, so that my softphone can regisert itself to the 7490 ?
Thanks in advice

Can you clarify your network description? You have IP devices plugged into both the Fritzboxen i.e. some before and some after the firewall? What is the network function of each? Is there double FW/NAT happening? Without knowing more it's hard to speculate on the problem, and it's not obvious siproxd would solve anything.

That fact each call initially works (inbound? outbound?) suggests call setup isn't being impaired by NAT problems. And if every call drops after ten minutes, it sounds more like a SIP or session timer somewhere in your stack (app, OS, Fritzbox, VOIP provider). Maybe double-check all the configuration settings for a timeout.

You mentioned "regisert itself to the 7490". Are you saying that box is a SIP Proxy and accepts registrations? Then how are your IP-Phone vs PhoneLite configurations set up?

What does that mean exactly? Crash? Install problem? The default configuration for siproxd should work "out-of-box". Usually all that's needed is to configure the SIP client (PhoneLite) and set its "SIP Outbound Proxy" to point to the siproxd router IP. You could try that, but it doesn't seem like a NAT problem from the little I can see.

1 Like

Hi guidosarducci,
thanks for your quick reply. Let me try to get things more clear.
The FB 7490 handels my Phones. PhonerLite is configured as a IP-Telephone with a user and a PW. So In PhonerLite the IP of the 7490 ist configured as Proxy/Registrar. That worked absolutely fine before having openwrt in place (as long as the PC was within the same net as the 7490 - no double NAT.
Now, there is double NAT for the PC with phonerlite is behind the firewall. Ports needed are open. When I start Phoner lite (still with the 7490 as Proxy/registrar) the status is "sip:username@fritz.box registered". Looks good. Phone calls wort (in- and outbound), but after some minutes I get disconnected.
So, I tried to install siproxd to get a stable connection. But I'm not shure how to configure siproxd and what to change in PhonerLite

Thanks, that's a little clearer now. I'll be honest and say it's unlikely you have a simple NAT problem, and therefore I doubt siproxd could even be useful, given that:

  1. you've already set up SIP port forwarding to your PhonerLite client, and
  2. you can receive all inbound calls and can place all outbound calls, and
  3. this was all working before even trying to set up a SIP ALG like siproxd.

If you google "voip call drops after 10 minutes" you'll find a lot of the same issues coming up, all unrelated to NAT traversal. Doesn't the "Faulty SIP Timers" section in this link sound like your issue:

Or the "Malfunctioning SIP Session Timers" here:


I suggest you uninstall siproxd or any nat-helper kernel modules, and start with google and review of your SIP settings: both on your 7490 and/or your VOIP provider. Look for things like: SIP invite/update/reinvite, session-expires, session timer.

1 Like

Thanks a lot for you answer.
I found an option to set the timeout in PhonerLite (that was at 900) and raised it to 2000. Now I can test. The strange thing still is, that there were no timeout problems before implementing the firewall. But anyway, it's worth a try.
What I managed to get to work also is directly connect to my SIP-Provider, not to the FB 7490. So now, it's testing time...
Thanks again

Great, that sounds like a better approach. Just be careful not to change too many things at the same time since that will obscure your test results. Perhaps test your timeout change and SIP provider change separately, as the latter could easily introduce new network traversal problems...

1 Like

absolutely. The good thing is, that I can configure several profiles in PhonerLite, so each approach can be tested seperately