Iopsyswrt (openWrt derivate) build unsuccessful

Hi devs,

I am looking to build iopsyswrt, which is based on OpenWRT.
It fails within the process with

make[8]: *** No rule to make target 'libatmctl.so_arm.shipped', needed by ''.  Stop.

I believe it is part of the bcmopen packages available here:

Tried multiple versions (targeting bcmopen-EG400-6.0-latest) of it with multiple servers (ubuntu16 and ubuntu20). All the same result.

Looking into the problematic package, I have the following structure:
trying to build it directly, I get the same output.

From what I know about makefiles, I can not find anything that would relate to the original error.

Any ideas from someone on this?

Let me know if you need to have a look at the makefile or anything else.

That is something you need to ask IOPSYS, not OpenWrt - we are not privy to their proprietary SDK and even less Broadcom's binaries


I know that it is not OpenWrt specific. It's more of a general build / make issue. (I doubt it's a source code problem / bug, as the corresponding driver exists for quite some months)

I could also have asked this at stackoverflow etc. but decided I'd find more specific experts over here.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.