Iomega old StorCenter IX2 rs232 SERIAL pin layout UNKNOWN

hello from Italy: I need help
I'm trying to revive and nstall on it the open WRT on an old Iomega IX2 Storcenter first version NOT THE IX2-200.
I woult to connect the pc with the iomega's board using the serial connection but all the guides availbale on the planet earth are about the fu**y IX-2 200.
I need to know the exact PIN LAYOUT for to connect it.
Is there someone on the planet earth that before of me has tried to revive this old Nas?
Apparently ALL the mankind has used only the ix2-200!!!
Thanks in advance to everyone

Hey, serial pinout for kirkwood devices is almost always the same, 4pin header, pin 1 GCC, then TX, GND, RX.
I've had a few kirkwoods, including the IX2-DL that I made openwrt for and they all had that pinout.

The iconnect wiki page should help.

Or there's tons more kirkwood info on the doozan linux forum.

The 2x5 pin 2.54mm header suspiciously looks like the standard PC RS-232 motherboard connector. I doubt the device will have real RS-232, but maybe pinout is similar?

What I would do is this:

  1. Find all pins of the this 2x5 pin connector which are directly connected to GND using multimeter and measuring resistance e.g. to USB connector shield which should also be GND.
  2. Measure voltage on all other pins, exclude everything above 3.3V.
  3. Connect 3.3V-level TTL serial adapter GND---GND and then try all non-GND pins without voltage level above 3.3V as potential TX from the StorCenter by connecting it to RX of the serial adapter. Use terminal with 115200 baud 8N1 which is the typical setting for all Marvell ARM SoCs.
  4. Once you found TX pin (ie. you get to see Iomage U-Boot and maybe Linux starting), continue with probing for the RX pin by connecting TX of the serial adapter to any of the remaining non-GND pins without high voltage level, starting with the direct non-GND, <=3.3V neighbors of the TX pin you just found then power on the board, then try to interrupt U-Boot or type things on Linux console once the device finished booting.

In this way you should find the pinout without risking to destroy anything and without wasting too much time on it.

Were you able to figure this out? I got exactly the same device, the original ix2, not the ix2-200. It did not come with any disks. It is currently flashing the blue light for me and does not seem to boot. I am trying to revive it.

Ix2 loads its firmware from the drives and has very minimal flash space, you would need to load openwrt from a mounted drive.

Lenovo had a rescue usb you could use, but that could be gone by now.

Serial console access is easy though

1 Like

Figured out the serial console JCOM1:
Looking from the top of the board, with the USB ports facing right:

    • <-- GND
    • <-- TX (goes to pin 1 of my Arduino)
    • <-- RX (goes to pin 0 of my Arduino)

After doing that, and shorting RST and GND on the Arduino, I can talk to the Iomega board via PuTTY

And yes figured out that much about ix2 reading its firmware from disks :frowning: Amazing design...
Anyways, was able to find the 2.0.18 firmware on the Lenovo board, and some scripts on Github that promise to do some further work on it; poking more.

I do not know, the my iomega board switch automatically OFF COSTANTLY after around 2 minutes, 2 and half minutes. the blue led pulse. after two minutes or what is blink red led then GO OFF.
I can't do nothing.
I don't understand if this a feature of the logic board or a fault.
I connected the usb to 3,3 little connector to iome ha but get nothing.

As you've already got serial don't bother restoring the lenovo software, it's ancient, bug ridden and slow. These boxes work great with the arm version of debian, check the doozan forum for a guide (pretty straightforward).
Or create an openwrt build to suit, also not that hard, you can use the files on my github as a starting point. Only change needed is to mount the rootfs from sata instead of flash.

Thanks! I almost got there - got it to the point of reading the kernel off IDE as, apparently, the stock U-Boot doesn't support loading from USB. That's when I decided to update flash and bricked it :(. It still kicks off U-Boot after a powercycle, but halts the boot process when U-Boot fails to read flash - and there seems to be no way to get back to the U-Boot prompt; I've tried Esc, Alt-Z, and some other key combos to no avail.

Before I bricked it, mine used to just blink the blue light, without stopping or rebooting. The serial output showed that it was successfully reading the Linux kernel from flash, booting it, but was failing to read the firmware off the first RAID partition on the non-existent HDD

@jdwl1o1 thanks a lot, I did look at your github - it seems to be for a slightly newer ix2. Mine (and I believe @italian_o 's ) seems to be older, it's what other sites refer to as a Gigabit ix2

uBoot issues on the IX2s are challenging as the exposed uart isn't uart1 - which means you're unlikely to be able to load uboot via kwboot.

If uboot is corrupt your only option might be removing the flash and writing it in a programmer.

an image is better:
this is the my iomega nas: