Internet stops working when I try to change the MAC of the router

As far as I know, the only way to tell my ISP to change my public IP address is to change the MAC address of the router. It worked with the old official firmware of the the router. Now, I want to do the same thing with OpenWrt, but I have problems.

I opened the web administrator, and navigated to Network -> Interfaces -> WAN -> Advanced Settings -> Override MAC address, and tried a few random MAC I had gotten from MAC-generator websites. But when I changed the MAC, the Internet connection stopped. LAN works (that is, I can access other computers on my home network), but I cannot access any public websites such as Google. Rebooting the router had no effect. And most annoyingly, it did not restore the Internet connection even to clear the "Override MAC address" field and reboot. The only way was restoring backed-up configurations.

Was my way of changing the MAC wrong? Or is this a bug? Or is this a specific problem of my ISP? What is the correct way to tell a fake MAC address to the ISP?

It seems like either a bug. Even changing the "Hostname to send when requesting DHCP" caused the same problem. I reset the configuration and started from scratch. Now changing the MAC does not stops the Internet connection.

Two things to consider:

  • your ISP might lock to your router's MAC address, temporarily (to prevent you from logging in twice) or semi-permanently (as questionable authentification mechanisms, requiring manual interventions from the ISP)
  • your random MAC address might not be valid, as there are syntax rules to consider (for testing, start with just changing the last octet).

There's also a bug in LuCI which prevents to assign MAC address properly, though I'm not sure if it is still relevant: