Hey,
i have Dell 4G LTE modem plugged in via USB. It was previously working fine with the same /etc/onfig/network on another hardware and older (19.xx) OpenWrt version.
Now I've migrated to x86 hardware (previously arm) and new OpenWrt version (OpenWrt SNAPSHOT r24414-255d5c9bf8 - self compiled because I needed to patch MHI PCI driver for my upcoming new 5G modem).
The problem is that after the reboot, though wwan interface exists and shows IP address from the network and gateway - there is not internet. Ping does not reach gateway or any address from the internet
If I go into the luci interface and click restart on the wwan interface - everything starts working
Another difference from 19.xx is that I now have some kind of virtual wwan_4 interface?
Any tips on troubleshooting that?
This is the UI after reboot (it shows packets moving, it seems that wireguard established tunnel connection, but ping/traceroute does not work from the OpenWrt:
And this is how it looked on the previous version:
Routing table:
# X.Y.Z.H - wireguard remote tunnel IP
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
0.0.0.0 100.89.211.160 0.0.0.0 UG 0 0 0 wwan0
X.Y.Z.H 100.89.211.160 255.255.255.255 UGH 0 0 0 wwan0
10.5.0.0 0.0.0.0 255.255.255.0 U 0 0 0 wg0
100.89.211.128 0.0.0.0 255.255.255.192 U 0 0 0 wwan0
192.168.3.0 0.0.0.0 255.255.255.0 U 0 0 0 br-lan
my /etc/config/network:
config interface 'loopback'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
option device 'lo'
config globals 'globals'
option ula_prefix 'fdef:b43e:cdfe::/48'
config interface 'lan'
option proto 'static'
option ipaddr '192.168.3.1'
option netmask '255.255.255.0'
option ip6assign '60'
option device 'br-lan'
config interface 'wwan'
option ifname 'wwan0'
option proto 'mbim'
option device '/dev/cdc-wdm0'
option pdptype 'ipv4v6'
option apn '[redacted]'
option peerdns '0'
option auth 'none'
config device
option name 'br-lan'
option type 'bridge'
list ports 'eth0'
config interface 'wg0'
option proto 'wireguard'
option private_key '[redacted]'
option listen_port '51280'
list addresses '10.5.0.1/24'
config wireguard_wg0 'wgclient1'
option public_key '[redacted]'
list allowed_ips '10.5.0.0/24'
option endpoint_host '[redacted]'
option endpoint_port '51280'
option persistent_keepalive '25'
option route_allowed_ips '1'