Internet not working properly when extended to another router

Hello, I'm new to OpenWrt and networking stuff, so please forgive me if I use the wrong word/jargon.

So I'm using an x86 mini PC (without a wireless card) as an OpenWrt router and trying to extend the internet to a Deco x20 router as a wifi AP.

As I'm using a Japanese ISP with a v6plus (v6プラス) connection, I followed some Japanese blogs as a guide to make the v6plus work. But I'm not sure if that configuration is messing with the internet connection on the Deco router because if I'm using a PPPoE connection the internet is working fine on the Deco router but the speed is slower without the v6plus connection.

Here is my topology to describe what I'm doing right now:

OpenWrt version: 22.03.2
Kernel version: 5.10.146

and here is my network config:

# /etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd11:1d51:5627::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth1'
	list ports 'eth3'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ip6assign '60'
	list ipaddr '192.168.7.1/24'

config interface 'wan'
	option device 'eth0'
	option proto 'dhcp'

config interface 'wan6'
	option device 'eth0'
	option proto 'dhcpv6'
	option reqaddress 'try'
	option reqprefix 'auto'

config device
	option name 'eth0'

config interface 'wanmap'
	option proto 'map'
	option peeraddr '2404:9200:225:100::64'
	option ipaddr '14.10.0.0'
	option ip4prefixlen '15'
	option ip6prefix '240b:250::'
	option ip6prefixlen '31'
	option ealen '25'
	option psidlen '8'
	option offset '4'
	option legacymap '1'
	option tunlink 'wan6s'
	option maptype 'map-e'

config device
	option name 'eth1'

config interface 'wan6s'
	option proto 'static'
	option device '@wan6'
	option ip6prefix '240b:250:520:2600::/56'
	list ip6addr '240b:250:520:2600:62be:b4ff:fe06:2b2c'
	option ip6gw '240b:250:520:2600::1'

config interface 'deco'
	option proto 'static'
	option device 'eth2'
	option ipaddr '192.168.9.1'
	option netmask '255.255.255.0'

config route
	option interface 'deco'
	option target '192.168.68.0/22'
	option gateway '192.168.9.2'

I also got this in the system log:

kern.warn kernel: [ 2196.659267] ip6_tunnel: map-wanmap xmit: Local address not yet configured!

Any help is very much appreciated.
Thanks in advance!

lacunas,

welcome to this forum.
I persume eth0 is the connection between Internet and the OpenWrt PC.
Within your config the Deco X20 is on eth2, in the drawing it's eth1?
Also in your config: br-lan has port eth3, where or what is that? Should that not be eth2?

I don't understand why you use: config interface 'wanmap'

As far as I can see you only need eth0 (WAN) and 2 eth ports in br-lan (eth1 and eth2, LAN) in your config.
IoT router and Deco X20 are 'clients' of main OpenWrt PC. Deco X20 is wifi AP for other devices.

Why not use the Deco X20 as (AP) repeater? It's wan connection to an ethernet port on OpenWrt PC.
Like the other (IoT) router on the other ethernet port on OpenWrt PC.
All clients will get into the same LAN. Deco X20 has to pass-through dhcp requests to OpenWrt PC.

DG.

I'm not sure what v6plus is. Generally with modern equipment (no need for legacy support) you should run a direct v6 network with your endpoints receiving an IPv6 within the ISP's prefix. V4 only sites should be handled either dual stack or with NAT64 / 464xlat on the ISP end (to your endpoints, they are considered IP6 sites) The Deco network needs to be confgured with an ip6assign. As there are no further routers (see below), use 64 for this value.

The Deco system should be in AP or bridge mode, not acting as a router. This can be checked by checking that the IP addresses on the wifi devices have been issued by the OpenWrt x86 and appear in its (IPv4) DHCP lease table.