Internet issue in a mesh network

I have a wireless mesh setup of 3 routers using BATMAN Adv.
(My network looks something like this)


Initially device 2 is the only active member doing a video call and device 1 and 3 are idle members.
Then device 1 started playing a 4k video.
As soon as the 4k video started playing, the video call in device 2 started having problems(poor quality, going to reconnecting after every few minutes and sometimes so bad that a simple messages takes minutes to go) but when I do speed test it was shows me 40mbps(upload and download) with 3ms of ping and 6ms latency.

Am not sure what is the problem...??(My internet plan is 75mbps and doing speed test using gateway nodes gives me around 72mbps so streaming a 4k video shouldn't destroy my video call..)

This is my node configuration
/etc/config/network

##For gateway node 
#/etc/config/network
....
....

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1 bat0'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

....
....

config interface 'bat0'
	option proto 'batadv'
	option routing_algo 'BATMAN_IV'
	option aggregated_ogms 1
	option ap_isolation 0
	option bonding 0
	option fragmentation 1
	#option gw_bandwidth '10000/2000'
	option gw_mode 'off'
	#option gw_sel_class 20
	option log_level 0
	option orig_interval 1000
	option bridge_loop_avoidance 1
	option distributed_arp_table 1
	option multicast_mode 1
	option network_coding 0
	option hop_penalty 30
	option isolation_mark '0x00000000/0x00000000'

config interface 'nwi_mesh0'
	option mtu '2304'
	option proto 'batadv_hardif'
	option master 'bat0'
#node 2 and 3 
#evething is same only the lan part changes 
#/etc/config/network

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1 bat0'
	option proto 'dhcp'

/etc/network/wireless

#Same for all the 3 nodes
#/etc/network/wireless


config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11g'
	option path 'platform/10300000.wmac'
	option htmode 'HT40'
	option channel '6'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'Node_Wired'
	option key 'helloworld'
	option encryption 'psk2'

config wifi-device 'radio1'
	option type 'mac80211'
	option channel '36'
	option hwmode '11a'
	option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
	option htmode 'VHT80'

config wifi-iface 'wmesh'
	option device 'radio1'
	option ifname 'if-mesh'
	option network 'nwi_mesh0'
	option mode 'mesh'
	option mesh_id 'MeshCloud'
	option key 'MeshPassword123'
	option mesh_fwding '0'
	option mesh_ttl '1'
	option mesh_rssi_threshold '0'
	option encryption 'sae'

If any further details are required do let me know. I just wanna fix this issue.
Thank you.

which devices ?

how was the speed test made ?

is your connection symmetric ?

is there more than one gateway, you say nodes.

The device1 is a gaming laptop and device 2 and 3 are smartphones(honor view 10 and galaxy note 10).
I did the speed test using ookla and yes the connection is symmetric.
There is only one gateway and rest are acting as simple mesh nodes.

hw of the nodes, not the clients :slight_smile:

whoopsie :sweat_smile:
The nodes I have are tp-link archer c20 v5.(It's specification )

and if you connect device 2 to the gateway node, and repeat the exercise, do you get the same issue(s) ?

In that case it works just fine.

and the same happens if device 2 moves to the 3rd node ?

On the basis I have seen what looks very much like this problem on numerous occasions, I'll give my input...

Probable Scenario:
Device 1 is connected directly by ethernet to the router. It is playing a 4K "on demand" video stream. It will use the maximum bandwidth available to it to fill its media player buffers, optimally enough for 1 or 2 minutes of viewing. This will fully saturate the 72 Mb/s Internet feed in bursts every few seconds.

Device 2 is running a video call using webRTC or similar real time streaming with effectively no buffering. When Device 1 is streaming, Device 2 cannot maintain a continuous real time stream so stutters at best or disconnects at worst.

Solution (the one I use so know it works - but there are probably other ways):
Install SQM on the Internet router (gateway) with SQM bound to the ethernet interface Device 1 is using (eth0.1?).

Set upload and download rates for Device 1 to say 10Mb/s (More than enough for 4K video).
Device 2 will then have enough bandwidth for real time video.

You might have a problem with the C20 v5's though, if they only have 8/64 MB - hardly enough to run just openWrt these days.

Batman is completely unnecessary here as it is designed to provide layer 3 routing for large mesh networks, whereas you just have 3 nodes on a bridged mesh. So you could save quite a bit of space by just using simple 802.11s.

Yes the same issue happens there.

I tried removing all the device and just kept device 2 on the network connected to node2 and still I am experiencing the same issue.. video calls being frozen, high ping while playing multiplayer games like csgo,etc

You mean you removed Device 1 and Device 3?
You are playing multiplayer games AND video calling simultaneously on Device 2?

Yes I removed device 1 and 2.
And no am not doing that simultaneously.

But now you are saying the video call has problems even without the 4K streaming.

First I thought it's because of 4k video, so I tested it without it turns it has issues with or without 4k video.

Does Device 2 still have video call problems when connected to the gateway wifi?

In that case it works just fine.

You were implying that it used to work on the mesh and something changed (ie 4K streaming - but that was a red herring).

So was it working at some stage, or has it never worked?

There could be many reasons if it has stopped working, for example a degraded signal between the mesh nodes.

Everything else works just fine from all the node ..it's just that I can't get video calls and online multiplayer works properly.

An answer would help.