Internet connectivity for LAN/Wifi devices in default config of 21.02.1


I'm using now OpenWrt for quite a long time and especially I'm happy with my Linksys WRT1900ACS. I was pushing back the update to the new 21.02.x branch as the device is affected by the swconfig vs. DSA change, such it will take more time to get everything up and running again.

Today I tried and used the sysupgrade for 21.02.1. I unchecked to reuse the old config as of the switch to DSA and checked the forced update. The router did the update and came back with the known standard address and I started setting up the device again based on the old config.

What I noticed is that WAN interface was working, got a proper IPv4 ad IPv6 address, but the LAN and Wifi connected devices didn't got an internet connectivity. Device diagnostics where also fine (regarding ping, traceroute, nslookup).

I checked the description here: and I have in my 19.07.8 config the

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 5t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '4 6t'

But there is no kind of VLAN config or bridging between LAN and WAN in the new 21.02.1 configuration. Now I wonder, does the default config of the OpenWRT SW doesn't configure routing between WAN and LAN? I was guessing that should be a standard for a router device.

I tried to add the configurations from the named description:

config device
	option type 'bridge'
	option name 'br0'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'
	list ports 'wan'

config bridge-vlan
	option device 'br0'
	option vlan '1'
	list ports 'lan1:u*'
	list ports 'lan2:u*'
	list ports 'lan3:u*'
	list ports 'lan4:u*'

config bridge-vlan
	option device 'br0'
	option vlan '2'
	list ports 'wan:u*'

Then rebootet the router and reset the network interface on my windows, anyhow the situation stayed the same.
Windows PC just got an IPv4 address from the internet network range. IPv6 was not assigned, so prefix handling also seems not to be standard in the configuration.

I now switched back to 19.07.8 and rolled back my config from backup cause I was trying for a few hours but need internet at some point (e.g. to create this new topic :slight_smile: ).

Does somebody have a sample config, so to come to a standard forwarding behavior of the router? I do not have any special needs like several separated networks and I know how to work on a command line. (Hope I don't need to have a deeper dive into DSA just to be able to update from 19.07.8 to 21.02.).

Any help is welcome!

The default configuration should work. You don't need to bring the wan port into a bridge-vlan unless you need it to switch packets back out to one of the other Ethernet ports.

In the default use case where wan is its own network connected to a modem, it is fine to just declare option device wan (or even option device wan.35 if the modem requires tagged packets).

Make sure the upstream network is not also The wan and lan need to be different subnets for routing to work.


thanks for the hints.

The default configuration should work.

Yeah, thats what I expected, but it didn't. :slightly_smiling_face:

option device wan

Pretty sure this was in the 'network' config. Anyhow it looked like I had two seperate networks without any forwarding (neither IPv4 nor IPv6), as ping was working for 4 and 6 from the router, but not the connected devices.

Make sure the upstream network is not also

It is not. I have 192.168.2.x for the IPv4 internal network. 'wan' is a cable modem (in modem mode), so the 'wan' interface directly gets an external IPv4 and IPv6 prefix.

Reading again I might have missed this line:

Gather all of the switchport interfaces (wan, lan1, lan2, etc.) in one bridge interface. Remove them from other bridges if they exist.

I guess I missed removing other bridges... There might have been still the 'lan' bridge.

Flash with default configuration, plug a cable modem into the WAN port, and you should have routing from the LAN (Ethernet) to the Internet without any additional configuration.

Once you see that work, then you can try to break it if you want to.

Ok understood, problem is in front of the computer. I'll try again, first get internet connectivity working before starting to configure it.

tried today and as you said, it works out of the box. Not sure what I did last time to break it, but I have to admit, the problem was indeed in front of the computer. Probably I already fiddled around with the LAN/WAN switch config as I was sure I have to do it according to the documentation mentioned above.
Anyhow problem is solved!
Thanks for your replies!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.