Internet access via WAN on Linksys WRT3200ACM

I am sure that I am making a basic error but I just cannot find the solution hence reaching out here.

Currently I have to plug the incoming internet feed in to the LAN bridged ports as I cannot get internet access when it plugged into the Linksys WRT3200ACM port. My ISP provider is Vodaphone and at the moment has the Firewall on but DHCP off.

What I want to achieve to put Vodaphone router into Exposed Host / DMZ mode (which it supports), plug the cable from that into the WAN port of the Linksys, have the firewall working correctly and setup port forwarding. However I am falling at the first hurdle of getting internet access and it driving me mad.

I have not posted in a forum before so not sure what you need to help. I have added some files requested in other post.

OpenWrt 19.07.7, r11306-c4a6851c72

/etc/config/network
config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd64:3fd5:f0ab::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.1.2'
        option gateway '192.168.1.1'
        list dns '8.8.8.8'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '5t 3 2 1 0'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option vid '2'
        option ports '6t 4'

config interface 'WAN'
        option ifname 'eth1'
        option proto 'dhcp'

/

etc/config/firewall
config defaults
        option input 'ACCEPT'
        option output 'ACCEPT'
        option synflood_protect '1'
        option forward 'REJECT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option network 'lan'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        list network 'WAN'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fc00::/6'
        option dest_ip 'fc00::/6'
        option dest_port '546'
        option family 'ipv6'

If you have disabled the DHCP on the Voda router, you can't expect wan on 3200 to get settings by dhcp.
Either enable DHCP server on Voda modem, or assign a static IP on 3200 wan.

1 Like

Why bother with the ISP router though?
A much more elegant solution would be to get a standalone modem like the Draytek Vigor and then configure everything at the router level as PPPoE
I'm with BSkyB and do this. Sky actually hide your user and pass on their router but the crack was revealed years ago...

I am thinking about moving to a standalone modem.

As a first step I wanted to do more research as well as get this working before jumping in and spending money.

I am doubting my self in the settings to set the WAN as static.

In the last setup the.....

  • Vodaphone router has been on 192.168.1.1
  • Lynksys 192.168.1.2

Are these the correct setting's....

ipv4 address should be 192.168.1.2, and ipv4 gateway should be 192.168.1.1.

No it is not correct. address can be 1.2 and gateway must be 1.1
Also you'll need to change the IP of the lan interface, as it is the same and you'll have a conflict. Change it to 192.168.100.1 for example.

1 Like

Thanks for all the help and hope you folks have a little more patients with me.
My concern is getting this wrong losing connection to the Linksys router (192.168.1.2).
I also have a load API call to the Linksys openwrt router to do things like automate turning kids wifi off etc.

Does the following look correct?

The WAN setting could be the following (set IP address to 1.6 to avoid conflict with LAN / lynksys router which has a static lease of 192.168.1.2)

My question is this.
The vodaphone router will be plug into to WAN (internet) port on linksys router
Do these setting's not mean vodaphone router will be given an IP of 192.168.1.6?

As things stand now, before I save the changes, there is DHCP static lease which sets the vodaphone router to 192.168.1.1. In my understanding this is what is setting my gateway.

thanks for any insight you can give or links to anything to build my understanding

no, it s your choise, you said that no dhcp are active on vodafone.
now you need edit the lan interface of the wrt3200 and set it to static address 192.168.2.1

the wan config is ok now.

1 Like

Thanks for the reply

I tried to change the LAN setting as below to move as suggested.

The apply changes does not work and resets.
(Yes I am trying to re-sign in on 192.168.2.1 to the router)

OK, have been doing more research and guess my problem is that whalst I am trying to set the LAN to 192.168.2.1, there are a lot static dns leases set up with 192.168.1.x. Also there is a lot already setup based on these IP's

It goes to be a significant amount of time to rework everything

Can I set the WAN to 192.168.2.2 ?
In this case does the gateway still stay 192.168.1.1 or does it need to be 192.168.2.1

Hope you folks can guide me the last step as this is driving me nuts.

no

yes , the lan need be 192.168.2.1 or something different from 192.168.1.x

delete ipv4 gateway 192.168.1.1 and custom dns 8.8.8.8 in the lan interface, for now use less as possible.

Thank you so much for all the help.....it was a real education.

After thinking through everything that I will have to do to get this sorted, I think I will give the modem a go first.

I just got the username and password from ISP. In addition I have ordered a DrayTek Vigor 130 VDSL2/ADSL2+ Ethernet Modem. If I have issues I can always fall back on what we chatted about above.

I am going to mark this as closed.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.