Interface wan6 has no default route in the main routing

Hello!
I ran into a problem that I can’t solve for more than a week.

I have two external connections. Each of these connections is managed through its own router. This router is connected to its Internet service provider. A 6v4 tunnel and an OpenVPN client and other services are configured on the routers.

Both routers are combined into multiWAN through the third Netgear R6300 V2 router, on which the OpenWrt 19.07.0-rc2 r10775-db8345d8e4 / LuCI openwrt-19.07 branch git-19.356.80404-43c74d3 and luci-app-mwan3 git-19.356.80404 system is installed 43c74d3-1.

When creating multiple external connections using DHCP and DHCPv6, the IPv6 connection is not registered in the routing table.
When creating a "static address" the situation is similar.
How to properly configure load balancing to work simultaneously IPv4 and IPv6?

Please help in solving this problem.

I apologize in advance for my English, I do not know this language well, therefore I use a translator.

network config


config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd79:bf47:3778::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option igmp_snooping '1'

config device 'wan_eth0_2_dev'
	option name 'eth0.2'
	option macaddr '10:da:43:95:69:79'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '5t 0 1 2'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '5t 4'

config switch_vlan
	option device 'switch0'
	option ports '5t 3'
	option vlan '3'

config interface 'wan_14'
	option ifname 'eth0.2'
	option proto 'dhcp'
	option force_link '1'

config interface 'wan_24'
	option ifname 'eth0.3'
	option proto 'dhcp'
	option force_link '1'

config interface 'wan_16'
	option ifname 'eth0.2'
	option proto 'dhcpv6'
	option reqprefix 'auto'
	option reqaddress 'try'
	option force_link '1'

config interface 'wan_26'
	option ifname 'eth0.3'
	option proto 'dhcpv6'
	option reqprefix 'auto'
	option reqaddress 'try'
	option force_link '1'




mwan3 config


config globals 'globals'
	option mmx_mask '0x3F00'
	option rtmon_interval '5'

config policy 'balanced'
	option last_resort 'default'
	list use_member 'mx_1'
	list use_member 'mx_2'
	list use_member 'ks_1'
	list use_member 'ks_2'

config interface 'wan_14'
	option enabled '1'
	option initial_state 'online'
	option family 'ipv4'
	option track_method 'ping'
	option reliability '1'
	option count '1'
	option size '56'
	option max_ttl '60'
	option check_quality '0'
	option timeout '2'
	option interval '5'
	option failure_interval '5'
	option recovery_interval '5'
	option down '3'
	option up '3'
	list track_ip '8.8.8.8'
	list track_ip '8.8.4.4'
	list track_ip '2001:4860:4860::8888'
	list track_ip '2001:4860:4860::8844'

config interface 'wan_16'
	option enabled '1'
	option initial_state 'online'
	option family 'ipv6'
	option track_method 'ping'
	option reliability '1'
	option count '1'
	option size '56'
	option max_ttl '60'
	option check_quality '0'
	option timeout '2'
	option interval '5'
	option failure_interval '5'
	option recovery_interval '5'
	option down '3'
	option up '3'
	list track_ip '8.8.8.8'
	list track_ip '8.8.4.4'
	list track_ip '2001:4860:4860::8888'
	list track_ip '2001:4860:4860::8844'

config interface 'wan_24'
	option enabled '1'
	option initial_state 'online'
	option family 'ipv4'
	option track_method 'ping'
	option reliability '1'
	option count '1'
	option size '56'
	option max_ttl '60'
	option check_quality '0'
	option timeout '2'
	option interval '5'
	option failure_interval '5'
	option recovery_interval '5'
	option down '3'
	option up '3'
	list track_ip '8.8.8.8'
	list track_ip '8.8.4.4'
	list track_ip '2001:4860:4860::8888'
	list track_ip '2001:4860:4860::8844'

config interface 'wan_26'
	option enabled '1'
	option initial_state 'online'
	option family 'ipv6'
	option track_method 'ping'
	option reliability '1'
	option count '1'
	option size '56'
	option max_ttl '60'
	option check_quality '0'
	option timeout '2'
	option interval '5'
	option failure_interval '5'
	option recovery_interval '5'
	option down '3'
	option up '3'
	list track_ip '8.8.8.8'
	list track_ip '8.8.4.4'
	list track_ip '2001:4860:4860::8888'
	list track_ip '2001:4860:4860::8844'

config member 'mx_1'
	option interface 'wan_14'
	option metric '1'
	option weight '1'

config member 'mx_2'
	option interface 'wan_16'
	option metric '1'
	option weight '1'

config member 'ks_1'
	option interface 'wan_24'
	option metric '1'
	option weight '1'

config member 'ks_2'
	option interface 'wan_26'
	option metric '1'
	option weight '1'




Route table from page http://192.168.1.1/cgi-bin/luci/admin/status/routes
Маршруты
На данном устройстве активны следующие правила.
ARP
IPv4-адрес	MAC-адрес	Интерфейс
192.168.3.1%eth2	6C:B0:CE:BB:9F:2A	wan_24
192.168.2.1%eth2	C0:FF:D4:90:80:3B	wan_14
192.168.1.105	0C:9D:92:4E:CD:91	lan
192.168.1.223%eth2	3C:D9:2B:20:89:8C	lan
Активные IPv4-маршруты
Сеть	Назначение	IPv4-шлюз	Метрика	Таблица
wan_14	0.0.0.0/0	192.168.2.1	0	1
lan	192.168.1.0/24	-	0	1
wan_14	192.168.2.0/24	-	0	1
wan_24	192.168.3.0/24	-	0	1
wan_24	0.0.0.0%eth0.2/0	192.168.3.1	0	3
lan	192.168.1.0/24	-	0	3
wan_14	192.168.2.0%eth0.2/24	-	0	3
wan_24	192.168.3.0%eth0.2/24	-	0	3
wan_24	0.0.0.0%eth0.2/0	192.168.3.1	0	main
lan	192.168.1.0/24	-	0	main
wan_14	192.168.2.0/24	-	0	main
wan_24	192.168.3.0/24	-	0	main
Активные IPv6-маршруты
Сеть	Назначение	Источник	Метрика	Таблица
wan_14	2001:470:6164::/64		256	2
wan_24	2001:470:6165::/64		256	2
lan	fd79:bf47:3778::/64		1024	2
wan_14	::%eth2/0		1024	2
wan_14	2001:470:6164::/64		256	4
wan_24	2001:470:6165::/64		256	4
lan	fd79:bf47:3778::%eth2/64		1024	4
wan_24	::/0		1024	4
wan_14	::%eth2/0	2001:470:6164::3a9c:4076%eth2	512	main
wan_14	::/0	2001:470:6164::%eth0.2/64	512	main
wan_24	::%eth2/0	2001:470:6165::3a9c:4075%eth2	512	main
wan_24	::/0	2001:470:6165::%br-lan/64	512	main
wan_14	2001:470:6164::%br-lan/64		256	main
wan_24	2001:470:6165::/64		256	main
lan	fd79:bf47:3778::%eth2/64		1024	main
(eth0)	ff00::%eth2/8		256	local
lan	ff00::%eth2/8		256	local
wan_14	ff00::%eth2/8		256	local
wan_24	ff00::%eth2/8		256	local
IPv6 соседи (neighbours)
IPv6-адрес	MAC-адрес	Интерфейс
fd79:bf47:3778:0:1966:1cc3:2ab7:b987	3C:D9:2B:20:89:8C	lan
2001:470:6164::1%eth2	C0:FF:D4:90:80:3B	wan_14
2001:470:6165::1	6C:B0:CE:BB:9F:2A	wan_24

PC adress from Netgear R6300 V2
Определенный для подключения DNS-суффикс: lan
Описание: Realtek PCIe GBE Family Controller
Физический адрес: ‎3C-D9-2B-20-89-8C
DHCP включен: Да
Адрес IPv4: 192.168.1.223
Маска подсети IPv4: 255.255.255.0
Аренда получена: 27 декабря 2019 г. 15:33:18
Аренда истекает: 28 декабря 2019 г. 3:33:17
Шлюз по умолчанию IPv4: 192.168.1.1
DHCP-сервер IPv4: 192.168.1.1
DNS-сервер IPv4: 192.168.1.1
WINS-сервер IPv4 : 
Служба NetBIOS через TCP/IP включена: Да
IPv6-адрес: fd79:bf47:3778::ef1
Аренда получена: 27 декабря 2019 г. 15:33:14
Аренда истекает: 2 февраля 2156 г. 22:01:46, fd79:bf47:3778:0:940b:894a:3ae3:bb27
Временный IPv6-адрес: fd79:bf47:3778:0:1966:1cc3:2ab7:b987
Локальный IPv6-адрес канала: fe80::940b:894a:3ae3:bb27%5
Шлюз по умолчанию IPv6: fe80::12da:43ff:fe95:6978%5
DNS-сервер IPv6: fd79:bf47:3778::1

It can be seen that in the table for IPv6 routes, there are no interfaces responsible for IPv6. Instead, IPv6 routes are assigned IPv4 interface names. How to fix it?

iproute2 commands out
/etc/iproute2$ ip -4 a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
7: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    inet 192.168.1.1/24 brd 192.168.1.255 scope global br-lan
       valid_lft forever preferred_lft forever
9: eth0.2@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    inet 192.168.2.28/24 brd 192.168.2.255 scope global eth0.2
       valid_lft forever preferred_lft forever
10: eth0.3@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    inet 192.168.3.27/24 brd 192.168.3.255 scope global eth0.3
       valid_lft forever preferred_lft forever
/etc/iproute2$ ip -6 a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 state UNKNOWN qlen 1000
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::12da:43ff:fe95:6978/64 scope link 
       valid_lft forever preferred_lft forever
7: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fd79:bf47:3778::1/60 scope global noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 fe80::12da:43ff:fe95:6978/64 scope link 
       valid_lft forever preferred_lft forever
9: eth0.2@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 2001:470:6164:0:12da:43ff:fe95:6979/64 scope global dynamic noprefixroute 
       valid_lft 42999sec preferred_lft 42999sec
    inet6 2001:470:6164::3a9c:4076/128 scope global dynamic noprefixroute 
       valid_lft 39863sec preferred_lft 39863sec
    inet6 fe80::12da:43ff:fe95:6979/64 scope link 
       valid_lft forever preferred_lft forever
10: eth0.3@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 2001:470:6165:0:12da:43ff:fe95:6978/64 scope global dynamic noprefixroute 
       valid_lft 43177sec preferred_lft 43177sec
    inet6 2001:470:6165::3a9c:4075/128 scope global dynamic noprefixroute 
       valid_lft 39860sec preferred_lft 39860sec
    inet6 fe80::12da:43ff:fe95:6978/64 scope link 
       valid_lft forever preferred_lft forever
/etc/iproute2$ ip -4 rou
default via 192.168.3.1 dev eth0.3 proto static src 192.168.3.27 
192.168.1.0/24 dev br-lan proto kernel scope link src 192.168.1.1 
192.168.2.0/24 dev eth0.2 proto kernel scope link src 192.168.2.28 
192.168.3.0/24 dev eth0.3 proto kernel scope link src 192.168.3.27 
/etc/iproute2$ ip -6 rou
default from 2001:470:6164::3a9c:4076 via fe80::c2ff:d4ff:fe90:803b dev eth0.2 proto static metric 512 pref medium
default from 2001:470:6164::/64 via fe80::c2ff:d4ff:fe90:803b dev eth0.2 proto static metric 512 pref medium
default from 2001:470:6165::3a9c:4075 via fe80::6eb0:ceff:febb:9f2a dev eth0.3 proto static metric 512 pref medium
default from 2001:470:6165::/64 via fe80::6eb0:ceff:febb:9f2a dev eth0.3 proto static metric 512 pref medium
2001:470:6164::/64 dev eth0.2 proto static metric 256 pref medium
2001:470:6165::/64 dev eth0.3 proto static metric 256 pref medium
fd79:bf47:3778::/64 dev br-lan proto static metric 1024 pref medium
unreachable fd79:bf47:3778::/48 dev lo proto static metric 2147483647 error 4294967183 pref medium
fe80::/64 dev eth0 proto kernel metric 256 pref medium
fe80::/64 dev eth0.2 proto kernel metric 256 pref medium
fe80::/64 dev eth0.3 proto kernel metric 256 pref medium
fe80::/64 dev br-lan proto kernel metric 256 pref medium
/etc/iproute2$ ip -4 ru
0:	from all lookup local 
1001:	from all iif eth0.2 lookup 1 
1003:	from all iif eth0.3 lookup 3 
2001:	from all fwmark 0x100/0x3f00 lookup 1 
2003:	from all fwmark 0x300/0x3f00 lookup 3 
2061:	from all fwmark 0x3d00/0x3f00 blackhole
2062:	from all fwmark 0x3e00/0x3f00 unreachable
32766:	from all lookup main 
32767:	from all lookup default 
/etc/iproute2$ ip -6 ru
0:	from all lookup local 
1002:	from all iif eth0.2 lookup 2 
1004:	from all iif eth0.3 lookup 4 
2002:	from all fwmark 0x200/0x3f00 lookup 2 
2004:	from all fwmark 0x400/0x3f00 lookup 4 
2061:	from all fwmark 0x3d00/0x3f00 blackhole
2062:	from all fwmark 0x3e00/0x3f00 unreachable
32766:	from all lookup main 
4200000001:	from all iif lo failed_policy
4200000007:	from all iif br-lan failed_policy
4200000009:	from all iif eth0.2 failed_policy
4200000009:	from all iif eth0.2 failed_policy
4200000010:	from all iif eth0.3 failed_policy
4200000010:	from all iif eth0.3 failed_policy
/etc/iproute2$ ip -6 link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP mode DEFAULT group default qlen 1000
    link/ether 10:da:43:95:69:78 brd ff:ff:ff:ff:ff:ff
3: eth1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000
    link/ether 10:da:43:95:69:79 brd ff:ff:ff:ff:ff:ff
4: eth2: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000
    link/ether fa:c6:c7:f7:88:1e brd ff:ff:ff:ff:ff:ff
6: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000
    link/ether 00:00:00:00:00:00 brd ff:ff:ff:ff:ff:ff
7: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP mode DEFAULT group default qlen 1000
    link/ether 10:da:43:95:69:78 brd ff:ff:ff:ff:ff:ff
8: eth0.1@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP mode DEFAULT group default qlen 1000
    link/ether 10:da:43:95:69:78 brd ff:ff:ff:ff:ff:ff
9: eth0.2@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP mode DEFAULT group default qlen 1000
    link/ether 10:da:43:95:69:79 brd ff:ff:ff:ff:ff:ff
10: eth0.3@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP mode DEFAULT group default qlen 1000
    link/ether 10:da:43:95:69:78 brd ff:ff:ff:ff:ff:ff
/etc/iproute2$ ip -4 link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP mode DEFAULT group default qlen 1000
    link/ether 10:da:43:95:69:78 brd ff:ff:ff:ff:ff:ff
3: eth1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000
    link/ether 10:da:43:95:69:79 brd ff:ff:ff:ff:ff:ff
4: eth2: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000
    link/ether fa:c6:c7:f7:88:1e brd ff:ff:ff:ff:ff:ff
6: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000
    link/ether 00:00:00:00:00:00 brd ff:ff:ff:ff:ff:ff
7: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP mode DEFAULT group default qlen 1000
    link/ether 10:da:43:95:69:78 brd ff:ff:ff:ff:ff:ff
8: eth0.1@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP mode DEFAULT group default qlen 1000
    link/ether 10:da:43:95:69:78 brd ff:ff:ff:ff:ff:ff
9: eth0.2@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP mode DEFAULT group default qlen 1000
    link/ether 10:da:43:95:69:79 brd ff:ff:ff:ff:ff:ff
10: eth0.3@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP mode DEFAULT group default qlen 1000
    link/ether 10:da:43:95:69:78 brd ff:ff:ff:ff:ff:ff

Hello, I can confirm this issue on 19.07.0-rc2. When using DHCP and DHCPv6 on separate interfaces such as wan and wan6, which is the default configuration, then the routes on the Status->Routes pages show "wan" instead of the expected "wan6" for IPv6 routes. (But IPv6 routes are still shown on "ifstatus wan6" as expected and not on "ifstatus wan".)
Though this doesn't cause any IPv6 connectivity problems for me, but I don't use mwan3.