Intel 7265NGW dissapears after switching mode to AP

Hi everyone!
I have a board Mikrotik 33G with installed openwrt on it.

root@OpenWrt:/# uname -a
Linux OpenWrt 4.14.82 #0 SMP Sun Jan 19 12:50:14 2020 mips GNU/Linux

All required modules are enabled: iwlwifi, mac80211, cfg80211 etc. The device is available for scanning SSID's but after switching it to Master mode it disappears. I use this wireless config:

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '5'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
        option disabled '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'wwan'
        option mode 'ap'
        option ssid 'Hydra'
        option encryption 'none'

An option path is correct. It was obtained from a wifi config command. After running 'wifi up' command device disappears from ip link list without any logs in the dmesg.
Can anyone help me?

Almost no intel wifi chip does support ap mode.
Check the out put of iw list to determine the supported operation modes.

1 Like

Thank you for reply
Yes, I already checked this point:

        Supported interface modes:
                 * IBSS
                 * managed
                 * AP
                 * AP/VLAN
                 * monitor
                 * P2P-client
                 * P2P-GO
                 * P2P-device

I already had the same problem with different device here but that problem was related to redundant option in config. Now this solution doesn't help me

What about system and kernel logs?
There aren't any hints for the failure?

No, there aren't any new logs in dmesg

There are some lines with an error after boot:

root@OpenWrt:/# dmesg | grep iwl
[   27.118325] iwlwifi 0000:01:00.0: assign IRQ: got 25
[   27.123649] iwlwifi 0000:01:00.0: pci_enable_msi failed - -89  <-- this line
[   27.151596] iwlwifi 0000:01:00.0: loaded firmware version 29.1044073957.0 op_mode iwlmvm
[   27.207221] iwlwifi 0000:01:00.0: Detected Intel(R) Dual Band Wireless AC 7265, REV=0x210
[   27.275523] iwlwifi 0000:01:00.0: base HW address: 3c:6a:a7:fa:fd:fc
[   27.355742] ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs'

@slh maybe you can help me again?

does not match, channel 5 is a 2.4 GHz channel while you tell the driver to use the 5 GHz band (option hwmode '11g' would be needed here). No Intel driver at all supports AP mode in the 5 GHz band, so you're restricted to using the 2.4 GHz band (but again, Intel wireless hardware isn't made for running in AP mode - and that might show).

Disclaimer: I don't own any 7265ngw (or similar Intel-) card and can't help beyond this.

Thank you for reply
Yes, I've tried to use 2.4GHz and 5GHz frequencies and I've got the same result

And what about the system logs?

Command: logread

1 Like

Yes, logs were disabled. After enabling logread I found out that there isn't hostapd in the image. Thank you, @juppin, I've looked only in dmesg.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.