Installtion firmware for WE1326-BKC

I have tried to install the firmware WE1326. I get this message : this firmware is not valid.
Could you please help me to fix this issue.

  • Did you follow the install instructions?
  • Did you use the sysupgrade file to install OpenWrt?;a=commit;h=ff258effd508fc75edfb08ba709b333619d3f1e8

Thank you for your response.
Could you please help where can I download the new file with mode 6044. to be installed.

I tried to install the firmware without any result. I am always getting a message that is an invalid firmware.
I changed the Router, now I have WG3526-KC. the vendor sent me an Openwrt version. when installed, it seems not like yours. Could you please help me to install your version and how can I install it.
Thank you for your help.

In order to install Openwrt to Zbt WE1326 you have to long press for 5 seconds reset button while connecting the power supply. That way you will access to recovery interface that will allow you to upload the Sysupgrade image file. I tested it with lastest 19.07 Sysupgrade with no issues