Installing vpn

Hello all,

I am trying to install a VPN connection on my rasberry pi (model: 4B), I am following along with NetworkChuck (
All my network seems to be working, I can connect to my wifi at home, and the Wifi adapter is being hotspot with a new name. The only problem I have is that I cannot install a vpn. And what I mean by that is that my OpenWRT software does have openVPN but I cannot start the .conf or .ovpn file.

Beside that I also cannot configure the vpn.

Do you guys know a solution?

Which VPN provider do you use?
Are there any output logs?
What VPN protocol are you using?

I mean this is strange right?

I use NordVPN.

Beside that I am an with using OpenWRT so I don't know how to see the logs. And the protocol I am using is UDP.

are you setting it up via the webinterface, or cli ?

The error is telling you that the file you are trying to access is not a directory. It is a regular file - you cannot use cd (change directory).

I tried both, I tried to it with the web interface and tried it with the terminal

when/where did it fail, specifically ?

Wow, now I see, my brain wasn't working. Thanks for the clear up

Use LuCI GUI to do this

The luci-app-openvpn package has a small 'trick'. After you configure your .conf file you will start 'save and apply' wait 10 seconds on the page and press enabled and 'save and apply'

I am trying to start it but it doesn't start with no error's on the screen.

I uploaded the .ovpn file through the web interface. Or do I really need to configure the file by myself?

Use mkdir to create a directory such as /etc/config/openvpnfiles and place your .ovpn file, certificates, etc there. Edit the /etc/config/openvpn file to point the instance of OpenVPN to the .ovpn file which you obtained from the VPN provider and stored in /etc/config/openvpnfiles. This is better than storing files in /etc/openvpn (as most guides say) because everything in /etc/config and under it will be preserved when you upgrade OpenWrt.


Status > System Log

logread -e dnsmasq
logread -e nordvpn

Okay, I will give that a look.


This will confirm my noobnezz, I forgot my account credentials in a separate file. And that's why the vpn didn't start.

enjoy now hahahahahah

and remember, VPN does zero for your internet privacy.

hahaha thanks