Installing then Uninstalling Not Working Help!

I recently installed OpenWrt on my Netgear WNR1000v3. At first I thought the firmware didn't install correctly and tried resetting using Netgear's tips. After doing some more research I was able to access it through telnet in putty and was able to change the root password and restart. Every since that I haven't been able to get back into it. I've tried pinging it, sometimes it shows others it doesn't, and also accessing the web interface doesn't work, just shoes LuCl configuration but never loads. Any advice on how to get it back to the out of the box firmware would be much appreciate. I could really use the help, thanks!!

What are these tips? Did you change anything or were you able to access the console from Putty with SSH?

Holding reset with power for 30 seconds, 30 seconds off, then 30 seconds on, I didn’t know it was installed till I tried putty. I didn’t ac cess it through SSH but through telnet. I only changed root password and rebooted then haven’t gotten access since.

What version of OpenWrt did you install? Please share a link/location where the image came from.

I believe it was this from this page

That is an official OpenWrt stable release, so that is good. However, did you see the warnings about your device -- that device is very old (~10 years) and will not perform well at all since it has only 4MB flash and 16MB RAM, which is really not enough to run OpenWrt properly. I am guessing that LuCI (the web interface) will not be included in your image because it will not fit (and you will not be able to install it, either).

Assuming you can regain access to your router, you could try flashing LEDE (OpenWrt) 17.01.7 which will run more smoothly, but it may have security vulnerabilities and is considered very out of date (getting help/support here will be difficult simply because it is so old and people just won't remember the nuances of that version compared to the current versions; you'll also be asked why you are running such an old version and why you are using such old/underpowered hardware).

You should very seriously consider purchasing a newer router -- you can get reasonably powerful routers that will run OpenWrt well for ~$20-$50 US.

Meanwhile, to address your immediate issue:

  • Make sure your computer does not have any other network connections (turn off wireless, use an ethernet cable between your router's LAN port and your computer).
  • Does your computer get an IP address from the router via DHCP?
  • Can you ping the router (default
  • Can you ssh into it (default username: root, password is blank)?
1 Like

I do not get a dhcp automatically, I have to assign it one. I can ping usually without trouble but accessing ssh doesn’t work.

when you ping, what TTL do you see?

1 Like

Also, as an aside -- what are you planning to do with this device? I just noticed that the 2.4GHz wifi is not supported (and that is the only radio you have in the device)... so it can be a wired device only (assuming that the unsupported feature note is accurate)..

1 Like

Sorry, when I ping I get destination host unavailable. I plan on going back to the out of the box firmware.

Have you tried getting the failsafe mode to work? Usually you press a button such as WPS for reset rapidly as you apply power... one or more of the LEDs should blink rapidly if failsafe works.

1 Like

Ok a ping got 64 TTL twice

2 times and then it stopped? It could mean that it is crashing or otherwise failing to complete the boot (there is a brief period that it will likely respond during the early stages of booting).

TTL 64 is expected when the router is working properly, and TTL 100 when it is in failsafe mode (IIRC).

You might be able to get tftp recovery or a serial recovery to work, but how specifically to do that on your device is not shown on the device info page.

I think you should probably give up soon on this device... it is just simply obsolete (802.11g wifi, 100Mbps ports, 4MB/16MB, probably super slow routing performance/bandwidth limits, etc.).

Anyway, from the device info page (emphasis added)

This device has too little storage and too little memory for proper operation.

You can still tinker with it, but be aware that, probably for those reasons, installing release 17.01.4 crashes on first boot. m(

See a general warning on Supported Devices and more device-specific details on Techdata specific to Netgear WNR1000 v3.

If you want to continue anyway, you're on your own with generic instructions.

Also, you should check the “recovery” possibilities, to be able to go back to stock firmware if needed.

1 Like

Two failed then two went through, now every time they go through. Currently I’m trying to use tftp to flash firmware and I’m on 3/3 and it’s taking a while. Thanks for your help!

Is there a way to upgrade with a .chk without using the web interface?

You might consider starting from scratch.

Re-install the factory firmware, and then try an earlier version of OpenWRT -

1 Like

I also get this when trying to access from chrome
/usr/lib/lua/luci/dispatcher.lua:315: /etc/config/luci seems to be corrupt, unable to find section 'main'
stack traceback:
[C]: in function 'assert'
/usr/lib/lua/luci/dispatcher.lua:315: in function 'dispatch'
/usr/lib/lua/luci/dispatcher.lua:208: in function </usr/lib/lua/luci/dispatcher.lua:207>

I'm trying to get back to factory firmware but am having trouble

It should have bootloader http recovery. Hold down the reset button while turning the power on, and keep holding it until the power LED starts flashing. Connect your PC and browse to You may need to static IP the PC. This should bring up a single internal page where you can flash stock firmware.

OpenWrt cannot run in 16 MB RAM. It's going to crash before booting fully.