Installing PPPOA to work with BT Fibre 100

I had my Linksys WRT3200ACM running happily on PlusNet, but have now moved to BT Fibre 100 and can't get it to work. According to the instructions ( I need to install PPPOA ppp-mod-pppoa on my router, but I can't connect to the internet so
opkg update
opkg install ppp-mod-pppoa
don't work. How can I install ppp-mod-pppoa without access to the internet? I have tried daisy chaining the router to the BT hub, but that doesn't work. Any help would be really gratefully received - thanks.

The settings are:

Connection type: PPPoA (PPPoATM)
VCI = 38, VPI = 0
Encapsulation: VCMUX
Modulation: G.DMT
RFC: 2364
Network type: WAN (Not LAN)
MTU: Auto/Normal 1458 – 1500 (Lower numbers can help if data corruption occurs default is
QOS: UBR (Unlikely to be CBR/VBR)
The username should be of the format or No password is required, but if the router insists, use bt as the


The A in pppoa denotes ATM, but fibre 100 is almost certainly running on PTM, please try pppoe as protocol instead, British ISP, as far as I understand, often support both on ATM links and on PTM/VDSL2 links PPPoA is not an option. Also PPPoA needs to be run on a device with a real ATM interface and your WRT3200ACM is not one such device.

1 Like

I am still trying to enter the settings into my router. I am following moeller0's advice to use PPPOE, but I can't work out how to enter the settings in bold below:
VCI = 38, VPI = 0
Encapsulation: VCMUX
Modulation: G.DMT
RFC: 2364
Network type: WAN (Not LAN)
MTU: Auto/Normal 1458 – 1500 (Lower numbers can help if data corruption occurs default is
QOS: UBR (Unlikely to be CBR/VBR)
Please may I have some further advice.
Many thanks,

With VDSL2 there are no VCI or encapsulation setting necessary, these are all constructs needed for ATM based ADSL links, fibre 100 is decidedly not ATM based, hence you should be able to completely ignore those.
I would hope that section 7.5 of should get you going?

1 Like

Please may I have a bit more help. I have looked at the instructions and section 7.5 relates to my setup:
The instructions read:
"All Openreach FTTC VDSL fibre connections in the UK, require the following VDSL parameters:
VLAN ID: 101 ie. use ptm0.101 for LEDE17 only.
use dsl0.101 for OpenWrt 18 and later.
(nb. ‘dsl’ is lower-case ‘DSL’)
Annex: B (all) nb. Annex A may also work in some areas.
Tone: A (A43C + J43 + A43)"

But I can't find where to put the VDSL parameters, on interfaces they are not under "general settings", "advanced settings", "physical settings" or "Firewall settings". On general settings I have the protocol set as PPPoE as suggested earlier. I have the PAP/CHAP username as with the PAP/CHAP password as "bt" as per the instructions. The device is eth1.2.

Thanks again,

Well, on your WRT3200ACM you will not find these settings, as these are only directly applicable on your modem and only if the modem runs OpenWrt.

So let's take a step back, you have the WRT3200ACM you want to use as router and you have a network socket and between the two you need a modem. The DSL/BVLAN settings will need to be configured on the modem, the PPPoE credentials on the the device terminating the PPP tunnel, so either the modem (which then would be said to operate in router mode) or on your WRT3200ACM (in that case the modem needs to operate in bridged mode or at least in PPPoE-passthrough mode).
But back to your link, what kind of modem do you have?

Dear Moeller,
Thank you again for your prompt help. My modem is an OpenReach modem, a Nokia modem , the last one listed at: I have tried to find out further information on it, but is seems to be a 'black box'. It was supplied together with a "Smart Hub 2", which was connected to the modem with a cat 5 patch cable. A separate issue is that the bandwidth is supposed to be 100-150Mb/s, but is currently around 90Mb/s. I swapped the cat 5 cable for cat 6 and it made no difference. I have a cat 6 network to every room. They are sending an 'engineer' out next Thursday!

Thanks again,

Ah, thanks, that shows that indicates I was wrong and you do have a true fibre to the home (FTTH) link, not a fibre to the cabinet (FTTC/VDSL2). But in that case you can ignore all the gunk about ATM/ADSL or PTM/VDSL2 related configuration. But now we need to figure out the gunk about openreach's fibre platform :wink:
But there is really only the question about a potential VLAN tag, as far as I can tell.
Now, I assume you already tried to hook up your WRT3200ACM with the correct PPPoE credentials and that did not work, correct? So I would try next with VLAN 101 to just mirror what is used on older technologies by BT.
Now, I have never used a WRT3200ACM so am not 100% sure where how to configure that but for other router's a wan VLAN can be configured by opening the GUI navigate to Network -> Interfaces, click edit on the WAN interface, select the Physical Settings tab, click on the Interface drop down box, click custom and add eth1.101...
That might do the right thing, or it might not. Good luck.

fyi, if your Smart Hub 2 is working with your FTTP connection, simply configure the WAN connection on your openwrt router to use PPPoE protocol and wire it to the Openreach fibre modem.

Set the username to or
Use any non-empty password such as 'BT'.

Suggest using MTU of 1492.

(The Openreach modem handles everything else such as VLAN tag etc. Do NOT try to configure it on the openwrt router)

See also section 7.5 of installation guide for HH5A.

1 Like

I haven't tried it with PPPOE yet as I couldn't work out to set the parameters. I will try now. Please can I confirm that I have the correct settings. I will list them all. I have a WAN and a WAN6 which are both eth1.2.
My settings for both WAN and WAN6 are:
General settings
Protocol - PPPoE
Bring up on book - ticked
PAP/CHAP username -
PAP/CHAP password - bt
Access Concentrator - auto
Service name - auto

Advance settings
Use builtin IPv6-management - ticked
Force link - not ticked
Obtain IPv6-address - Automatic
Use default gateway - ticked
Use DNS servers advertised by peer - ticked
Use gateway metric - 0
LCP echo failure threshold - 0
LCP echo interval 5
Host-Uniq tag content - auto
Inactivity timeout - 0
Override MTU - 1492

Physical settings
Bridge interfaces - not ticked
Interface eth1.2

Firewall settings
Create / Assign firewall zone - wan; wan6

So please can we check that I have all the settings above correct.

Now unfortunately I appear to have created a new problem and I don't know how. Above the interfaces is a red box containing white text as follows:
Invalud or unexpected token

Then under LAN (br-lan) it says Unsupported protocol type
followed by a blue hyperlink - Install protocol extensions
If I click on the hyperlink it comes up with a page
Free space: 99% (59.4MB)
Filter: luci-proto
Download and install package - package name or URL
Actions - Update lists , Upload Package, Configure opkg

Available - No package
No packages matching "luci-proto" (Reset)

I really appreciate your help.

Many thanks,

These seem to be pretty much the defaults, with your use-name and password added? I happen to have pretty much the same (id changed LCP echo failure threshold and LCP echo interval, but that is not your issue...)

What protocol did you select for the LAN-bridge? I have the default static address...

I have taken some screenshots all of the LAN settings:

I'm not sure what I have done!
Thanks again.

Mmmh, it is a bit sad that on my phone the first and probably most important image has too low resolution to be readable.. .

I would believe that potentially the fastest course of action would be to start from scratch, by reflashing the router and then go step by step. Why? Because the default LAN bridge should simply work out of the box, so running into issues there seems a sign of something unfortunate having happened. It should be possible to figure out and correct things from the current state as well, but that is IMHO only worth it if you enjoy the process and the experience of standing sort of in the machine room of your home network...

fwiw, perhaps try clearing all current openwrt settings to return to openwrt factory defaults?

In LuCI, go to System -> Backup/Flash firmware -> Perform Reset

I have just done a system update and I was able to connect first time!

For the benefit of other BT Fibre customers the only settings that needed changing were:
Protocol - PPPoE
PAP/CHAP username -
PAP/CHAP password - bt
Override MTU - 1492

I'll have to reinstall the applications, but at least the router is working OK.

Thank you so much for taking the time to help me.

Best wishes,

Please mark as Solved.

Thanks Bill.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.