Installing OpenWrt on R8000p

I am a novice at this type of thing. I can't find a way to install OpenWrt on my R8000p, I have found the way how to but with no instructions at all, I can't just update it to OpenWrt because it only accepts .chk files. I need instructions or links on how to install. Thanks.

I believe you still require serial console access at this point, see

Is it not possible then? If it is how what do I do with this? Sorry if I'm asking dumb questions, I'm very new. If possible I need very easy instructions.

From the commit adding support for this device I understand that you need to connect to the serial port found on the board e.g. using a USB-to-serial adapter operating at 3.3V TTL level.
Something like this:

Used in a way like this

Once you have connected the serial console and opened it (e.g. using puTTY with Windows or minicom with UNIX'es) you can interrupt the boot which will open a web interface allowing to upload the raw firmware image.

R8000P serial port. 3.3v required.
FYI: I have installed openWRT however couldn't make WiFi work.


1 Like

How did you set up the connection? I dont get any response from my R8000P.


Baud rate: 115200 8 bits, No parity, 1 stop bit. (or 8-N-1)

And make sure that the Tx is connected to the Rx (and vice versa), connect ground. Usually you should not connect 3.3 or 5V or any of the other connections.

Thank you for fast replying. I tried

Baud rate: 115200 8 bits, No parity, 1 stop bit. (or 8-N-1)
and only connected Tx-Rx / Rx-Tx

Still no response but I can now type something in putty, it was not possible before.

you must connect ground. Did you do that?

Yes, I connected ground, too. For 1 second after turning on i can type something in putty, then it freezes.

As both your computer and the R8000p are supposedly connected to the power grid, what you are seeing may be noise due to ground loop issue. If it's a laptop, try running in on battery while using the USB-serial adapter, that may help.

Did you ever get this to work?

Hi I would like to come back to this post - the screen above I think is incorrectly.
I got data from serial only when connecting Tx<>Tx Rx<>Rx (according to screen above).
But the data is garbage like encoding is wrong.
I've setup console as Baud rate: 115200 8 bits, No parity, 1 stop bit. (or 8-N-1)

You might have to play with the Baud rate.

Another example; this BCM device needs 9600
Broadcom G610 serial port settings

Thx but no luck.
Also settings uses no Parity and I experimented with Flow control (using putty) but no luck with those 2 chages.

Tired using linux and screen with 115200 the output is garbage with 9600 there is no output

I gave this a try today on an R8000P, also had no luck getting a working connection using a USB-TTL adapter w/ putty. Here are some things I tried and observed, in case it's helpful to anyone else (I'm referring to the pins on the R8000P as labeled in @mohacs photo)

  • Connecting only GND and TX on the R8000P to GND and RX on my adapter, I can get garbage/scrambled data in the console with speed set to 115200 8-N-1. I tried a handful of speeds (115200, 38400, 14400, 9600) and all of putty's flow control options with no discernible difference
  • Connecting RX on the R8000P to TX on my adapter (leaving the others connected, so now 3 wires are connected) stops any data at all from appearing in the console. Disconnecting this wire lets the data resume in the console
  • These behaviors are the same whether or not I connect the 3.3V wire
  • I also tried interrupting the boot by jumping the TX & RX pins. If I jump them before powering the device, it doesn't seem to turn on. If I jump them once the device is starting to boot, it seems to just stop, and kills the lights on a connected ethernet port.

If anybody has thoughts on what else to try, it would be greatly appreciated. And if I can do any testing to provide additional data points to someone more knowledgeable than me, I'd be happy to.

Test your uart adapter on another device, or even just loopbacked to itself. Sounds like bad grnd in the adapter or other fault.

Thanks for the idea.

I've confirmed that the USB UART itself works as expected. I can log in to my raspberry pi over serial using this adapter. I also took the USB device out of the picture and connected the pi's serial pins into the R8000P, and I see the same behavior as I did from my computer with the USB adapter described above (garbled data when connected to TX, no data when connected to TX and RX.)

Ok, well that’s something. Where did you get the uart pin out for your device from?

Can you post some pictures of how you are connecting it?