Installing OpenWrt on Nanostation 5AC Loco


I want to install openwrt on my Nanostation 5AC Loco device with the firmware 8.7.0 Build 42152. I follow the procedure but I get this error;

WA# hexdump -Cv /bin/ubntbox | sed 's/14 40 fe 27/00 00 00 00/g' | hexdump -R >
WA# chmod +x /tmp/fwupdate.real
WA# /tmp/fwupdate.real -m /tmp/openwrt-19.07.3-ath79-generic-ubnt_nanostation-ac
Invalid version 'WA.ar934x.v8.5.0-42.OpenWrt-r11063-85e04e9f46'

What is this exactly? Where can I find a valid version or what should I do to install it?

Any help is appreciated

First downgrade it to WA 8.4.1 stock firmware. The patching of fwupdate.real is specific to that version.

Use the unmodified fwupdate.real to flash the different stock firmware.

Hello Mike,

Unfortunately, device prevents to downgrade below 8.5.3 due to Ubiquiti policy. They have limited to downgrade below the factory firmware version. I tried with 8.5.4 as well but no change.

Obviously the problem is this 'WA.ar934x.v8.5.0-42.OpenWrt-r11063-85e04e9f46' which is actually the firmware "openwrt-19.07.3-ath79-generic-ubnt_nanostation-ac
-loco-squashfs-factory.bin". It seems to be incompatible with the stock firmware 8.5.3+ and I don't know where to find the compatible one. Do you know where to download it from?

I downloaded and tried something from github but it gives another error like "MAGIC..." or so. I am stuck right now. Installation procedures described in the openwrt website is not complete I guess. There are some points which is assumed known by everyone but it is not like that. We are not all superb genius hackers. Installation procedures must be more spesific, step by step which is not right now.

You may need to go in stages not all the way down to 8.4.1 at once. When you use fwupdate.real it will also downgrade the bootloader, which is good since that's likely to be less restrictive to TFTP flash an even earlier version.

The official firmware is crypto signed. It doesn't matter what the version string is in an OpenWrt build, as both TFTP and the standard fwupdate.real will not accept any unsigned firmware.

Has anyone figured out how to install on a new Nanostation?

The one I just purchased came with 8.7.0. I was able to downgrade to 8.5.4 but still could not get any lower.

Any lower firmware is rejected with the message "Incorrect firmware version. Please upload v8.5.3 or newer and try again."

8.5.3 is no longer available from Ubiquiti. I'm guessing that one had a hole they are trying to hide.

In case someone else goes down the same path and ends up here. The hardware page really should point to the "Common Procedures for Ubiquiti Products" page first instead of providing outdated instructions.

I should also mention that the first read of these instructions leaves you wondering where the hexdump command is run and where ubntbox comes from. The instructions need to first say ssh onto the device.

You can help to improve the wiki by editing it.
If you do not yet have an account for the wiki, please send me a PM with your desired username and email address and I will manually create an account for you.