Installing OpenWrt on Linksys E8450

I tried to install OpenWRT on the Linksys E8450.
the firmware running on it is
I tried to upgrade it using:
But during upgrade it says it's not the right file format.
Any directions on how to make this happen?

To be more specific, it's running stock version:

This is what I'm getting. Any hints?

Follow UBI procedure at

Thanks, I however still get the same message
Likely, because I'm not getting to the console and select a different option?
How do I get to the console?

And you've followed the github how to?

Looking at the OEM version string, you might have a problematic version 1.1.00.xxxxxx
You might need to either downgrade or upgrade the OEM version first.

See the advice on Daniel's site:

Stock firmware version 1.1.x rejects the installer image. The recommended work-around is to downgrade to version 1.0 before running the installer.

Stock firmware version 1.2.x does not require downgrading.

Stock firmware version or higher, including 1.2.x require using the _signed.itb image instead

Thanks for the advice.
I did try to downgrade to this image: FW_E8450_1.0.01.101415_prod.img
It did accept the image, however, after this the site wouldn't come up anymore and it said luci not found.
Perhaps I should upgrade to 12.x first?

I think I did. I tried downgrading to version 1.0, but then luci wouldn't come up and I'd have no web gui anymore. So I had to factory reset again.

No real-life experience, sorry. I installed my E8450 1,5 years ago while the OEM was still 1.0 (I think).

The Linksys OEM firmware has no LuCI, so I am not quite sure what you mean.

If you mean the Linksys GUI, you might need to change browser or at least clear the browser cache. (The browsers are sometimes difficult to get to accept a changed certificate, token or something...)

1 Like

Thanks, I downgraded to version: Current Firmware Version:
However, I'm still getting the same message, image file is incorrect. :frowning:
I could try 12, but since I'm getting the same thing in 1.1 and 1.0, I don't know how much good version 1.2 will do?

Which OpenWrt image file gets rejected?
Note that based on that wiki advice, the 1.0 needs the unsigned image file, while 1.2 would want the signed image.

1 Like

Thanks a lot, I forgot. I used the unsigned image now and renamed it to a short name.
That worked, after that I used the sysupgrade image and it runs openwrt now.
Thanks very much for your help, we're running 802.11ax here now! :smiley:

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.