Installing OpenWrt on Appliance

Hi there, I have an appliance from Ipanema ip e 40ax V2 which is equipped with Intel(R) Atom(TM) CPU C2558 @ 2.40GHz, CF 1GB, RAM 4GB, 256GB HD, 2 Lan, 3 Wan.
I need to know if I can install an Image on it and what you recommend.



The standard x86_64 image ought to suffice, thanks to the Atom CPU, but the absence of any obvious video ports suggests you'll be confined to using the RS232 port to manage the thing:

I don't know the 40AX, so I don't know how to control its startup behaviour. The thing has two USB sockets so, if it supports booting from USB, you could flash the x86_64 image onto a USB stick, boot the thing from it, and see if the device behaves as you'd want, before taking any drastic steps such as flashing the on-board storage.

1 Like

There is no way around simply trying, some of these vendors lock down BIOS access (and booting from external media), others add in special-purpose hardware (mdio controlled switches, packet accelerators) for which no drivers exist.

The general procedure is always the same, pick legacy-CSM (traditional BIOS) vs UEFI as you need it, first try to boot from removable media (e.g. USB stick), if that fails, writing OpenWrt to the internal mass storage (SSD, compact flash, SATA DOM, etc.) might suceed, anything beyond that will need trying/ testing.

Sadly technical information and specifications are usually hard to find for these devices.

1 Like

actually appliance has a compact flash where OS is booting.

Ah! If the CF card is removable, and you have a spare (or don't mind forking out for a spare), you might be able to write OpenWRT to the CF card and give it go.

Good luck!

By the description, it sounds like another Lanner clone/spin off.

Feel free to post a photo of the PCB.

This morning I realise I didn't specify which x86_64 image.

Given the nature of the device and the limited options for direct interaction with it, I would suggest the squashfs image, not the combined image, for any experimentation you may wish to perform. As for whether to choose the EFI or BIOS image, well... the choice will depend on the board inside the box. Try both?

The choice is yours, but that's what I'd go with in your situation.

As you say, manufacturer blocked the access using some kind of bios protected by password. I removed Compact Flash and password request message comes up.

Yesterday I did two things, remove battery to reset bios but it didn’t work.
I tried moving left jumper and power up whiteout success.
After that I realized there is other jumper located in front of cpu heat sink, I moved to other position, powered up and appliance didn’t start. I switched the jumper to the original position and bios setup password disappeared.
Now I need to get a compact flash reader to load the sw image you suggest. I’m not sure if Lanner is the manufacturer.
Thanks for your help and support


1 Like

Of course! Heaven forbid you might want to find out how it works...

Congratulations on managing to get rid of the password, though.

I have a Lexar LRW300U on my desk, which has worked well. No idea if it's still available for purchase, though; I've had it for a while.

Not really, boot Openwrt from an USB flash drive, then write the same image to the compact flash while being connected to Openwrt using ssh.

Thanks for advising

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.