Installing on D-link DNS-313

Hi , I have been trying to install OpenWrt on my old NAS, following the device-specific instructions. I don't get very far though, I can prepare the disk (as instructed) and when i pop it in the NAS, it seems to boot up alright (on/off LED is on, and after some time the HD LED and network LED are also on, indicating that it went through some kind of boot process. However, it does not seem to take as IP address. There is no difference it seems whether or not it is connected to my home network or as a stand-alone device on it own network. i've done some nmap sniffing around on the network but nothing seems to ping back. Any suggestions? Is there a way to make some changes through config files (that i should be able to access when i re-cradle the disk)?



Connect your PC to the device directly and not over your existing LAN. The tutorial is telling you that.

Sorry didn't mention this specifically but also tried this, to no avail. No address can be obtained by the pc.


Well it is really hard to find the error without serial console access. Given the device is fully booted I would try to connect your PC directly again and assign a static IP to your PC e. g. with gateway

Alternatively you could try an older version like 19.07.2 or 19.07.1.

yeah that is exactly what i tried after not obtaining a lease, but no result

i have been perusing the rootfs system (by mounting the drive via USB and i noticed there are only files in /etc/config: dhcp, dropbear, firewall and mdadm - which looks a bit minimal but that could be due to the NAS setup? I'll try your suggestion to go with an older version - thanks!

That looks very minimal indeed. There should be at least a file network and system too.
Maybe that sth. was going wrong copying the image or the image itself is corrupted.

Did you verify the signature of the file? Did you try to repaet the copy process already?

First thing i redid the whole procedure, also tried using a couple of different image files, also tried the "original" OLD method described here:

it is definitely different (for example it has an additional file in etc/config named Samba), but the end result is basically the same, seemingly working well (based on LED status, looks like a normal bootup) but no access ...

I am starting to think it is something very stupid or perhaps unrelated to OpenWrt...

Well then I would check/swap the LAN cable first (if it is fixed correctly) and try to connect from another PC. Last option would be a defect (maybe just dirty) LAN port.

lan cables checked and switched. only have one pc with an ethernet port :-s but the one i am using works fine when i connect it to my home LAN.

I checked the led indicators in the device manual and the following is definitely interesting:

      *The LED will be solid GREEN when the remaining capacity of the drive is less than 5%.*

mine shows up as green.... although the drive is completely empty except for the boot stuff.... maybe should try a different harddrive?

I would check first the downloaded file and then assure that the drive is connected correctly during the copying process. Maybe avoid USB and use SATA directly.

Hallo Pieter,

It seems we are stranded in the same place, I was going to post the following message as a new thread, but it seems logic to follow-up on your message;

Dear All,

For just 20€ I picked up a D-Link DNS-313 with 500 gigs and it works as a file and media server no problem.

Of course, that was not good enough anymore as soon as I read this:

I took a 2GB drive and a virtual linux box to install the OpenWrt image following the instructions from that same page.

So I booted it when I got to step 5, no network cable connected, the disk indicator showed green. (I just learned while reading the forum that you fix that back to blue after step 7, no worry.)

I plugged it in and then came step 6:

OpenWrt things work as usual with OpenWrt: the device will give YOUR computer an IP from DHCP (as if it was a router), then it comes up and you can telnet or SSH in to set it up (usually just ssh root@ ).

That doesn’t happen. The computer on the other side of the cable first waits quite a while and finally says “unknown network” and shows:


Snipped empty connections

Adaptador de Ethernet Ethernet:

Sufijo DNS específico para la conexión. . :

Vínculo: dirección IPv6 local. . . : fe80::e931:7105:3128:1b6a%3

Dirección IPv4 de configuración automática:

Máscara de subred . . . . . . . . . . . . :

Puerta de enlace predeterminada . . . . . :

I also tried to plug both the NAS and the computer into the same router, the NAS keeps hiding.

Where do I search for it?

Thank you!

Sr. Gerard

That should be fixed after step 7 from here

I haven't tried any further (assuming that it may have been a HD problem and i wasn't going to buy a new one...) . i was never able to find the network address of the NAS

Have same situation. After connect to serial, we say that board don't want to boot linux image. Probably current support is only for model B that is identified as 313v3 but we have model identified as 313v2(my NAS is revision DNS-313 rev.A2G).

Boot log:
t disk 0
Disk Drive: IDE-0, Device-0, 250069680 Sectors [UDMA6] 128 GB 43 MB
Partition 3: Linux 32949 Sectors 16 MB
Partition 4: Linux 524349 Sectors 268 MB
foun file zImage

Processor: SL3512c2
CPU Rate: 300000000
AHB Bus Clock:150MHz Ratio:2/1
MAC 1 Address: 00:1E:58:AF:
MAC 2 Address: 00:50:C2:22:
inet addr:
Kernel RAM Location: 0x00600000 Filename: /.boot/zImage
Initrd RAM Location: 0x00800000 Filename: /.boot/ramdisk.bin.gz
PHY 0 Addr 1 Vendor ID: 0x001cc912
==> enter ^C to abort booting within 2 seconds ......
boot from ide
checked model name : dns-313v3
Bad Model Name!