Installing on Archer A5v5 (C50v5)

I'm trying to follow install instructions posted by bill888. My router looks like the left image (2 antennas) at https://openwrt.org/toh/tp-link/archer-c50. On the bottom of my router, I see a sticker that says "Model: Archer A5(US) Ver: 5.6". Before I try loading openwrt, I'm hoping someone might be able to answer some questions for me to reduce the chance that I screw up :slight_smile:

I think I found the right file in bill888's dropbox (tp_recovery.bin within Archer A5v5 (C50v5) Test - 16MB.zip), but I'd love to confirm via md5sum or similar. Does anyone know such a hash?

I've set up my desktop w/ tftpd and a static IP. What port on the router do I connect the cable to?

I know I'm supposed to hold the reset button while booting the router. How long do I hold it? How do I know it's done?

Once it's done and I reset my desktop to regular networking, will I be able to connect a cable to any LAN port and see the openwrt interface at 192.168.1.1?

Thank you!

Jason

Any LAN port can be used before and after installing Openwrt.

I can't remember with my former C50v4, but I think just keep Reset button held down until you see the transfer take place if you are using TFTPD32/64 for Windows.

About 10 seconds after power on, while holding the RESET button

Stock to openwrt (from my original copy stored on hard drive). Hash matches one found in my dropbox folder.

D:\Temp>md5sum tp_recovery.bin
699adb0a5befbbfae12bbe80bb8e9b7e *tp_recovery.bin

Note that 2.4 GHz wireless range is degraded. The fix is not in stable editions or snapshots. See bottom of wiki page for C50 for link to thread where you will find a patched 19.07.4 sysupgrade image created by @VintageRain which could be installed afterwards.

1 Like

Wow, thank you Bill!

I tried it a few different times, but haven't had success yet. I wonder what I'm doing wrong.

I confirmed that I can use tftp from my phone and a mac laptop to download the tp_recovery.bin. I configured tftpd to be extra verbose so that each request is logged in /var/log/syslog

After I have set my (Linux) desktop to use the static IP, ifconfig reports:
inet 192.168.0.66 netmask 255.255.255.0 broadcast 192.168.0.255

My md5sum matches---thanks for that!

When installing, I start with the router plugged-in, but switched off. I hold the reset button, then turn on the router. I keep holding the reset button. Watching /var/log/syslog (copied below), I see my ethernet port cycle down/up a few times. After about 2 minutes, I haven't see any tftpd log messages and I give up :frowning:

Oct  4 15:24:06 sancerre kernel: [1797250.409621] r8169 0000:25:00.0 enp37s0: Link is Down
Oct  4 15:24:25 sancerre kernel: [1797269.888092] r8169 0000:25:00.0 enp37s0: Link is Up - 100Mbps/Full - flow control off
Oct  4 15:24:26 sancerre kernel: [1797270.163998] r8169 0000:25:00.0 enp37s0: Link is Down
Oct  4 15:24:30 sancerre kernel: [1797275.026016] r8169 0000:25:00.0 enp37s0: Link is Up - 100Mbps/Full - flow control rx/tx
Oct  4 15:24:43 sancerre kernel: [1797288.004714] r8169 0000:25:00.0 enp37s0: Link is Down
Oct  4 15:24:45 sancerre kernel: [1797289.626303] r8169 0000:25:00.0 enp37s0: Link is Up - 100Mbps/Full - flow control off

In the end, I still see the tp-link UI at 192.168.0.1 with the old configuration. Might there be something obvious I'm doing wrong?

Thank you!

Jason

The file transfer should start within 10 seconds of turning on the router.

Some suggestions based on quick google search for similar TPlink routers such as the C7:

Hold the Reset button down. Turn on the power. Release the button after 5-10 seconds. The file transfer should start.

Install an ethernet switch (or may be use any old router not with LAN IP 192.168.0.x of course) between the A5 and the computer?

Only other suggestion is to borrow a Windows computer to see if it makes any difference if it is an ethernet issue which I've witnessed with some other routers (not TPlink) when wanting to use TFTP.

1 Like

I tried holding for 5-10 seconds and plugging both the router and my computer w/ tftp into a switch, but didn't get it to work. I'll probably try a few more times.

Ultimately, I'm looking for a solid ethernet router, so I might try a Ubiquiti EdgeRouter.

Thanks for all the ideas and help!

fwiw, are you using any 3rd party antivirus/security/firewall software on your Windows PC?

I recall the first time you use TFTPD32/64, the access control box for firewall settings usually pops up if you are using Defender, and I normally tick both boxes to allow app to be used on private and public networks. It's the only other thing I can think of which might cause problems.

1 Like

My desktop is Linux and there's no firewall. I can easily download the file from a Mac laptop plugged into the same switch (when both machines are using dhcp assigned by the router). I guess the only thing I haven't tried is using tftp to download when I have my desktop configured with the 0.66 static IP. I might give that a try...

Sorry, I should have mentioned, but we don't have any Windows machines in our household.

Thanks for all the ideas :slight_smile:

Jason