Installing LEDE on EA3500

How do I tell which is which?

I'm guessing this is a release build since it has release in the URL

Yes, the top directory at -- either "releases" or "snapshots" -- provides a good hint. :wink:

The last time I tried to install LEDE from stock Linksys on my EA3500, about a month ago, it wouldn't flash, both stable and development builds failed. If that happens to you, just install OpenWrt and then install LEDE from OpenWrt. Also, you might want to look at this thread and the fixes they discuss, my EA3500 has the same dropping problem as the EA4500 (they're almost identical devices).

1 Like

lede include package

Is this the config you would use if you were to build your own?

I'm confused and not sure what this is

I think @ahmadrasyidsalims meant to show you which packages came by default when using builds from the builbot (here for the release build). This is not a config you would normally require to do anything with.

If you build your own, you don't have to get that config neither, you just have to make menuconfig, select target, save and exit and make. This would result in the same default configurations used by the buildbot.

As a new user of LEDE, if you also want to build your own firmware, take your first steps here:

1 Like

Same thing happened here. I tried flashing the lede bin file from stock linksys and it wouldn't take.

I was able to flash the openwrt trunk build r47197 git-15.310.28416-524c918. I used the squashfs from wolftek's website since it has Luci.

I then made the mistake of trying to flash with the lede bin which didn't take.

The lede sysupgrade one also didn't work.

tried openwrt sysupgrade and it also didn't work.

When I got my EA3500, it's build was already in OpenWrt trunk so I never used the Candyhouse build and I'm not familiar with it, I'd assume since you used the squashfs-factory.bin file you would be able to upgrade normally, so I don't know why it didn't work, maybe someone who's familiar with Candyhouse will run across this and be able to help.

In the meantime, it looks like only one flash has worked, so the stock Linksys firmware should still be on the other partition, you can boot into it by interrupting the boot 3 times -

Unplug the EA3500
Plug it in
Wait a few seconds and then unplug it before it boots completely
Wait a few more seconds and then plug it back in and repeat the above
Do that 3 times and on the 4th time leave it plugged in and let it boot.

That should take you back to stock Linksys, from there you can install the OpenWrt trunk build without Luci (not Candyhouse), and I can show you how to install Luci from there or how to upgrade without Luci, it's really pretty easy. Also, looking through the comments on the Candyhouse page, it sounds like you can flash the stock Linksys firmware form the Candyhouse gui, but I'm not positive about that, it's probably best to try and boot into the other partition first.

1 Like

I wasn't able to get it to boot to the stock linksys firmware with the unplug method, I reflashed instead and got it to stock.

I did some googling and reading. Is it as simple as flashing openwrt bin file first then using download sysupgrade file to tmp then using the sysupgrade command?

If so, I'm not sure which openwrt file to use.

Is this the guide for downloading the sysupgrade file to tmp? Would I replace with the lede sysupgrade file?
Starts at For sysupgrade-based upgrades

Do I need the verbose command since I'm not saving any configurations or packages?

Since I'm doing everything from stock, do I have to save any configurations or packages?

Does the sysupgrade file end in extension tar or do I have to extract and compile it?

So I would have to ssh into the router? I'm planning on using kitty, I'm on a pc x86.

Ok, here's my attempt at a step-by-step:

Preliminary step: router WAN port connected to your modem and LAN port connected to your computer.

  1. Under Windows, download and install Putty or your favourite ssh emulator.
  2. From the stock firmware, flash OpenWrt using this snapshot build:
  3. Using Putty or your favourite, connect to your router using host name, port 22, Connection type SSH
    a. Login as user root, no password
  4. Type the command opkg update
    a. There should not be errors like "failure to download" - usually means that your Internet is down
  5. Type the command opkg install luci-ssl
  6. Type the command reboot
    a. Wait for the router to come back online (you can ping from your connected PC to know when it will be available)
  7. Using your browser, connect to "". Add an exception for the warning about the certificate.
  8. Go to the upgrade firmware menu and now use this firmware:
    a. Do not retain settings
  9. Now, you should be on LEDE finally
  10. Assign a strong password to the root user
  11. Set Dropbear listening interface on the LAN side only

If OpenWrt ==> LEDE still doesn't work with Luci, you can try from the CLI using putty also; using the following commands would do a sysupgrade:

cd /tmp
sysupgrade -n -v lede-17.01.2-kirkwood-linksys-audi-squashfs-sysupgrade.tar


I'm stuck at failure to download, should I connect the router wan port directly to my cable modem then a lan port from the router to my pc?

Absolutely, I forgot to mention that, but that's standard flashing procedure anyway.

a simple power cycle fixed it of all thing :joy:

luci is still installed for lede after I used sysupgrade.

should I uninstall before I install luci-ssl?

It's installed but not in ssl mode (https). I changed my original post to give instructions to install it ssl right away instead of afterwards.

Give it a try without uninstalling first. After a reboot you should only able to connect to https and not http anymore.

If you want to build your own OpenWrt/LEDE
This is example config... Automatically generated file;

Refrence :

Thank you and everyone else! Everything worked perfectly.


Very good step by step instructions, DjiPi. Everything worked perfect!!!

1 Like

what a stupid mess this whole project split and re-merge process created!

now there are 2 factory images for this device and the later doesn't work. of course working one is not shown in directory structure!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.