Flashing 18.06.1 on Linksys EA3500 fails


I'm trying to install 18.06.1 on the device (from the stock factory image from Linksys to OpenWRT) and after flashing, it fails and goes back to the old firmware (this router has a backup firmware)
According to the device page
18.06.1 should be supported on this device.

The page mentions that you might have to first install 15.x LEDE to make it work, but I could not find an 15.x image for this router. I'm also not sure how LEDE relates to OpenWRT, I have seen a lot of forum posts referring to it.
I got a tip from a forum that a known snapshot image would work, so I installed that one, and it did work.
What I have installed now is: DESIGNATED DRIVER (Bleeding Edge, 50072), which was from 2017 if I'm not mistaken. It does work, but is probably not recommended for productive use. I installed luci on it and then tried the upgrade image for 18.06.1 again from this point and it failed again.

Is there a special trick to get this router on 18.06.1?


Use the previous 18.6.0, 18.6.1 is not ready yet

There is already quite a number of topics regarding installation of OpenWrt on EA3500 -> https://forum.openwrt.org/search?q=ea3500

There is also a bug report: https://bugs.openwrt.org/index.php?do=details&task_id=1810


That's ancient. Current snapshots can be found here: http://downloads.openwrt.org/snapshots/targets/

Prior to flashing 3rd party firmware, it's recommended to have access to a USB-TTL cable or USB-to-UART for serial access, as the only way to troubleshoot boot issues is by connecting via serial.

  • I personally recommend anyone flashing OpenWrt to install a 3.5mm Female Audio Jack on their router, which ensures the user will only ever have to open their router's case once for serial access.
    • You can find instructions for doing so under the 3.5mm Jack Install tab
      • While the wiki pages is for the WRT AC Series, that specific tab is applicable to any router
    • A USB-TTL-AJ cable would be required for use with the female 3.5mm jack

You do not need a USB TTL cable for flashing OpenWrt to the EA3500 OpenWrt 17.5 and OpenWrt 18.06 will flash from stock. The bug is in OpenWrt 18.06.1.

From factory, this worked for me then upgraded to present release just fine:

Ah but this was for 18.06.0 -- so I have yet to try 18.06.1

A lot of info that is not needed in this post. From the webinterface just upload the .bin file and away you go!

Did you read the bug report and look who made it! The ea3500 is not booting back to it's old firmware the sysupgrade does not even start. I know what you are talking about and you are making things more complicated.

My bad, you're right.

(I deleted my two previous posts, as I missed the Bug Report and my posts were making things more complicated)

I've looked at that discussion and I can't get it to work. Which snapshot image am I supposed to be trying? The link provided redirects to the archives, and there are no snapshots there. If I try to flash 17.x or 18.x, the router says that it worked, but then the LinkSys firmware shows up instead.

Try a current snapshot, I don't know if it will work or not, but in general snapshots seem to be the only builds that will flash from factory on the ea3500.

Nope, no luck.

The progress bar doesn't fill up all the way before it switches to telling me that the router is rebooting. Is that expected, or could that be an indication of a problem?

It's been so long since I flashed from stock I just don't remember. I used to have a build from November or December last year that I know worked on my ea3500, but I don't know if I still have it or not and I don't have access to the drive it should be on right now, but I'll check when I can, late tonight or tomorrow, and if I still have it I'll put it in a dropbox so you can give it a try if you want.

Just wanted to report that I managed to install 18.06.0 successfully, but not 18.06.1, which does not work, the install fails and the router reboots 3 times, restoring the backup partition firmware.
So for now, 18.06.0 is good enough for me.

Borrowed and laptop and checked, but I don't seem to have it anymore unfortunately, @LinuxAPUser seems to have had luck with 18.06.0 though, so that's worth a try.

I've tried 18.06.1, 18.06.0,

I had somehow managed to get r47197 on there previously (don't remember how), but flashing from that wouldn't work neither. Tried upgrade and factory at that point. It just doesn't want to budge.

Can anyone upload again working from GUI flashable factory.bin of 15.05? I can't find it nowhere :frowning: