Installation on Linksys EA7500 fails

This is my first day with openWRT. I followed the instructions on to the letter. This was initially a challenge. It took me about 2 hours to get into manual config mode so I could load the firmware. Before updating, it complained about the file name. I chose YES,, continue anyway and it said it was flashing.

When it rebooted it was still a linksys, so following the instructions I flashed again. Still a linksys. Tried a reset and flashed again several more times, still a linksys.

Being new at this, I have no idea what to try next, or perhaps it just isn't possible.
Any help resolving this would be greatly appreciated.

I don't have that model so the only thing I have to offer is make sure you're using the right instructions and firmware. There seems to be a v1 and a v2

I just discovered that this problem was discused in Problem installing on Linksys EA7500v2 as recently as September 2, 2022. It seems that the end result was failure.

So I'm probably wasting my time trying to do this. After all it's been said that trying the same thing repeatedly and expecting a different result is one definition of insanity.

Still, If anyone has an idea about how to make this work, I'm all ears

This series of devices have A and B boot partitions. You may have successfully flashed to "B" but are still booting "A". If either A or B won't boot after 3 attempts the router will move to boot the other partition.

I have an EA7300 V2 (I submitted the patch to add V2 to the OpenWrt repository) and it runs like a champ

BusyBox v1.35.0 (2022-10-14 22:44:41 UTC) built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 OpenWrt 22.03.2, r19803-9a599fee93
root@Shepnet:~# uptime
 12:33:08 up 23 days, 19:15,  load average: 0.16, 0.08, 0.07

What I would recommend is downloading the factory firmware and flash it over itself.
Then follow the instructions:

Thanks, I'll try that

What is the best way to reboot? GUI or power cycle?

I do not think it matters. Essentially
s_env is the boot counter and if it reaches 3 then it switches boot partitions.

Although it's initially a pain, essentially you have a built in back-up.

i have the ea7500v1 non US
and I hate that recovery thing
if you have trouble plunging in you power plug
it all oh a sudden turns from an access point to a router
I wish both firmware's shared the config at lest

can't see it i the ea7500v2 page but i believe it's the same as the EA8500
where the US version is different & you can't flash it with out opening it up

I flashed again, then did 3 restarts from the gui followed by 4 reboots with the power switch. It's still a linksys.

It's not clear from that page what you do after you open it. Any more info?


i'm sure it wants a serial adapter setup on it and then

#### How to flash with workaround for altered vars

* connect ethernet and serial cable

* [run a TFTP server](

* set ip address of TFTP server to

* put openwrt factory image to tftp folder

* connect via serial `picocom -b 115200 /dev/ttyUSB0`

* stop device while booting in u-boot

* run commands:

setenv image <filename for openwrt image on TFTP server> setenv ipaddr setenv serverip setenv flashimg2 tftp '$loadaddr $image; nand erase $altkern $imgsize; nand write $loadaddr $altkern $filesize' saveenv

This last line `saveenv` writes these env vars to memory, so you don't have to retype them if you need to begin again

run flashimg


run flashimg2



At this point router will reboot and you can monitor via the serial connection and verify that it is NOT Linksys firmware. If you got `Loading T T T T T…` error it means the bootloader can't download firmware, check your TFTP server, firewall or serial connection.

Thanks. I will study this and see if I can get a serial czble attached

I was able to do it without cracking the case or using a usb serial adapter but it took a number of tries.

This is a bootloader issue. My guess is that the bootloader reads the boot count and if it is not equal to 3, increments the count by 1 and continues to boot the prior partition. If = 3, boot other partition. Not sure if a successful boot resets the counter back to 1.

Assuming it does reset, it won't flip partitions until it fails to complete. You could test this by powering up and when it starts to boot, switch it off x 3. I also read someplace, that flashing the factory firmware over itself switches boot partitions. I surmise this is more of an inference from boot behavior rather than working through the boot code.

Flashing the factory firmware over itself was one of the things I tried and after doing so, my OpenWrt flash was successful.

my model in Australia was the same but the US models have different firmware

It's worth a try. Thanks