Installation of OpenWrt on Litebeam m5

I have a litebeam m5 23 db and I would like to install openwrt .. once I installed it from the same administration page but I had to reset it from the factory and it had air os again and now it does not let me install lede that could do? greetings and thanks

Hello, did you get it installed? It tells the firmware would be invalid.

Hey Guys,

what's about the integration? I found offical support for LiteBeam M5 on openwrt device page. There is an offical sysupgrade and factory image, but of course it won't load via web-ui.

Now I used SCP to copy newest openwrt image into /tmp and tried it via ssh:

XW.v6.1.7# fwupdate.real -m fwupdate.bin -d
Found mtd block: /dev/mtd0(u-boot)
Found mtd block: /dev/mtd1(u-boot-env)
Found mtd block: /dev/mtd2(kernel)
Found mtd block: /dev/mtd3(rootfs)
Found mtd block: /dev/mtd4(cfg)
Found mtd block: /dev/mtd5(EEPROM)
Got U-Boot variable: mtdparts = mtdparts=ath-nor0:256k(u-boot),64k(u-boot-env),1024k(kernel),6528k(rootfs),256k(cfg),64k(EEPROM)
Adding U-Boot partition: u-boot 9F000000 00040000
Adding U-Boot partition: u-boot-env 9F040000 00010000
Adding U-Boot partition: kernel 9F050000 00100000
Adding U-Boot partition: rootfs 9F150000 00660000
Adding U-Boot partition: cfg 9F7B0000 00040000
Adding U-Boot partition: EEPROM 9F7F0000 00010000
Calculating flash size:
Adding block: /dev/mtd0("u-boot") - size: 00040000
Adding block: /dev/mtd1("u-boot-env") - size: 00010000
Adding block: /dev/mtd2("kernel") - size: 00100000
Adding block: /dev/mtd3("rootfs") - size: 00660000
Adding block: /dev/mtd4("cfg") - size: 00040000
Adding block: /dev/mtd5("EEPROM") - size: 00010000
Total flash size: 00800000
Flash start: 9F000000
Flash end: 9F800000
Current: XW.ar934x.v6.1.7.32555.180523.1754

New ver: XW.ar934x.v5.6.15.30572.170328.1052
Versions: New(329231) 5.6.15, Required(328971) 5.5.11
FW Part: "u-boot"(1), MAGIC: 'PART', Base: 0x9F000000, DLen: 0x00037CAC, PLen: 0x00040000
FW Part: "kernel"(2), MAGIC: 'PART', Base: 0x9F050000, DLen: 0x000E9789, PLen: 0x00100000
FW Part: "rootfs"(3), MAGIC: 'PART', Base: 0x9F150000, DLen: 0x005E0000, PLen: 0x00660000
FW Part: "script"(4), MAGIC: 'EXEC', Base: 0x00000000, DLen: 0x00006BBD, PLen: 0x00006BBD
Bad Image Structure
Signature check failed
XW.v6.1.7# fwupdate.real -m fwupdate.bin -d -f
Bad Image Structure
Signature check failed
XW.v6.1.7# fwupdate.real -m fwupdate.bin -d -force
Bad Image Structure
Signature check failed

I also did this with official Firmware XW.v6.1.7.32555.180523.1754.bin

Here I saw much more ongoing and I guess there was a real flashing because the device runs now 6.1.7.

Unfortunately I have no serial access. I don't know how to open the feedhorn and get it waterproof after opening again. - So as far as I understood in some other discussions we need a beta-image (I registred and accept terms for beta, but couldn't find betaimages at ubiquiti-pages), flash an unsigned old image (offically available on OEM-site) and from there flash the openwrt*.factory image. A direct flash of unsigned images don't work, it stops with error code 43.

I would love if we could get this device to work under openwrt because I wanna use wiregurd with this device and I don't know how to install this on OEM-FW. I guess no chance for it :wink:

Any experience for performance with this device under openwrt?

The device-page in openwrt:

Hey Guys,
Have you been successful in installing OpenWRT on Litebeam M5? I have been unsuccessful in downgrading to xw.v5.6, any attempt to install any firmware lower than xw. v6.17 I lose GUI and SCP access, my only successful procedure has been through TFTP.

I have finally been able to successfully install OpenWRT19.07.x on the Ubiquiti Litebeam M5. I have tried several installation processes I could find on the web which was not successful for me. I was able to install OpenWRT after downgrading to XW.v6.1.3 via TFTP.

The popular suggested method: "Downgrade to unsigned version via AirOS web GUI only possible using v6.0.6-beta firmware(FW). First upgrade/downgrade to v6.0.6-beta, then downgrade to unsigned v5.6.15. Just then it will be possible to downgrade to an even lower AirOS version, e.g. v5.5.11." was unsuccessful for the Litebeam M5 with Atheros AR9342 rev 3.

Unsuccessful Procedure

  1. Flashing via ubnt GUI failed to accept any FW lower than XW.v6.1.3. "Firmware image check failed. Error code: 43"
  2. Flashing via SSH using ubnt fwupdate.real command failed to accept any FW lower than XW.v6.1.3
  3. Flashing via TFTP did accept FW lower than XW.v6.1.3 but with "Initialization Error A12".

Successful Procedure
I installed the "cs" custom scripts versions of airOS in this order

  1. via web GUI or SSH: from XWv6.1.7 to XWv6.1.4

  2. using TFTP downgrade to XW.v6.1.3 then Open WRT 19.07.x factory (this process must be done via TFTP).

the regular AirOS FW might work but it was not tested.

AirOS firmware custom script Download

PS I have installed this on 3 different Litebeam M5 following this process. I hope this would save a lot of people some headaches.

Here are some Notable links

[ 0.000000] Linux version 4.14.215 (builder@buildhost) (gcc version 7.5.0 (OpenWrt GCC 7.5.0 r11278-8055e38794)) #0 Tue Jan 19 13:10:02 2021
[ 0.000000] MyLoader: sysp=a5a5a5a5, boardp=a5a5a5a5, parts=a5a5a5a5
[ 0.000000] bootconsole [early0] enabled
[ 0.000000] CPU0 revision is: 0001974c (MIPS 74Kc)
[ 0.000000] SoC: Atheros AR9342 rev 3
[ 0.000000] Determined physical RAM map:
[ 0.000000] memory: 04000000 @ 00000000 (usable)
[ 0.000000] Initrd not found or empty - disabling initrd
[ 0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
[ 0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes


would someone help to downgrade my Litebeam M5?
I can't find xw6.1.4 oder xw6.1.3 firmware. I can download other versions, but not these ones. Maybe someone could help.

How is the performance compared to airos under openwrt doing?

Then click "see past firmware"

1 Like

Hello, how are you?, can you use opendns from Litebeam m5?, I would like to configure a captive portal there.

Hi all,
question to the moderators: is this equipment going to have an openwrt firmware for the versions 21.x ?
From the HW requirements, it seems fine ...

thanks in advance

It is probably the same hardware platform and can run the same firmware as the Nanostation M5 loco XW, which has been ported. But I offer no guarantee of that. If you have the old bootloader which does not check firmware signature, you can easily TFTP debrick direct back to OpenWrt.

1 Like

No consegui mediante ningún proceso posteado instalar openwrt en mi litebeam m5 xw.
Sin embargo instalando previamente la version sin signo
y a continuacion desde gui el openwrt del loco m5;

funciona perfectamente :frowning: :slight_smile:

¿cuál será la diferencia entre:
openwrt-19.07.10-ar71xx-generic-ubnt-loco-m-xw-squashfs-factory.bin funcionando y
openwrt-19.07.10-ar71xx-generic-ubnt-lbe-m5-squashfs-factory.bin que acaba colgado?


The preferred language in the OpenWrt forum is english.
When writing in your native language, please always provide an english translation.
This way other users all around the world can take part in the discussion and possibly benefit from the outcome, without having to use a translator.

Thanks! :slight_smile:

Version 19.07 and all ar71xx builds are deprecated. Most models in the ar71xx tree have been migrated to ath79 and continue in later versions. However, the Litebeam M5 has not been migrated.

The Nanostation loco M XW appears to be the same chipset and general hardware platform as the Litebeam M5, except it has a dish antenna system (which makes no difference to software). I was suggesting to try the ath79 loco-m-xw build, since there is no ath79 lbe-m5 build. I do not have a Litebeam M5 to try this myself.