Install router after powerline OpenWrt

no that doesn't work at all sorry

the modem box interface is 192.168.1.254

I tried with the router in 192.168.2.1 and in 192.168.1.1 I have internet but I cannot access the interface of my box to create and open the ports (dmz)

in ip I have this address I don't know why in overview

192.168.1.55/24

I resume it is like that

modem router bbox + first cpl / second floor + cpl + openwrt router

may be an ip conflict

@dlakelan @Kherby

If you followed mk24's suggestion

Your ISP provided device should function only as a modem.

I would like to deactivate the function but impossible,

there is no bridge mode as in many countries on this bbox it is required to make a modem router

I would set up the topology as

ISP device > OpenWrt device > powerline 1 > powerline 2 > ps5

If the ISP device has no bridge mode you will need a second separate IPv4 range for the OpenWrt LAN. You can try something like 10.9.8.0/24

1 Like

ok so isp device -> router openwrt -> cpl 1 on the ground floor -> cpl 2 floor -> ps5
the ethernet cable of the cpl1 I connect it to the isp peripheral or to the openwrt router?

To the OpenWrt router. The ISP device connects to OpenWrt WAN

1 Like

and the router openwrt "lan" to first cpl ethernet ? then just a second floor connect to cpl 2 the console and pc ?

Capture d’écran 2021-05-16 à 15.23.22

my router openwrt will make have do wich lan ip ?

@dlakelan

  • openwrt router is in router mode:
    -> Internet BOX and openwrt are currently connected by RJ45 PORT1 of the BOX to the WAN port of the openwrt
    -> the IP address of the openwrt is fixed, in 192.168.1.X in the interface of the internet box
    -> port 1 of the openwrt is connected to a PLC box which distributes to the other PLCs. All the equipment on the PLC network is therefore managed by the openwrt in 192.168.2.X.

it's correct ? i will retry tomorrow thanks so much

The OpenWrt LAN can be any IP other than 192.168.1.X. 192.168.2.1 is suggested, or anything in the 10.0.0.0 range. The OpenWrt WAN will have a 192.168.1.X IP to link to the modem.

Don't let any device connect directly to the modem except the OpenWrt router. Turn off the wifi in the modem if you can.

1 Like

bbox + powerline + 2nd powrerline + router openwrt

this solution is possible you think for just ps5 and pc ?

i' use chrome i will test with edge because chrome can cause an error dns i saw

Yes you can put the powerline link on either side of the OpenWrt router. Placing the OpenWrt router upstairs may have better wifi coverage.

1 Like

If you can't disable routing at least disable wifi. You can't have any devices connecting directly to the ISP other than openwrt

1 Like

ok thanks for the response everybody

this is the screen of my first intention

Capture d’écran 2021-05-16 à 21.22.31

This can work, as long as the powerline stuff works well. Make sure you set up SQM based on tests from a machine on OpenWrt LAN

1 Like

i would use your script :wink: the cpl is netgear plp2000

Yes or script, but set speeds based on tests from the LAN

1 Like

Hello everybody so i have put the routeur in the bix i have make a dmz to the router and i have a nat open

But my ping is over 20 ms before and i have packet loss

Why you think

Just enabled dmz and static in bbox

Run your speed tests and set your speeds correctly

1 Like

ok i have make also that i don't understand why

ok i think have found the solution grace to the thread

http://jelnet.online.fr/jlnt_bou2.htm#:~:text=Le%20routage%20doit%20normalement%20être,ou%20non)%20le%20serveur%20DHCP.

the bbox has a option route static

the bbox has a interface server to 192.168.1.254

the router has a 192.168.2.1

the overview in openwrt is the next
protocol dhcp
adress192.168.1.55
gateway 192.168.1.254
dns 192.168.1.254

if i understand i make a routage static to bbox with ip destination ? 192.168.1.55 it's right

thanks for response by advance

he has a sthread too in the forum

@vgaetera you can help me you maybe ? thanks