Install an IPK packet in the kernel with SDK

From the WEB interface I do not have any problem installing the package "NODOGSPLASH2"
I do an update of the packages then I install it.
To activate it I go into the file nodogsplash.conf.

But if I do a "RESET FACTORY" of the router, the packet will be deleted the next startup.

So I want to integrate it into the kernel with SDK.

I do :
make menuconfig
I go to "NETWORK" then "CAPTIV PORTAL" and I validate "NODOGSPLASH2"
and after being released.
I run the command "make"

All this goes well during the compilation.
I do an update of my firmware on the router and there also all this goes well, but I do not return the files of "NODOGSPLASH", as if he had not taken the installation.

I also tried the following solutions:

  1. I have downloaded the IPK file from nodogsplash
  2. I put it in bin / packages /
  3. I added the information in the Package & Package.manifest file

I ran the command "MAKE"
Then updated the firmware and always the same, the software nodogsplash does not appear.

I also tried this solution:
in the directory / LEDE
./scripts/feed update -a
./scritps/feed install -a
./scritps/feed install nodogsplash2


I ran the command "MAKE MENUCONFIG"
I chose NODOGSPLASH2, I save and I leave /
I run the command "MAKE"
I upgrade the firmware
AND always the same, the NODOGSPLASH2 software does not appear.

I recall that if I do it since the interfcace of the router, it works but if I do a "RESET FACTORY" it fades.

Thank you for your help.

Same is achieved much easier with the image builder.

Hi Stan

Do you have a procedural example, what should I do to make it work?


@Francesco this page has useful examples: