Initial install, setting up WAN for router

Hi, I'm new to openwrt, I have a NETGEAR EVG2000 which I've loaded with openwrt 19.07 & Luci.
I can ssh and use web GUI thru the ethernet ports. I'm trying to set the device up as a router. When I connect the WAN port from the default install to an existing router per the setup instructions, the ping etc. from openwrt fails. Although the instructions say the default install should work as a router, it seems to be missing wan setup.
https://openwrt.org/docs/guide-quick-start/troubleshooting_internetconnectivity
My understanding is that I would need to add something like the following to /etc/config/network, but the eth0.2 looks like a virtual network according to the articles I've read.

config interface 'wan'
option ifname 'eth0.2'
option proto 'dhcp'

Any pointers etc. would be greatly appreciated.
Current network below
root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fd03:368e:7680::/48'

config interface 'lan'
option type 'bridge'
option ifname 'eth0'
option proto 'static'
option netmask '255.255.255.0'
option ip6assign '60'
option gateway '192.168.0.1'
option ipaddr '192.168.0.2'

Make sure the existing router is not using the IP range 192.168.1.X. It doesn't work to route between two subnets that are the same. You will need to change your LAN IP or reconfigure other router and network.

Then the otherwise default settings will work. To route, plug the upstream network into the WAN port and let the other router's DHCP configure it. Do not add gateway or DNS to your lan settings.

Many thanks for the reply. I working wit hthe following setup:
PC 192.168.2.3 - openwrt router (192.168.2.1 (LAN port) - (WAN port) - existing network 192.168.0.x

Ping via Luci returns " ping: bad address 'opewrt.org' "
/etc/config/network

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fd03:368e:7680::/48'

config interface 'lan'
option type 'bridge'
option ifname 'eth0'
option proto 'static'
option netmask '255.255.255.0'
option ip6assign '60'
option gateway '192.168.0.1'
option ipaddr '192.168.2.1'

Does the wan port need to be configured.
Is there any other config I should publish.

Any pointers would be greatly appreciate.

Further examination shows this model is a DSL gateway with Broadcom chips, so the switch may not be set up in the conventional 4 + 1 scheme out of the box.

2 Likes

It doesn't look like there has been any success in enabling the WAN port on this device.
https://forum.openwrt.org/t/installing-lede-on-evg2000/11553/13

Apart from the initial commit to add support for this device in 2016, it doesn't look like there has been any further useful development.

1 Like

Many many thanks, I did not come across this post in my searches.
It explains a bit.
Looks like i'll have to get a newer bit of HW :wink:
Thanks again