Init routine goes into loop when trying to execute ubus with custom image for Deco M4R


I'm slowly making progress with my custom firmware for the TP-Link Deco M4R.

I can load the ramfs image vie tftp and boot from that but the init routine then hangs when it tries to execute ubus.

This is the log. I've included me uploading the image via tftp and pressing [4] at the right time so the output is as verbose as possible.

Error code 32512 seems to be that ubus can't be found and in fact when I go into failsafe mode during startup and check for it in /etc/init.d then there is nothing called ubus.

But when I check with make menuconfig then there are asterixes for ubus and ubusd under "Base system".

Does anyone know what I'm doing wrong here?

when I go into failsafe mode during startup and check for it in /etc/init.d then there is nothing called ubus

procd seems to be hardcoded to start ubusd, so i think (i dont have a running openwrt system yet) the non-existing /etc/init.d/ubus is not an issue. in fact your ubusd is started repeatedly but dies immediately.

did you try building on debian?

Didn't think someone would unearth this post after that long.

It definitely has something to do with using ubuntu to build the firmware. Here are others with the same issue and nobody has replied back that it didn't work with debian, so I'm guessing that ubuntu is the cause: X86_64 build of 21.02 doesn't boot because ubus exits with error code 32512 - #4 by bobthebuilder

There are also others who have successfully build newer version of openwrt based on my mod, so I'm guessing it's really just a matter of not using ubuntu.

I'm currently fine with my 19.07.8 build and all three devices are in use right now, so I haven't tried anything newer yet. That's why I've never wrote an update and will probably leave this topic open until I get around to upgrading my devices.

according to what i've read, it's not just ubuntu that's affected. it'd be better if people reported which OS and version they tried and what was the outcome. which would've been the next question for you :slight_smile: anyway, thanks!

root cause found: see #9545

1 Like