[INFO] 40MHz misconception on ath9k

I observed something interesting that has confused some people in this community. I wanted to observe and confirm that my device was still switching to 40 MHz bandwidth after upgrading to version 18.

Upon setting my 2.4 GHz wireless to Force 40MHz, I noticed that the device was still in 20 MHz mode. Using a WiFi (spectrum) analyzer, I noticed that my SSID was in fact in 40MHz mode!

I realized that the wireless client still refused to enter 40MHz mode while the band was congested. I could only confirm the AP was in 40MHz mode with a Wireless Analyzer. Hope this helps some people.

1 Like

like you couldn't just log into luci or console and check txrate..

I did. It shows 20Mhz. Apparently, because that's the rate of the client.

Hence, the need for a Wifi Analyzer.


The "analyzer" apps on smartphones are based on the channel and bandwidth that the APs advertise in their beacon packets. They do not actually scan the spectrum, the drivers in the OS do not allow that.

Also g, n and ac modulations are OFDM so they have their power rather evenly distributed "boxcar" style across the spectrum they occupy. Only b has a parabolic shape.


I am aware, and I am referring to those packets, thanks!

This is correct when seeing this on a true (frequency) spectrum analyzer. I'm referring to configurations of routers and the SSIDs on various channels, their strengths, etc. as seen by a mere cell phone with an app; but I totally understand what you are saying. Thanks for clarifying for those who may be reading!


This is a reason people tend to complain they have increased the bandwidth on their WiFi; and yet complain they still have slow downloads and/or still see 20MHz, as @psyborg noted:

There are many threads where people don't realize that.

so, what did you do to connect at 40MHz? sometimes when you apply settings the driver just reloads new setting and if you don't disconnect and reconnect to the network it stays at 20MHz.

1 Like

Good question. I did not connect to the SSID until I applied settings - as the AP was disabled prior.

This is simply a case of congested bands. I was demonstrating:

  • that a device will not operate in 40MHz mode, unless that portion of the band is in-fact clear.
  • If you want to verify the device in fact took your setting, you will have to use a "WiFi Analyzer App."

This has come up in a lot of threads: https://forum.openwrt.org/search?q=40%20mhz%20%40lleachii%20

and the almighty smarpthone OS can't show you that without installing an app? that is as annoying as a website trying to overcrowd itself with an ads then going for new buggy html standard and ask you accept dozen of their rules policies and cookies and also to update your browser before you can see that one information it threw up on search. or annoying as a gmail s new force to view mails. know what i did? just logged out of firefox and switched to classic view in good old opera 12. as for the bandwidth i'd check if luci actually set value to config, i noticed it is buggy in trunk too..

1 Like

Go to /etc/config/wireless on router and add line
option noscan '1'
on radio 2.4GHz save and look if you have any changes

@kiko80, that's all covered above...that's why there's a misconception.

It doesn't magically "make" 40 MHz just because you set it. The band must be clear.