Imagebuilder missing file for coreutils-8.32/coreutils-stdbuf

Hello Folks,

I've run into an issue building from Snapshot that began with r14423 and continued today with r14524 with a missing file fault in coreutils-stdbuf_8.32.

Searching through the buildroot structure I did find a sub-directory under:

/openwrt/build_dir/target-arm_cortex-a9+vfpv3-d16_musl_eabi/coreutils-8.32/ipkg-arm_cortex-a9_vfpv3-d16$

but unlike all the other modules in this directory, the coreutils-stdbuf CONTROL and bin subdirectories aren't populated.

I tried searching github openwrt/packages and https://git.openwrt.org/feed/ which returned nada (I'm still not very familiar with the site).

I made my first good build using imagebuilder from snapshot about 3 or 4 weeks ago to get by the DSA change on my platform, and refined my ./config into a working custom build I was quite happy with.

I did:

backup my ./config
make distclean
git clone
./scripts/feeds update -a
./scripts/feeds install -a

Restored my ./config
and took a quick look to make sure it looked right and did:
make

Now I'm googly-eyed and stumped. Can anyone give me some direction please?

if you're talking about the buildroot and not the image builder... you imported a seed/diffconfig file right?

below shows sliding it to the side and comparing the new basic parameters with what you imported...;

  • ./scripts/diffconfig > config.import1.diff

  • move your .config > config.import1

  • make menuconfig > select target+board ( not much extra stuff )

  • make V=s

  • ./scripts/diffconfig > config.vanilla1.diff

  • diff config.vanilla1.diff config.import1.diff

1 Like

Thank You :weary:

I don't know how many times I've read over and over the last few days:
https://openwrt.org/docs/guide-developer/build-system/use-buildsystem#configure_using_config_diff_file
it nagged at me a bit, but it just didn't click because my config had given me three or four good builds.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.