"image not found" error in sysupgrade

I'm attempting to force sysupgrade to revert my router back to an OEM firmware.
My dual partition router had oem firmware on part 1 and openwrt on part 2. I accidently flashed my first partition to openwrt as well. I've been in a headache trying to revert my first partition today.
I'm not too tech savy but this has been my attempt so far. (I'm on mac os)

copied oem firmware to /tmp
ssh in, cd to /tmp (success)
sysupgrade -n -F linksys.img
an error pops up saying image not found.

Any help with this? I have a short time frame to get this done and sent on its way. Any help would be appreciated.

You probably could have just used the LuCi GUI and be done within seconds on the mysterious device with your rollback.

educated guess for the mysterious device (probably you saved a few seconds by not mentioning the device name :wink: ):

1 Like

my bad. its a linksys wrt32x.

i tried to use the luci gui but the upgrade never finished. in advanced boot it currently says Linksys/Unknown (Compressed).

ill see if i can figure something out with the information provided

If LuCi extension lists it, the flashing should be successful (or you still have the vendor firmware in the other partition)
try turning the router off and on 3x via button or switch partition via the Luci boot partition menu, to enable the other partition for booting.

welp i think i’ve bricked my router. neither partition is working now. (tried the 3 switch on off method)

try it again, to switch the partition again

(neither a sysupgrade with „image not found“ result nor the switch of partition would brick it)

after a few more attempts of the switch method i was able to boot up the second partition (i just flashed from) in advanced boot it still says the first partition is linksys/unknown (compressed).

i’m so confused. i thought i just did a successful sysupgrade to the first partition. after following your advice it went through and the connection dropped but the first partition is still not working

Current OpenWrt version, have you done a change of kernel size by flashing a factory OpenWrt version where the size was increased.

only thing i’ve done is from the second partition (openwrt) i flashed openwrt again (in attempt to install a clean image) and ended up overriding the 1st partition (linksys wrt) via LuCI. i got back to the second partition and attempted to flash the linksys wrt back on the first partition and ended up where i am now.

  • from the current working image, flash 19.07 factory image and boot from that 19.07
  • flash 19.07 factory image again and boot from that
  • then flash the linksys image

(18.06 or 19.07 will do)

in attempt to fix this, i followed the wrt32x ‘return to stock firmware’. Luci isn’t an option for it says ‘due to missing/incompatible metadata in OEM images, sysupgrade must be forced via the command line’

so i attempted a sysupgrade via ssh. ssh in, cd to tmp, put in the correct command, it said it upgraded and the connection closed but nothing happened. first partition still states linksys/unknown (compressed)

i will attempt. thank you

Before 22.03 existed, I was able to go back to stock via LuCi, before I sold mine.
(I avoid recommending 21.02 for Linksys WRT)

Not sure about the success factor of the newer wiki description, I had never used that

so to confirm. i have flashed 19.07 twice on the second partition, now flash linksys wrt via luci?

that was the longest 3 hours of my life i love you thank you :heart:

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.