I'm trying to set up 22.03.5 on my raspberry pi

I'm trying to set up 22.03.5 on my raspberry pi.
I installed a usb to eth for another eth port (eth1).

I'm having a few problems. :frowning:

root@OpenWrt-router:~# uname -a
Linux OpenWrt-router 5.10.176 #0 SMP Thu Apr 27 20:28:15 2023 aarch64 GNU/Linux

I'm going to disable the wireless interface, the spam to the system log is annoying.

root@OpenWrt-router:~# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         OpenWrt-router.         UG    0      0        0 wlan0    *      UH    0      0        0 pppoe-nexicomfi     *        U     0      0        0 br-lan     *        U     0      0        0 wlan0

Should the Iface for the default route be the pppoe-...?

It seems I am connecting but the gui is not updating.
I suspect I get random disconnects due to "daemon.warn pppd[2587]: Timeout waiting for PADO packets".

I get tons of

daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan) e0:4f:43:79:e6:01
daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan)
daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan)
daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan)

despite checking "suppress logging of the routine operation for the DHCP protocol":

Why is the wlan in the WAN zone? It has the same IP range as the Pi router, which will cause conflicts if it is indeed connected to another router.


I ended up reinstalling from scratch and it works.

The builtin wifi was setup as a DHCP client on the existing network so I could install the driver for the usb->eth adapter but I disabled it after.

1 Like