IKEv2 DNS Leak

Hello, I apologize in advance for my English. I have been using the IKEv2 vpn protocol for 2 weeks now and everything suits me except one. When I start an IKEv2 tunnel on my router, I have a DNS connection (using DNS from the ISP). I already tried to set the dns of my vpn provider but unsuccessfully, I used this instruction https://openwrt.org/docs/guide-user/services/vpn/strongswan/roadwarrior). I am hope for your help.

P.S I am using ProtonVPN

Have you read this?
There is a DNS updater script.

1 Like

Yes, I've seen that before. The problem is that this is a setting for OpenVPN, and I have IKEv2. But in that setting there is a script to activate the DNS of my VPN provider. Can anyone rephrase this script for IKEv2?

Hi, thanks a lot @pavelgl for pointing out the problem, I found a solution :). The problem was in "/etc/strongswan.conf", since I accidentally set "install_routes = no" before, so the "ip route show table 220" command did not work. After I removed this "install_routes = no" parameter everything worked, and now I have DNS from ProtonVPN;). Thank you very much!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.